Missing print filter Brother DCP-J562DW

After a long while I try Enos again, but I don’t get the printer to work. I am using XFCE, in case it relates to that. The printer I use is Brother DCP-J562DW. I installed brother-dcpj562dw from the aur.

I followed the instructions on the Discovery print page on the website, but what I do I keep getting Missing print filter. How can I solve this ?

Did you install the nss-mdns package, start avahi-daemon.service, and edit the hosts line in /etc/nsswitch.conf? It is described here: https://wiki.archlinux.org/title/Avahi#Hostname_resolution

Those steps are not explicitly described in the Discovery wiki page, but that ArchWiki page is linked. At the bottom of the Discover wiki page it mentions that those extra steps may be needed in the case of a Brother printer.

@MiVo , I tried to reproduce the problem focusing to ppd file (as much I can without the Brother printer).
During XFCE install selected cups support. Installed brother-dcpj562dw-cups-bin from AUR. Selected Manage Printing and added by providing ppd at the bottom of the the screen:


I tried all this, but no luck sofar, still the missing print filter. I also saw this message:

File “/usr/lib/cups/filter/brother_lpdwrapper_dcpj562dw” not available: No such file or directory

Do you have a directory /opt/brother/Printers/? For a different Brother printer, the suggestion which worked for me is to link the filter file there (/opt/brother/Printers/dcpj562dw/cupswrapper/brother_lpdwrapper_dcpj562dw by analogy, but the exact file structure could be slightly different) to the place CUPS expects it (apparently /usr/lib/cups/filter/brother_lpdwrapper_dcpj562dw) and restart CUPS.
Source: https://aur.archlinux.org/packages/brother-hll8360cdw-cups-bin#comment-796099

I did all the above, but still no luck.

@MiVo Please ignore if it’s useless or does not make sense.

cd /opt/brother/Printers/dcpj562dw/cupswrapper
sudo ./cupswrapperdcpj562dw

although it says

ERROR : Brother LPD filter is not installed.
lpadmin -p DCPJ562DW -E -v usb:/dev/usb/lp0 -P /usr/share/cups/model/Brother/brother_dcpj562dw_printer_en.ppd
lpadmin: Printer drivers are deprecated and will stop working in a future version of CUPS.

but when I print a test page there is no error message and item/job is in the queue
"Waiting for printer to become available."

First, is this a network printer or connected via USB cable?

If it is a network printer, have you set a static IP address using the little LCD screen on the printer itself ?

For a network printer, follow the instructions i this post


Well, the error is gone now, but then nothing happens, not even "Waiting for printer to become available." .

And it is usb connected .

1 Like

After installing the dnf package-manager for Arch Linux (sudo pacman -Syu dnf), I downloaded the driver-packages (Linux RPM) from the offical Brother website, and strictly followed the on-site instructions there, like…

sudo dnf install <packagename> (potentially more than once for multi-function printers coming with more than one driver-package)

And …badoom(!) the drivers work (for a different Brother printer model, here)… :wink:


1 Like

I tried that with dnf, but when I want to install I am getting something like “Unable to detect release version”, and conflicting requests. And some lines in Dutch language.

Kan releaseversie niet detecteren (gebruik ‘–releasever’ om vrijgaveversie te specificeren)
Probleem: tegenstrijdige verzoeken

  • niets biedt /bin/sh welke nodig is voor dcpj562dwlpr-1.0.0-0.i386
  • niets biedt libc.so.6 welke nodig is voor dcpj562dwlpr-1.0.0-0.i386
  • niets biedt libc.so.6(GLIBC_2.0) welke nodig is voor dcpj562dwlpr-1.0.0-0.i386
  • niets biedt libc.so.6(GLIBC_2.1) welke nodig is voor dcpj562dwlpr-1.0.0-0.i386
  • niets biedt libc.so.6(GLIBC_2.3) welke nodig is voor dcpj562dwlpr-1.0.0-0.i386
  • niets biedt libm.so.6 welke nodig is voor dcpj562dwlpr-1.0.0-0.i386
  • niets biedt libm.so.6(GLIBC_2.0) welke nodig is voor dcpj562dwlpr-1.0.0-0.i386
    (probeer ‘–skip-broken’ toe te voegen om niet-installeerbare pakketten over te slaan)

sudo pacman -S cups-filters cups

cups-filters and cups are already installed.

actually, I’m thinking its the aur package, so if it was me, i’d remove that one and just install the one labelled: brother-dcpj562dw, that’s the driver, and the cups wrapper package is just that, the cups wrapper.


sudo dnf install <packagename> --skip-broken

I wonder, how you got onto that Dutch Brother website… the one I linked above is in English. Also, I would try to download English (not Dutch translated) drivers. :wink:

No, I mean I am using Enos in Dutch language.

I added --skip-broken, but then I get this:

Kan releaseversie niet detecteren (gebruik ‘–releasever’ om vrijgaveversie te specificeren)
Can not load RPM file: dcpj562dwlpr-1.0.0-0.i386.rpm.

Ok. It wants to install some i386 packages, although you are probably on a X86_64 system. Doesn’t matter, they still work here. You may have to install some i386 dependency for cups.

You find the release-versie (1.0.0-0) on the page from your download:

Depending on what you chose to download and install.

It is why I said, “explicitly follow the instructions” given on the Brother website.

So, for the printer driver, it should be:

sudo dnf install <packagename> --releasever 1.0.0-0
Possibly having to append --skip-broken to the command-line. :wink:

I’m lost. The printer has WLAN hasn’t it? Remove the existing brother driver and
yay -S brother-dcpj562dw
It automatically appears among printers if OpenPrinting CUPS 2.4.2 is up
I’d like to know what do you see in your browser finally.

The question-mark certainly doesn’t belong to that URL you posted last.

He already tried the method you propose, as mentioned by him further up above.

May be, he didn’t do
sudo systemctl enable cups.service ?

Did or didn’t you, @MiVo ?