Missing grub2-theme-endeavouros

Hi,
Updating my system I get

Missing AUR Packages:  grub2-theme-endeavouros

I understand it is installed on my laptop but it is no longer in repos (i.e. not required anymore?)

So, I wonder if I should

yay -Rc grub2-theme-endeavouros

Is it OK to uninstall it?

2 Likes

Correct.

Yes. You may want to check /etc/default/grub and disable it there first if you have it enabled.

4 Likes

Searched for grub2-theme-endeavouros, it is not there.

OK. So I can just proceed and uninstall it.

But to learn more, assuming it was there in the file would just uninsatlling be enough? or it will be “calling” something that is not there and cause Grub issues?

Just curious, why it was removed?

1 Like

You should look at the line GRUB_THEME= and ensure it is commented out.

If you change the file, run grub-mkconfig

3 Likes

My /etc/default/grub shows GRUB_THEME=/boot/grub/themes/EndeavourOS/theme.txt after this package was removed. The only theme I see left is starfield.

Should be changing /etc/default/grub to starfield?

1 Like

you can remove the line completely too or if you want use another theme indeed its your grub :wink:

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/boot/grub/livewall.png"
#GRUB_THEME="/path/to/gfxtheme"

We do currently use the Background option where simply only a background image is set.

1 Like

yay -S update-grub
and
sudo update-grub

1 Like

Sounds interesting. I will try.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
GRUB_BACKGROUND="/boot/grub/coralsoceanunderwater.png"
#GRUB_THEME="/path/to/gfxtheme"
#GRUB_THEME=/boot/grub/themes/EndeavourOS/theme.txt

Updated system and Grub with the hook I previously did.
Rebooting.
Rebooted! Amazing! Done!
Thanks @joekamprad and @rpaloha (it needed to update Grub to work)

1 Like

Personally I don’t see any reason to install a package from AUR (Simple wrapper around grub-mkconfig) for updating grub.

If

sudo grub-mkconfig -o /boot/grub/grub.cfg

is too much to type:

alias update-grub=‘sudo grub-mkconfig -o /boot/grub/grub.cfg’

or whatever you like.

Mine is grup :wink:

5 Likes

The point is to avoid missing/forgetting/… not focusing to do it in case needed I just made a hook to update and do all the stuff automatically without the need of my intervention. (I can be tired/not focusing/… and restart system withut doing the required stuff)
Since I did it, it has been a month now and I forgot completely about the Grub issues.

The package from AUR is not a hook like yours for automating the grub update.

It is as it says: Simple wrapper around grub-mkconfig

Therefore, I see no point in installing an extra package to do what you basically can achieve yourself with aliases.

3 Likes

Sorry, I am not sure I follow.
You say there is a package in AUR that does the Grub update. What is this package (it is wrapper I understand). Does it run automatically when needed?
What is the difference between it and the hook?

EDIT:
I personally don’t like having any software installed unless needed. This is one reason I loved EndeavourOS.

1 Like

No.

1 Like

So, for me, just my point of view, there is no point for installing it.
The hook is much better as it runs automatically when needed.

Exactly!

:slightly_smiling_face:

1 Like

This just happened to me. I uninstalled it and i disabled it in /etc/default/grub. Then it only booted to the firmware. I tried to figure out how to fix this but wasn’t successful. I didn’t understand why it was reporting this as coming from the AUR? I thought these files were isn the EOS repo. Anyway i could boot to Windows by using the f8 key but my grub was pooched and boots into firmware only. I tried to reinstall grub and update it but it was on btrfs and wasn’t co-operating. I just ended up reinstalling instead of spending all my time trying to understand why this happened. I just didn’t have time for it. I’m not one to worry about saving stuff so reinstalling takes about 4 mins. Just don’t know why this happened now since i thought i was past this grub issue long time ago.

It isn’t. It is telling you it is missing from AUR. All that means is that the package isn’t in the either the repos or AUR.

Did you run grub-mkconfig after that?

Yes i did and it would only boot to firmware.

1 Like

Interesting. Grub is a mystery sometimes.