Missing Desktop Effects

[alienprober@TheMothership ~]$ yay -Q | grep -i nvidia
nvidia-installer-db 2.4.7-1
nvidia-installer-dkms 3.3.7-1
nvidia-settings 450.66-1
nvidia-utils 450.66-1

I’ve attempted to launch nVidia settings and it loks to be attempting to launch and then just doesn’t.

[alienprober@TheMothership ~]$ nvidia-settings

ERROR: NVIDIA driver is not loaded


ERROR: Unable to load info from any available system

I thought SbK had a spin of Plasma that uses Compiz. Apparently not. There is a spin of Mate and XFCE though.

EDIT: According to Wikipedia, Compiz can be used with Plasma.

Hmmm…Normally the nouveau driver is blacklisted during installation of the proprietary driver. I wonder if that didn’t happen in your case. Can you take a look in /etc/modprobe.d/ and /usr/lib/modprobe.d/ to see if there’s anything for Nvidia in that folder? Also wonder if adding the nomodeset option to your Grub menu will help.

I was wondering about that from the wiki, but was hesitant cause the only things I ever do with Grub are change how long the OS selection screen shows and make it show if I need to. I’ll check those files now.

I’d suggest adding it to the startup options in Grub at boot time to test for a single boot. If it works, then add it permanently.

OK first folder nothing in it at all, second folder the below is all.

bluetooth-usb.conf
nvdimm-security.conf
r8168.conf
systemd.conf

OK do you have the exact line I need to add?

That might be the blocker. I’m not at my desktop atm, so I can’t check my own setup. Let’s try adding module_blacklist=nouveau to grub at boot time as a quick test.

OK let me do a reboot before i add that cause I just installed Timeshift, Timeshift-autosnap, and Grub-btrsf. I just want to make sure the later shows up as it should.

No love there. was worth a shot.

That’s unfortunate. I’ll check my system and get back to you when I’m able (unless someone else more knowledgeable can chime in).

1 Like

You don’t appear to have the nvidia drivers installed.

That would definitely explain why it’s not blacklisted :face_with_hand_over_mouth: lol

This time I just launched pamac and searched nVidia. Figured if they broike the system I’d just rerun the OS, but…

[alienprober@TheMothership ~]$ inxi -F
System:
  Host: TheMothership Kernel: 5.8.7-arch1-1 x86_64 bits: 64 
  Desktop: KDE Plasma 5.19.5 Distro: EndeavourOS 
Machine:
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx 
  serial: <superuser/root required> UEFI: American Megatrends v: 3103 
  date: 06/17/2020 
CPU:
  Info: Quad Core model: AMD Ryzen 3 3200G with Radeon Vega Graphics bits: 64 
  type: MCP L2 cache: 2048 KiB 
  Speed: 1396 MHz min/max: 1400/3600 MHz Core speeds (MHz): 1: 1389 2: 1335 3: 1391 
  4: 1880 
Graphics:
  Device-1: NVIDIA TU116 [GeForce GTX 1650 SUPER] driver: nvidia v: 450.66 
  Display: x11 server: X.Org 1.20.9 driver: nvidia unloaded: fbdev,modesetting,vesa 
  resolution: 2560x1080~60Hz 
  OpenGL: renderer: GeForce GTX 1650 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 450.66 
Audio:
  Device-1: NVIDIA TU116 High Definition Audio driver: snd_hda_intel 
  Device-2: AMD Family 17h HD Audio driver: snd_hda_intel 
  Sound Server: ALSA v: k5.8.7-arch1-1 
Network:
  Device-1: Intel I211 Gigabit Network driver: igb 
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: a8:5e:45:55:75:ae 
Drives:
  Local Storage: total: 9.21 TiB used: 77.73 GiB (0.8%) 
  ID-1: /dev/nvme0n1 model: Viper M.2 VPN100 size: 238.47 GiB 
  ID-2: /dev/sda vendor: Samsung model: SSD 850 EVO 120GB size: 111.79 GiB 
  ID-3: /dev/sdb vendor: Western Digital model: WD10EARS-00Y5B1 size: 931.51 GiB 
  ID-4: /dev/sdc vendor: Samsung model: ST3000DM001-1E6166 size: 2.73 TiB 
  ID-5: /dev/sdd type: USB vendor: Samsung model: Seagate Expansion size: 1.82 TiB 
  ID-6: /dev/sde type: USB vendor: MediaMax model: WL3000GSA6454 size: 3.41 TiB 
Partition:
  ID-1: / size: 111.49 GiB used: 12.45 GiB (11.2%) fs: btrfs dev: /dev/sda1 
  ID-2: /home size: 111.49 GiB used: 12.45 GiB (11.2%) fs: btrfs dev: /dev/sda1 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 43.6 C mobo: N/A gpu: nvidia temp: 40 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
Info:
  Processes: 303 Uptime: 3m Memory: 7.76 GiB used: 2.04 GiB (26.3%) Shell: Bash 
  inxi: 3.1.06

Thanks guys for all the help and suggestions, much appreciated. Before marking this solved is there anything else I should check? Thanks again.

EDIT:

Almost forgot to test the effects. All I can say is they are working PERFECTLY.

1 Like

On EndeavourOS Wobbly Windows & Magic Lamp exist for those who where inquiring. I happen to use them.

1 Like

It was a matter of getting the nVidia drives up and running. Like I said the effects that I was missing are working now.

2 Likes

Great to hear you got it working! Please mark as solved :slightly_smiling_face:

I’m revisiting this cause I’d like to find out how to check if I have the dkms driver, and if I don’t how I would switch to it. Thanks

An easy way to check if you’re have dkms installed is to run:

pacman -Qs dkms

You should get (at least) two entries, one is local/dkms for the system and an Nvidia one, something like local/nvidia-390xx-dkms.

You can then check the status of modules by running

dkms status

Open a new thread if you need help installing it.

2 Likes

OK thanks, much appreciated.

2 Likes