Low latency audio on Endeavour?


I’m just wondering - EndeavourOS uses Pipewire, right?
I mean, pacman -Qs lists pipewire packages so i assume it does.

Is there any specific way i need to set up pipewire for low latency audio?

A bit of background:
I installed EndeavourOS just to test if my nvme is failin. I was on Manjaro til now, and i was getting all sorts of I/O write errors, files (specifically kde files) changing owners and my user losing write privileges, and just generally weird behaviour… I kinda narrowed it down to KDE being weird, but then, when i tried to install the xfce version - it wouldn+t install a bootloader.

Then i downloaded EndeavourOS just to see if my nvme died. It installed no problem, so i’m not even sure it was an nvme problem after all.
So i’m here now… If it starts having the same I/O issues, then my nvme is bad. If not, i’ll keep using the OS.

Til then, i need to use my computer, so the first thing i need is low latency audio.
I used this guide to set it up, but i’m not sure Manjaro had pipewire. It had JACK and pulseaudio, and pulseaudio lagged on youtube videos until i set up Carla and pulseaudio-jack bridge and ran it through my audio interface.

As far as the adding user to the audio group, and adding the config parameters - that’s still the same right? Or does that differ?

And can pipewire play multiple sources at the same time without bridging? Cause the only way i could play youtube sound at the same time as me using JACK is with the pulseaudio-bridge.

Any info would be appreciated, or some links to some documentation i could read up that covers this.
Or maybe some helpful packages i need to install?
Basically, does EndeavourOS handle audio different than Manjaro (cause i don’t think manjaro uses Pipewire) is what i’m asking, and how to set up low latency audio for recording.


(Fingers crossed my nvme isn’t dead!)

1 Like

Welcome @vepar
Maybe do some reading on the Arch wiki. Pipewire is standard on EndeavourOS. Not an expert on this but maybe this helps with some reading then if you have some questions wanting to do something or something isn’t working you could post some questions.



Thanks for the link!
So it IS Pipewire, ok, that’s confirmed then. :slight_smile:
At least i know the direction i need to search now. Cause i wasn’t sure, i heard some distros “kind of” implement Pipewire, but it’s really just JACK and Pulseaudio, so i had to ask.
I know Pipewire still uses those, but there might be some specific configuration needed, hence the thread.

You can see it here with this command

[ricklinux@eos-plasma ~]$ inxi -Aa
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: Gigabyte driver: snd_hda_intel v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 2d:00.1
    chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 2f:00.4 chip-ID: 1022:1487 class-ID: 0403
  Sound API: ALSA v: k6.1.11-arch1-1 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.65 running: yes
[ricklinux@eos-plasma ~]$ 
1 Like

Ah, that’s helpful, thank you!

Yeah, i have similar, just the added external audio interface.

  Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
    v: kernel bus-ID: 3-2.2:4 pcie: chip-ID: 1235:8200 gen: 3 speed: 8 GT/s
    class-ID: 0103 lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 05:00.1
    chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD Family 17h/19h HD Audio vendor: ASRock driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
    speed: 16 GT/s bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Device-3: Focusrite-Novation Scarlett 2i4 USB type: USB
    driver: snd-usb-audio
  Sound API: ALSA v: k6.1.11-arch1-1 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.65 running: yes

TIme to read up on PipeWire then. :slight_smile:

Weird that it doesn’t list JACK here, but when i open Reaper (the DAW i’m using), i have only JACK, PulseAudio and ALSA options. But PipeWire wouldn’t be an option from what i understand, it’s just how audio is handled i guess, mixes all sources together?

Anyway, thanks for the link, i’ll read up on how to use PipeWire.

And well, hopefully don’t find out my nvme is dying and it was a completely separate problem before.
But Brave and firefox tabs keep crashing, it doesn’t look good lol, might even be memory related.
Oh well…

There are more than one Topics on the forum discussing low latency audio.
This is just one

and there are others that can be found with a search.


1 Like

Thank, but my question was not about low latency kernels, i don’t want to use that. :slight_smile:
Never needed to anyway, i don’t do anything that big that would require a low latency kernel.
Just home audio production, which so far, worked just fine on a normal kernel.

I did the search, but didn’t find any threads about where to start, only threads about problems that occur and need help, not how to set up the system for audio production.
@ricklinux gave me a great source for start, i’ll read up on that, and see if i can set it up myself the way i need it. From what i can gather, it’s a bit different than on Manjaro, so, i needed something to guide me in the right direction.


EndeavourOS uses the kernel argument nvme_load=yes Manjaro doesn’t

1 Like

Forgive the follow up but, what does that argument do exactly?

All i found was this by googling: https://man.cx/nvd(4)
But it doesn’t explain exactly what the difference is by including that kernel argument vs not including it.
Do you think my nvme is fine and it was just missing that argument?

As for the stability - i’m switching to xfce, kde has started to exhibit the same behaviour as it did on Manjaro. No login screen just now for no reason.

Anyway, haven’t yet started the Pipewire journey, i first have to make sure the system doesn’t do this, like it did now, that i can’t login.

I don’t understand this? I’ve been using kde since almost the beginning and I’ve never had these issues that users talk about. But then again i always reboot when i think it’s necessary and when i have updates related to kde that don’t necessarily require a reboot I always log out and back in. Kde for me is flawless.

This may not be entirely correct - please correct me … where needed.

As I recall it - some Intel NVMe devices utililze a double SSD which the controller manages internally.

The devices has the vmd acronym attached to them.

They consist of a very fast part used for the system and a slower storage part. There has been speculation on why and as vendors has been caught redhanded with highend devices where first adopters and testers has gotten really highend devices - when they reach the masses - it was impossible to achieve the same numbers as the first adopters and testers. It was then discovered that the following batches were using cheaper - not so fast storage.

The why could be explained as a production cost issue - faster chips comes with a price tag.

I got carried away - back to the question on nvme_load

The vmd driver is not loaded automagically and I think the load_nvme=yes and the vmd in mkinitcpio.conf is making those vmd devices functional when using a linux kernel.

When you say your system begin the same behavior as when you used Manjaro - then I think it is distribution independent and caused by some specific hardware within your system.

I started using KDE just to verify that Plasma is that bad. I was very biased because my initial contact with KDE - which is very dated - Suse Linux Open Enterprise Server - 10 DVD’s with software and 5 books :grin: - but KDE was nothing to be exited about.

I have been using Plasma since sometime late 2021 - and I have never had the issues I have been reading about - nothing, nada, zilch, zip - I even ran it on Nvidia for a short while - until I got my hands on a WX7100 Pro card - now my system is fullblown AMD - no issues to be upset about.

On Manjaro I have noted that Plasma shell tend to restart once in a while - usually trigger by clicking an item on the panel - it flashes and restarts only the shell - my apps etc is untouched.

My ws is now Arch installed using archinstall and the Plasma recipe.

It works fantastic.

1 Like

I’ve run both Arch Kde and EndeavourOS Kde and i find little difference. The Arch install may use slightly less ram but i have 32 GB so i don’t care. I’m not running a computer that has 4 GB or less or is dated. I am also AMD all the way!

1 Like

I don’t understand it either… On manjaro, KDE and KDE alone has exhibited behaviour such as randomly losing ownership of some KDE files related to login screens (i had to chown them for them to become writeable again), randomly changing the wallpaper back to default, upon logging in, an “unlock” button would sometimes apear after entering the password (correctly), and sometimes not, and when it did, it was 50/50 chance it was working and would let me into the system, frequent freezes of the whole desktop environment, freezes when changing activities, activities losing all icons i assigned to them, as well as wallpapers…

And i love the concept, it looks amazing, is super comfortable to use, edit and set up (i LOVE activities and how you can set different energy options for each one), but i can’t have a computer that i never know if it’ll randomly freeze or won’t let me in the desktop after logging in…

I want to use KDE, and i like it, but i can’t deal with that. I need my computer stable first, if KDE is the reason it’s unstable, then i can’t use it.
And to be fair - if something hardware related on my system is damaged, it might account for the instability, but then again - why was it always KDE related? Nothing else ever broke, except firefox tabs crashing sometimes…

I installed XFCE now, if this also has the same issues, then it’s definitely the hardware. If not, then idk, probably KDE or how it interacts with some of my hardware maybe, no idea.
I honestly don’t know why any of this is happening…

I see, thank you, i think i understand that now. At least better than i did. :smiley:
Hopefully that makes the system more stable IF the nvme was behaving badly due to not loading that argument.

Yes, that’s my guess as well, but then again - Manjaro, under the hood, never really did anything bad. Everything strictly kernel and manjaro related worked. All errors in some way pointed back to KDE, and i have no explanation as to why. Even when btrfs caught some i/o error, it was always some file related to KDE in some way. And KDE was again the one exhibiting strange behaviour here.
So while i’m not excluding hardware faliure - why would it only affect KDE?
I’m testing xfce now, let’s see how this behaves, if it starts to corrupt as well. If yes, then it’s definitely something with my hardware.

I also have 32GB so running KDE shouldn’t be an issue on that front at least. It’s also decently fast(ish) ram at 3200. And i’m also on AMD, so there shouldn’t be any weird Nvidia driver issues as AMD’s are better. I AM howerver running an integrated GPU, so maybe KDE doesn’t like that much? Cause it’s sharing the memory with the rest of the system, maybe that’s where the conflicts are occuring?

I’m out of ideas at this point really. KDE has everything i need and want, but i just can’t make it stable. :frowning:

Also apologies, this went a bit off topic lol, but i’m glad we can have the conversation, any idea not considered helps me troublehsoot this, so i appreciate it.

My bias against AMD was probably bigger than against KDE.

AMD once was memorable for they bad cpus - and how that cpu would interact with windows and the network card the most obscure not possible to troubleshoot way.

Have you tried booting a memtest ISO?

1 Like

I ran memtest for about 15 hours, it did 6 passes on 32 gb and found no errors.

However, this just happened…

Its the disk right?
The nvme is failing?

I use btrfs, so its wither btrfs (unlikely) or hardware error on the motherboard or nvme.

If it happens just like that - working one moment - throws error the next - then you are having a hardware problem.

What problem - I have no idea.

My first thought was RAM - but you had that thought as well.

I think that my habit when buying hardwaer - I don’t buy what I call consumer hardware.

The hardware every shopowner sell $10 below competition.

My graphic card is WX7100 Pro which saw market first time around 2015 - my workstation is Lenovo P620 which hit the market 18 month ago.

For the nvme_load I had several search hits on arch


Perhaps the comment is applicable for your system - albeit no deeper explanation :slight_smile:


I’ll test each ram individually again with memtest.
Just now, it gave me i/o errors when trying to install balena etcher from aur…
It looks like the nvme is failing…

Have you run a long smart test on the drive?

I did the smart test, it reported no errors.
Which is why this entire thing is so weird…

What is the full output of your hardware? Post the url

inxi -Faz | eso-sendlog


sudo fdisk -l