Live USB boot hangs on "Triggering uevents..."

While trying to install EndeavourOS (EndeavourOS_Artemis_nova_22_9.iso) on a newly assembled desktop via a live USB (made with Ventoy), it hangs/gets stuck/freezes after “triggering uevents”.

Some tweaking of the startup parameters (normal, grub2, removing modesets, etc.) I sometimes get the following error log:

Sometimes I get past the triggering uevents, but my monitor just remains black.

I’ve tried:

but to no avail. Installing Manjaro worked though.

Relevant specs: Intel i5 13600k, MSI GeForce RTX 3060 Ti Gaming Z TRIO 8G LHR.

Try creating the live usb with popsicle on manjaro. You can install popsicle from the AUR. Ventoy sometimes is problematic. Don’t know what else to tell you. That’s just my experience. You may still need the ibt=off parameter and then run the update grub command.

Edit: Otherwise if using Windows to create a live ISO i would use etcher.

Huh, Windows? What’s that?

PS Thanks, I’ll try the solution ASAP.

1 Like

I’m having the same issue. I’m trying to install on a new build using a new AMD 7900 XT GPU, so it needs the latest firmware files. I know I’ll have to build a custom ISO for that, but I’m unsure where to put the build linux-firmware files

Have you tried the just recently released ISO?

Yeah, I did that, but since the necessary firmware are still in testing it hangs trying to load the relevant pieces there. I can try downloading again now and re-imaging to see if that works.

1 Like

Have a look at the Advanced section of

and see if you could include the latest firmware package into the iso.

That’s what I’m working on, but I’m currently trying to figure out how to add the testing repo to the pacman config for building the iso, so any help there would be much appreciated.

My understanding of the following:

To install locally builded packages on ISO put the packages inside directory:


Packages will get installed and directory will be cleaned up after that.

is that one only needs to put the “already built package” in that directory (though I might be mistaken).

It can be downloaded from the mirror:

I think I got it to work and to boot with that firmware package, however now XFCE fails to load.

I’ve been working with a few others trying to get their 7900 XT working. I have a newly created ISO if you would like to try it. Let me know and i’ll post a link.

1 Like

Yes I would like to give it a try

So, I was able to get Endeavour installed with the help of ricklinux:

After that I did have a stuttering/flickering issue in Gnome, which I was able to fix using this:

So, I was able to fix the flickering by using Mesa-git, I specifically used the package bin from an unofficial repo, and had to use the note from:

I followed this specific thread on the arch forums:

I hope this might help other people. I still have to test out some games, but so far so good.

1 Like

Are you having any issues with flickering or cursor?

SORRY!!! - I did’nt see that the post was not for me: again, SORRY

No, I have issue with I can’t get desktop… terminal works fine… just that on live iso, I can’t go any futher then tty2 and been greeting with login and password, and since there is NONE … I can’t go further.

So if SOMEONE could make me a iso, where I can REACH the terminal, with user/pass … I could then make the errorlog and send it to you.

Or tell me: How can I (EASY) make endeavourOS iso, WITH the possiblity to reach terminal via user/pass
and then send a error log.

Dr Pain aka Per

Please, Can I have that iso ? maybe it even works for me ??? even that I got that darn intel arc 770

Dr. Pain aka Per

I’m also interested about the Iso since I used an Rx 7900 xtx. But I would be interested to know what an Intel ARC GPU does under Linux. Could you give us a feedback once you have installed it ?

Okay I’ll pm you.

@ricklinux things are working great in gmome wayland. I haven’t tried an x11 session.

1 Like

I’m glad it’s working. Others here are having flickering issues or issues with dual monitors going to black screen. I’m trying to understand why?