Live medium fails to start

I’ve discovered EndeavourOS recently, donwloaded the ISO and flashed with the dd command as recommended, but when I boot my USB stick this happens

Does anyone have an idea of what’s causing this?

Looks like something wrong with it.

Bad download, bad flash or failing usb drive perhaps.

I would try downloading it again if you can.

1 Like

I’ve downloaded the ISO via browser, I’ll try again with torrent

I don’t think it’s a problem with flashing since I’ve tried more flashing methods since and all of them give this same error, although you’re right it could be a problem with the USB since I haven’t used it for a while


One way to check would be to try another distro’s installer image, just to make sure.

Also, I can recommend Ventoy as a very easy way to avoid having to dd the entire drive every time.


I tried to use the Arch Linux ISO and it didn’t boot instead of giving me an error, huh

I haven’t tried Ventoy yet, I’ll check it out, thanks!

Ventoy really seems like a neat little suggestion. Thanks.

Seems a bad dd copy. Don’t know what you used to create the usb. The two best software I’ve used is Rufus and Etcher. In rufus just leave everything as is and when asked use dd to create the usb. Both programs don’t edit the files.

Assuming the USB drive is OK, there are other reasons for failure.

For one, Secure Boot needs to be disabled. And there may be more (related) BIOS/firmware settings that may need changing.

I would strongly advise against using Etcher. There are countless better alternatives.

Especially this post, this post is excellent: :rofl:

1 Like

Get into your BIOS/ UEFI and disable Secure Boot and enable ACPI. If you’ve done this then I’ve nothing to add. ACPI is important. It always worked for me. I suppose it it is motherboard specific.

It depends if we are talking about Windows or Linux. On Windows, I think Etcher is a pretty good choice. They have an imperfect(but not horrific) privacy history and the software is heavier than it needs to be. However, isn’t that true of a most Windows software? It also works really well and requires no configuration for almost any Linux distro.

On Linux, I completely agree. There are lots of alternatives which are more trustworthy, lighter and still do a great job in a simple way.


I was only talking about Linux. When you’re running windoze, you may as well indulge in all sorts of spyware as well as inefficient JavaScript based desktop apps – it can’t be worse than what your OS is already doing… :smiley:

1 Like

Personally i’d still use Rufus as more powerfull tool not implicated in spyware (it’s still writing my .iso…so), but whatever :upside_down_face:

1 Like

I’ve been in windows and still use it at work. I’ve used some scripts I built to stop calling home also debloats it and use a free open source firewall (better than windows firewall) block the rest. So it’s not that bad.

It is a ~280 MiB program that burns ISO images to a USB drive. It contains the entire Chromium browser compiled in it (literally millions of lines of code, just to draw a button that says “burn” or whatever). Even if it did not connect to the internet, it would be bad.

Not that it is going to make things better for you but I think he was referring to Windows with that statement. :cowboy_hat_face:


I personally like etcher on Windows and have never had an issue with ISO creation on a usb using it. On the other hand i don’t like Rufus. Just my own personal preference and i have used etcher for quite some time on Linux until i switched to popsicle.

Was talking about windows not Linux :man_facepalming:

That somehow makes it even worse :rofl:

I’ve got Etcher on one of my old MacBooks. It doesn’t “write home” in any way due to using LittleSnitch to block it but there is a lot of crap on there that would like to. That machine is not a daily driver anyway and rarely gets used.