Lenovo 3000 N500 won't boot

Having laptop: Lenovo 3000 N500, type 4233-5MG.
EndeavourOS wont boot on it.
Found one similar discussion, but none helped.
Tried also https://discovery.endeavouros.com/intel-gpu/intel/2021/03/ parameters, didn’t help.
Took HDD out, installed EndeavourOS (XFCE, online installation) in another laptop and put then HDD back, still don’t boot.
Using latest current ISO endeavouros-2021.08.27-x86_64.iso

Tried as boot parameter:
…none helped…

Welcome @zeroconf
When you say it doesn’t boot on it? What happens? Does it boot on any other linux distro?

Edit: How old is this hardware? Does it have a Geforce 9300 Graphics? Might not be supported.

1 Like

It starts loading but quite soon goes to restart.

Hardware is ca 10 years old, but I guess Linux gives life for old hardware. Actually this laptop was in active use, but currently cannot be used.

Current forum didn’t allow me to upload TXT-files, so I had to convert them into PDF…

LXLE 18.04 (based on Ubuntu 18.04 LTS) will boot:
dmesg-lxle_18-04.pdf (53.4 KB)
inxi-lxle-1804.pdf (16.4 KB)

Also Linux Mint 20.2 (based on Ubuntu 20.04.2 LTS) did boot (XFCE, MATE, Cinnamon), here is example files from MATE desktop:
dmesg-linux-mint-20-02-mate.pdf (59.3 KB)
dmidecode-linux-mint-20-2.pdf (14.3 KB)
inxi-linux-mint-20-02-mate.pdf (16.1 KB)

Hi and welcome to EnOS’s forum @zeroconf!


I just was updating my previous post as booting, exporting, converting, saving, logging in to current forum, etc, took time :slight_smile: Please see my previous post. this means, that Ubuntu and its derivates can boot. I used Ventoy to prepare bootable USB-stick. Also tested such USB-sticks, that were directly bootable - in case of Endeavour OS and also other distros. Still Endeavour OS didn’t boot.

It is obvious, that some bugs exist, but still even newest Ubuntu LTS and its derivates can boot. We might dream of ideal world, but as we can see, hardware is not always ideal. Even then we would like to use such hardware to give new life to it.

Found one BIOS update, but it seems, that it is not meant for that hardware particularly.

EnOS’ ISO on Ventoy has been a hit and miss of what I have gathered being said around the forum. I haven’t tried it myself on Ventoy so I can’t speak to that by personal experience.
You might want to try another tool to make a bootable USB.

As you read on my post, then you see, that I already did that and it didn’t help either. So, it is easy to blame Ventoy, etc but at the same time Ubuntu and its derivates can boot either using Ventoy or directly, but Endeavour OS cannot :frowning:

As Ubuntu and its derivates are also free and open-source software, perhaps it is possible to look, why they can boot and Endeavour OS cannot. I guess it is allowed to use same approach to make booting possible.

Have you tried other Arch-based ISOs? Might be that the Kernel shipped with the latest EnOS’ ISO doesn’t support some piece of hardware on your system.

If my assumption is correct and seeing your hardware is about 10 years old, so perhaps looking into what other distros might support it in practice could be an ideal solution.

You might want to boot your machine up with Ubuntu/Mint and provide the output of

inxi -Fxxxaz

for forum members to have something to work on.

If you look my posts, then I have already two inxi, dmesg outputs from two different OSes exported and uploaded.

Sorry, I missed that. :man_facepalming:t6:

Have you tried Arch ISO or other Arch-based distros to see if they boot up?

I tried GParted Live and OPHcrack Live - these didn’t boot up. I have old versions of these, using far older kernel than these Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. It seems, that it is matter of certain parameters, some kind of compensation mechanism, that Ubuntu (possibly some other distros) have, but Endeavour OS does not have.

Tried Manjaro 21.1.2 KDE, XFCE, GNOME - didn’t boot up.

That’s why I ask if you have tried Arch or other Arch-based distros? Endeavour’s ISO is nothing but Arch with a DE and some customization.

Edit- Vi cross-posted :innocent:

From my own experience:

  • Ventoy works well with Ubuntu and its distros

  • Ventoy does not work well with Arch and distros

  • If using Windows to create. Rufus + DD mode always works for Arch, Arco, EOS etc

  • If using Arch to create then imagewriter always works for me

Ventoy would give me mount error with EOS. There will be always be Ventoy compatibility as mentioned in there with so many distros.

I would try adding iommu=off in the grub menu on boot.

Edit: I do see it’s 2008 i was guessing 2006 but should be fine. Just have to figure out why it’s not not loading at boot.

I used usbimagewriter to write ISO - is it bad? That imagewriter seemed a bit outdated. Actually I already used direct boot with Endeavour OS - didn’t work either.

Sorry, but iommu=off didn’t help - just tested.

Try using etcher to create the iso.