Lenovo 3000 N500 won't boot

Tried also System Rescue CD 8.0.4 (amd64), which is Arch-based, didn’t boot either (via Ventoy and also directly). Tried different boot options it has in its menu. So, can’t rescue that system :pensive:

I guess it is not a matter of which program to use to create bootable USB-stick. I can boot Ubuntu and its derivates either directly or via Ventoy. If you claim, that Etcher will solve the issue, I can give a try. Although Balena Etcher seems to be outdated in AUR… Seems, that etcher-bin is the one.

I’m not going to say that it’s going to solve the issue but i have never had an issue with etcher. I do a lot of testing and it never fails me.

imagewriter may look old but it works. I use it to create USB sticks for old Intel Core 2 Duo 2007 machines even.

If you have access to a Windows OS use Rufus and DD mode if you don’t have a working Arch OS to use.

I also use Etcher on MacOS to create bootable sticks sometimes on my friend’s machine when he wants to try distros.

No harm trying out all. But hopefully and luck one will work!

@zeroconf
Here is a link to the previous ISO to try just to see.

https://mirror.alpix.eu/endeavouros/iso/endeavouros-2021.04.17-x86_64.iso

Edit: Here the checksum also.
https://mirror.alpix.eu/endeavouros/iso/endeavouros-2021.04.17-x86_64.iso.sha512sum

Edit2: See if it boots on the previous ISO

I have Endeavour OS (KDE) in another machine. Tried Etcher - didn’t help either.

Tried it (endeavouros-2021.04.17-x86_64.iso), prepared USB-stick with imagewriter, still doesn’t work. Tried to experiment with different boot parameters in GRUB, couldn’t find working combination :frowning_face:
Then current forum doesn’t allow me to post links…

You could perhaps have a look at the boot parameters in Grub for Ubuntu and see if there is certain parameters there. However I doubt it.

Firstly I’ve checked Ubuntu boot parameters already, later also from kernel.org and tried some of them. It is like lottery to play. No matter, how hard I would like to use on that laptop Endeavour OS, I cannot do that. Laptop works well and would like to use it with Linux. As some distros are capable to boot, then Linux in general works, even newer kernels.

Well then, perhaps an ideal solution for a not so “ideal” a piece of hardware in practice would be to use a GNU/LInux system that actually work on that hardware.

Whatever you choose to do I wish you the best of luck!

This is not specific enough, at all. Look at the boot messages to determine at what point it fails.

These use kernel 5.4. The EndeavourOS installer uses a much newer kernel.

This leads me to believe that your laptop has an issue with the newest kernel version.

Building on the suggestion to try an older installer image version, you might try several older versions from here:

https://mirror.alpix.eu/endeavouros-iso/

Perhaps one of those will boot, and then the issue can be narrowed down that way.

I guess as Ubuntu and its derivates are capable to boot, then it should be possible to look into it, how it is solved there (Ubuntu is also free and open-source) and copy it to Endeavour OS too. I am not capable to do that. Therefore I kindly ask community to do that. Hopefully can Arch and its derivates catch Ubuntu in that area and also make it possible to boot on a little faulty hardware.

Impossible to look into boot messages as it goes quickly to restart and nothing left. I remind, that I am not capable of booting either using USB or hard drive. I could look into boot messages using Linux Mint, I posted in one of previous posts those messages.

Please read again:

1 Like

On Ubuntu it shows “qwerty Kernel”. :thinking:

Then perhaps it is worth to try to install older kernel, than to install older OS in whole. But seems, that newest LTS is the oldest kernel I can install in Endeavour OS or Arch in general. As soon as I want to update, also kernel will be updated to newest version. Certainly, I can ignore kernel update, if this is enough to keep Endeavour OS running. At first I have to find working kernel and see, whether it is possible to install it…

There is another option,

Many people continue to use kernel 5.4.

Well, it is easy to guess, that newer, in current case even newest kernel is guilty. I installed Linux Mint 20.2 XFCE (it is closely based on Ubuntu 20.04.2 LTS XFCE) onto that laptop for now, by default is 5.4 kernel used. Then I installed newest 5.14.6 kernel with Linux Mint 20.2 and still computer is booting.
When I checked (to see, what was booted):

cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-5.14.6-051406-generic root=UUID=<UUID> ro quiet splash

…where instead of <UUID> was actual UUID value.

For references (perhaps there is something useful to solve it in case of Endeavour OS):

Now the question is - sounds like kernel version isn’t the issue here. I try to make some output and update the current post soon…

EDIT:
Again, couldn’t upload *.txt files, had to convert them to PDF…
dmesg-linux-mint-20-2_kernel-5-14-6.pdf (59.3 KB)
inxi-linux-mint-20-2_kernel-5-14-6.pdf (17.5 KB)

Have you tried the following kernel parameters with when you boot on the EndeavourOS ISO?

nomodeset i915.modeset=0

Yes, tried nomodeset i915.modeset=0 and didn’t work: