Cannot boot on Asus Z590 Mobo with Intel i7-10700K

I was trying to install Endeavour OS on my newly built system, but the live installer booted to a blank screen.
This is a pretty known issue these days, and has to do with the Intel integrated graphics.
You can find more info on the below links.
https://bbs.archlinux.org/viewtopic.php?id=266690

https://forums.linuxmint.com/viewtopic.php?t=345452

I tried to install Ubuntu 20.04 LTS, and it has the same problem as well. Although, this has been fixed in 21.04, and I was able to install it without any errors.

Even though I have a working system now, I love Endeavour OS and would like to get it installed asap.

Thank you and keep up the great work!

From my understanding it’s bug with the integrated GPU Intel UHD 630. It would be easy to install using a dedicated GPU and bypass the integrated Graphics. Supposedly a fix is in the works.

This didn’t work?

GRUB_CMDLINE_LINUX_DEFAULT="i915.alpha_support=1" 

@ricklinux It wasn’t able to load the UI at all.
Booting from the install media, just flashes some error momentarily and the screen goes blank.

Is there any other way to set the Grub flag?

I’m not sure what you are asking? You can load the kernel parameter by pressing e when grub starts and add it in to boot with. Then it would have to be added permanent after installing.

Edit: That is if it works.

It didn’t work.
No change at all.

i915 enable_psr=0

could work or others mentioned here:

none of these flags work.
Still trying to get Endeavour working.
Feeling so alien with Ubuntu…

Have you tried different outputs? Like HDMI/DP1/DP2/et cetera?

Also MAYBE if it’s a grub bug you could try to update grub of the installer or install grub from Ubuntu 21.04 and then target your USB flash drive with desired parameters (those from the install ISO and check also the parameters of ubuntu 21.04 grub, maybe there is some flag that solves your issue)

The problem is that I am not able to boot into Endeavour live USB.
The culprit is the Intel i915 display driver.
But, Ubuntu 21.04 includes a fix for this, so I was able to install it.

MAYBE you can chroot into liveCD of Endeavouros from ubuntu and update the i915 driver (w/o Kernel&Headers)

(This might break your livecd iso tho)

If you have another PC you can probably install it from there with all the necessary drivers/configs for your current computer, update and then boot on your z590.
If not MAYBE you can install the system via Virtualbox/or another VM to your hard drive (or install in the virtual box image then clone it/write to your actual hard drive) with all the stuff that you need and then boot it.

I am sorry if I’ve created some confusion, those are some crazy hacks that I’ve though off to solve your issue. lol

EDIT : you might want to try the latest DevISO.
It should be the easiest solution

https://github.com/endeavouros-team/ISO/releases/tag/0-EndeavourOS-development-ISO-releases

endeavouros-devel-next-2021.06.20-x86_64.iso

Thanks a lot for your input.
I’ll better try the latest DevISO first :slightly_smiling_face:

I am not able to see the latest releases for some reason.

And, the ISO-Next repo does not have any releases.

Found it!
https://github.com/endeavouros-team/ISO/releases/download/0-EndeavourOS-development-ISO-releases/endeavouros-devel-next-2021.06.20-x86_64.iso

1 Like

@anemo
What does this show?

sudo dmesg | grep -i i915

@anemo
You may need to boot with i915.force_probe=4c8a as a kernel parameter.

Edit: Same issue?

https://www.phoronix.com/scan.php?page=article&item=intel-rkl-linux&num=2

Edit2: Could also be added to modprobe?

options i915 force_probe=4c8a

Edit3: Your graphics id may be different also?

1 Like

Running on Ubuntu

$ sudo dmesg | grep -i i915
[    6.455177] i915 0000:00:02.0: vgaarb: deactivate vga console
[    6.457282] i915 0000:00:02.0: vgaarb: changed VGA decodes: olddecodes=io+mem,decodes=io+mem:owns=io+mem
[    6.458410] i915 0000:00:02.0: [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
[    6.504867] mei_hdcp 0000:00:16.0-b638ab7e-94e2-4ea2-a552-d1c54b627f04: bound 0000:00:02.0 (ops i915_hdcp_component_ops [i915])
[    6.522004] [drm] Initialized i915 1.6.0 20201103 for 0000:00:02.0 on minor 0
[    6.523384] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    7.119855] fbcon: i915drmfb (fb0) is primary device
[    7.119893] i915 0000:00:02.0: [drm] fb0: i915drmfb frame buffer device
[    7.805987] i915 0000:00:02.0: [drm] Reducing the compressed framebuffer size. This may lead to less power savings than a non-reduced-size. Try to increase stolen memory size if available in BIOS.

Yes this is the issue!

Some distribution kernels including the likes of Ubuntu are already carrying the patch for providing the Rocket Lake support out-of-the-box.

So, how can I modify the Endeavour installer to include this patch?

@ricklinux
I’m also not sure if I am doing it correctly.
Please check the attached image, how I am passing the flag to Grub.
Is this the correct way? (it did not work though)