Latest Update Error

Never had this warning until this latest update. This is new to this hardware.

==> WARNING: Possibly missing firmware for module: xhci_pci

1 Like

Hm… I wonder whether this is what’s causing issues with VirtualBox and USB3 with kernel 5.8? Was something missed form the config? :thinking:

Edit: Nah.

Think it is a harmless error, I tried the fixes (blacklisting the modules) and that does diddly squat, machine works fine.

https://bbs.archlinux.org/viewtopic.php?id=257937

1 Like

It definitely is a new message since 5.8.1 kernel i just noticed it. It is related to USB 3.0 or 3.1. This is an MSI X570 motherboard. Not causing any issues that i can see but is a new message.

1 Like

Probably you’re right, xhci should be usb 3

I had this a while ago. My system is fine. However I am not using VB.

Try the USB 3.0 ports and check if they work properly. Other than that, this message just says, that it is “possible” for the firmware to be missing. Doesn’t have to be the case.

lsmod | grep xhci_pci
xhci_pci               20480  0
xhci_pci_renesas       20480  1 xhci_pci
xhci_hcd              307200  1 xhci_pci

Yes the first two messages have been around forever. They are nothing more than info for some older hardware and not an issue. The newest one is related to newer usb but i don’t think it’s a problem if the usb 3 ports are working fine.

Mine is slightly different.

[ricklinux@eos-xfce ~]$ lsmod | grep xhci_pci
xhci_pci               20480  0
xhci_pci_renesas       20480  1 xhci_pci
xhci_hcd              286720  1 xhci_pci
[ricklinux@eos-xfce ~]$ 

Isn’t that the size of mem the module is using? Mine is using slightly more bytes than yours.

Could be…I’m not sure. I have 32 GB of memory onboard.

Edit: Yes it looks like the amount of memory. I wonder why yours is higher?

2f:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Matisse USB 3.0 Host Controller
	Subsystem: Micro-Star International Co., Ltd. [MSI] X570-A PRO motherboard
	Kernel driver in use: xhci_hcd
	Kernel modules: xhci_pci

I don’t know.

USB controller
             product: Sunrise Point-LP USB 3.0 xHCI Controller
             vendor: Intel Corporation
             physical id: 14
             bus info: pci@0000:00:14.0
             version: 21
             width: 64 bits
             clock: 33MHz
             capabilities: xhci bus_master cap_list
             configuration: driver=xhci_hcd latency=0
             resources: irq:135 memory:df310000-df31ffff

Here’s mine:

xhci_pci               20480  0
xhci_pci_renesas       20480  1 xhci_pci
xhci_hcd              307200  1 xhci_pci

I have the same error, USB 3.0 is working for my headset, but not for storage, not clear f it’s related.

xhci_pci               20480  0
xhci_pci_renesas       20480  1 xhci_pci
xhci_hcd              286720  1 xhci_pci

EDIT: My mistake, it worked, guess it wasn’t plugged properly, feeling dumb right now :sweat_smile:

1 Like

It is apparently due to missing firmware for some Renesas controllers. https://github.com/torvalds/linux/commit/a66d21d7dba84deeaf3b296c43eafc11094b6f09

5 Likes
xhci_pci               20480  0
xhci_pci_renesas       20480  1 xhci_pci
xhci_hcd              307200  1 xhci_pci

Why is my my memory amount different than yours and @pebcak yet @Elloquin & @mcury is the same as mine? Hmm?

Edit:

[ricklinux@eos-xfce ~]$ sudo lsusb -vv -s 4:1
[sudo] password for ricklinux: 

Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Device Descriptor:
  bLength                18
  bDescriptorType         1
  bcdUSB               3.10
  bDeviceClass            9 Hub
  bDeviceSubClass         0 
  bDeviceProtocol         3 
  bMaxPacketSize0         9
  idVendor           0x1d6b Linux Foundation
  idProduct          0x0003 3.0 root hub
  bcdDevice            5.08
  iManufacturer           3 Linux 5.8.1-arch1-1 xhci-hcd
  iProduct                2 xHCI Host Controller
  iSerial                 1 0000:2a:00.3
  bNumConfigurations      1
  Configuration Descriptor:
    bLength                 9
    bDescriptorType         2
    wTotalLength       0x001f
    bNumInterfaces          1
    bConfigurationValue     1
    iConfiguration          0 
    bmAttributes         0xe0
      Self Powered
      Remote Wakeup
    MaxPower                0mA
    Interface Descriptor:
      bLength                 9
      bDescriptorType         4
      bInterfaceNumber        0
      bAlternateSetting       0
      bNumEndpoints           1
      bInterfaceClass         9 Hub
      bInterfaceSubClass      0 
      bInterfaceProtocol      0 Full speed (or root) hub
      iInterface              0 
      Endpoint Descriptor:
        bLength                 7
        bDescriptorType         5
        bEndpointAddress     0x81  EP 1 IN
        bmAttributes            3
          Transfer Type            Interrupt
          Synch Type               None
          Usage Type               Data
        wMaxPacketSize     0x0004  1x 4 bytes
        bInterval              12
        bMaxBurst               0
Hub Descriptor:
  bLength              12
  bDescriptorType      42
  nNbrPorts             4
  wHubCharacteristic 0x000a
    No power switching (usb 1.0)
    Per-port overcurrent protection
  bPwrOn2PwrGood       10 * 2 milli seconds
  bHubContrCurrent      0 milli Ampere
  bHubDecLat          0.0 micro seconds
  wHubDelay             0 nano seconds
  DeviceRemovable    0x00
 Hub Port Status:
   Port 1: 0000.02a0 lowspeed L1
   Port 2: 0000.02a0 lowspeed L1
   Port 3: 0000.02a0 lowspeed L1
   Port 4: 0000.02a0 lowspeed L1
Binary Object Store Descriptor:
  bLength                 5
  bDescriptorType        15
  wTotalLength       0x002b
  bNumDeviceCaps          2
  SuperSpeed USB Device Capability:
    bLength                10
    bDescriptorType        16
    bDevCapabilityType      3
    bmAttributes         0x02
      Latency Tolerance Messages (LTM) Supported
    wSpeedsSupported   0x0008
      Device can operate at SuperSpeed (5Gbps)
    bFunctionalitySupport   3
      Lowest fully-functional device speed is SuperSpeed (5Gbps)
    bU1DevExitLat           0 micro seconds
    bU2DevExitLat           0 micro seconds
  SuperSpeedPlus USB Device Capability:
    bLength                28
    bDescriptorType        16
    bDevCapabilityType     10
    bmAttributes         0x00000023
      Sublink Speed Attribute count 3
      Sublink Speed ID count 1
    wFunctionalitySupport   0x0001
    bmSublinkSpeedAttr[0]   0x00050034
      Speed Attribute ID: 4 5Gb/s Symmetric RX SuperSpeed
    bmSublinkSpeedAttr[1]   0x000500b4
      Speed Attribute ID: 4 5Gb/s Symmetric TX SuperSpeed
    bmSublinkSpeedAttr[2]   0x000a4035
      Speed Attribute ID: 5 10Gb/s Symmetric RX SuperSpeedPlus
    bmSublinkSpeedAttr[3]   0x000a40b5
      Speed Attribute ID: 5 10Gb/s Symmetric TX SuperSpeedPlus
can't get debug descriptor: Resource temporarily unavailable
Device Status:     0x0001
  Self Powered
[ricklinux@eos-xfce ~]$ 

Afraid not…

It’s not even an error - it’s a warning.

The kernel added support for a particular type of USB device which needs specific firmware. Unless you have that device then you don’t have to do anything - it’s a harmless and merely informational warning (same as the other ones for wd719x and aic94xx)

3 Likes