LaptopTouchpad settings

After fresh install, my laptap’s touchpad does not react to touch, only click.
There are no touch settings availbale in settings.

Some system info:
[eljejer@spectre ~]$ dmesg | grep touch
[ 3.015294] hid-multitouch 0018:04F3:25BF.0001: input,hidraw0: I2C HID v1.00 Device [ELAN2514:00 04F3:25BF] on i2c-ELAN2514:00

[eljejer@spectre ~]$ udevadm info -e | grep touch
E: DRIVER=hid-multitouch

What can I do?

Do you see your touchpad if you enter
xinput list
?

If it’s there try to run
xinput list-props id
where id is the id of your touchpad from the previous command.

1 Like

[eljejer@spectre ~]$ xinput list-props 10
Device ‘ELAN2514:00 04F3:25BF’:
Device Enabled (172): 1
Coordinate Transformation Matrix (174): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Calibration Matrix (311): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Calibration Matrix Default (312): 1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
libinput Send Events Modes Available (294): 1, 0
libinput Send Events Mode Enabled (295): 0, 0
libinput Send Events Mode Enabled Default (296): 0, 0
Device Node (297): “/dev/input/event17”
Device Product ID (298): 1267, 9663
[eljejer@spectre ~]$

I’m no expert, but that doesn’t look right to me…
For the comparison that’s my output for the xinput list-props

Device Enabled (148):	1
	Coordinate Transformation Matrix (150):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Tapping Enabled (301):	1
	libinput Tapping Enabled Default (302):	0
	libinput Tapping Drag Enabled (303):	1
	libinput Tapping Drag Enabled Default (304):	1
	libinput Tapping Drag Lock Enabled (305):	0
	libinput Tapping Drag Lock Enabled Default (306):	0
	libinput Tapping Button Mapping Enabled (307):	1, 0
	libinput Tapping Button Mapping Default (308):	1, 0
	libinput Natural Scrolling Enabled (283):	0
	libinput Natural Scrolling Enabled Default (284):	0
	libinput Disable While Typing Enabled (309):	1
	libinput Disable While Typing Enabled Default (310):	1
	libinput Scroll Methods Available (285):	1, 1, 0
	libinput Scroll Method Enabled (286):	1, 0, 0
	libinput Scroll Method Enabled Default (287):	1, 0, 0
	libinput Accel Speed (292):	0.000000
	libinput Accel Speed Default (293):	0.000000
	libinput Left Handed Enabled (297):	0
	libinput Left Handed Enabled Default (298):	0
	libinput Send Events Modes Available (268):	1, 1
	libinput Send Events Mode Enabled (269):	0, 0
	libinput Send Events Mode Enabled Default (270):	0, 0
	Device Node (271):	"/dev/input/event12"
	Device Product ID (272):	2, 14
	libinput Drag Lock Buttons (299):	<no items>
	libinput Horizontal Scroll Enabled (300):	1

What DE are you using? It may have GUI tools for managing input devices.

1 Like

If you are using the Xfce Desktop Environment, open Settings Manager and scroll to and open Mouse and Touchpad. You will see that you are in Devices. Make sure that your particular touchpad device is shown. Just below that you will see two tabs: Buttons and Feedback plus Touchpad. Open Touchpad and activate Tap touchpad to click if necessary and also make sure that the scrolling mode is set to Two-finger scrolling. This should work.

If you are not using the Xfce DE, then someone else will have to help you.

Good luck.

Lawrence

Thanks Lawrence. That did the trick. However, for the touchpad tab to become active, I first had to change the device from Elan into Synaptics.

1 Like

Thanks for your input Tasia91. Problem is solved; I had to change the device setting first in the gui.

1 Like