ETPS/2 Elentech Touchpad - Not Working after Endeavour OS fresh install and attempting to install package

Not a problem, but you can add to the kernel line nowatchdog

or you can open the /etc/default/grub file:

GRUB_CMDLINE_LINUX_DEFAULT=" … nowatchdog"

and after closing the file:

sudo grub-mkconfig -o /boot/grub/grub.cfg
restart

Touchpad → https://wiki.archlinux.org/index.php/Touchpad_Synaptics

Delete xf86-input-synaptics, sorry :frowning:

1 Like

https://wiki.archlinux.org/index.php/Libinput

Hello @Chronoshift
See if it lists your device.

libinput list-devices

Also see what module is loading as @Resiliencia has asked.

lsmod

Then check:

dmesg | grep -i elantech

This may help:
https://wiki.archlinux.org/index.php/Lenovo_IdeaPad_5_15are0#Touchpad

Also check this thread.

Edit: Also check to make sure there isn’t a function key that turns on the Touchpad.

Update 7/27/20 11:00 a.m. :
I rebooted my computer and the touchpad seemed to be working with mouse both plugged and unplugged. I created a snapshot with Timeshift. About 15 minutes later my computer froze up and I had to shutdown and reboot. After rebooting, the touchpad wasn’t working again. I have now uninstalled xf86-input-synaptics because it is outdated.

Here is the output of lsmod from yesterday and this morning:
https://pastebin.com/eymYk893 - lsmod 7/26/20
https://pastebin.com/kZP1kEen - lsmod 7/27/20

Hello @Chronoshift
See if it lists your device.

libinput list-devices

Also see what module is loading as @Resiliencia has asked.

lsmod

Then check:

dmesg | grep -i elantech

I don’t see the device listed here:
https://pastebin.com/wPkGTiv0 - libinput list-devices 7/27/20
I typed : dmesg | grep -i elantech
There was no output and showed nothing.

Before when the touchpad was working it was finding the device in Xfce4 “Mouse and Touchpad” Settings in that “Device” dropdown menu it shows:
“Swiftpoint Limited Swiftpoint Z Consumer Control” and
“Swiftpoint Limited Swiftpoint Z”
I only have one mouse so I’m not sure why it is listing two devices.

Open Touchpad and activate Tap touchpad to click if necessary and also make sure that the scrolling mode is set to Two-finger scrolling.

There is a “Buttons and Feedback” tab, but no “Touchpad” tab. Probably because it is not detecting my device.

Also check to make sure there isn’t a function key that turns on the Touchpad.

There is a Function Key that is supposed to turn on and off the touchpad by pressing the Fn + F6 keys. Currently they don’t seem to do anything. When the touchpad was working the Fn + F6 key was behaving as it should.

With the following command output, you will find more information.

$ lspci -vm

I’m glad it works, otherwise don’t worry.
:slight_smile:

when I type in:
xinput list-props
there is no output.

This is the output for just xinput though:
https://pastebin.com/1qr5HQFb - xinput

1 Like

I see it normal, I leave mine:

Resumen

$ xinput
⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ KYE SYSTEMS CORP. Wired Mouse id=9 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
↳ Power Button id=6 [slave keyboard (3)]
↳ Power Button id=7 [slave keyboard (3)]
↳ Sleep Button id=8 [slave keyboard (3)]
↳ SINO WEALTH USB KEYBOARD Consumer Control id=12 [slave keyboard (3)]
↳ SINO WEALTH USB KEYBOARD id=10 [slave keyboard (3)]
↳ SINO WEALTH USB KEYBOARD System Control id=11 [slave keyboard (3)]

1 Like

Yes, lspci commands are working, but we still need to find out why the touchpad isn’t working though.

This is the output:
https://pastebin.com/6Z8YYuzr - lspci -vm

There really isn’t much information about your ETPS / 2 Elentech touchpad, but I did find an oarche, which its author says works after applying:

https://bugzilla.kernel.org/show_bug.cgi?id=81331

@Chronoshift
There was a specific issue with the Gigabyte P35 V5 Laptop but i would have thought that by now the latest kernels would have fixed that.

Try this and see if it’s relevant? This only lasts for a few seconds. Maybe it won’t do anything?

modprobe -r psmouse
modprobe psmouse

Edit: Have you looked at the pacman log in /var/log/pacman.log to see what you was updated or installed when approximately it stopped working?

There really isn’t much information about your ETPS / 2 Elentech touchpad, but I did find an oarche, which its author says works after applying:

https://bugzilla.kernel.org/show_bug.cgi?id=81331

I believe that I have the same issue presented in the article mentioned above by Judd. I then did some additional testing:

With power cord plugged in:
Warm Boot:_________________________ works, then freezes
Cold Boot: __________________________ doesn’t work
Wait 1 min with power cord
unplugged then plugging it in again:_______works then freezes

With power cord not plugged in:
Warm Boot:__________________________works
Cold Boot:___________________________doesn’t work
Wait 1 min. then Cold Boot
don’t plug it in afterward:________________works

I also have logs and such for when I found it worked again:
https://pastebin.com/yAsYQw0q - libinupt list-devices (whille working)
-Elentech Touchpad now shown at bottom.

https://pastebin.com/x8jxXdS3 - xinput (while working)
-Elentech Touchpad is listed on the third line.

https://pastebin.com/bj3hkBgN - Xrg.0.log (whike working)

https://pastebin.com/YgYgaM4D - lsmod (while working)

https://pastebin.com/6WP9tz9f - lspci -vm (while working)

dmesg | grep -i elentech --> Now Shows:
[ 9.539248] psmouse serio1: elantech: assuming hardware version 4 (with firmware version 0x461f00)
[ 9.553483] psmouse serio1: elantech: Synaptics capabilities query result 0x00, 0x15, 0x0f.
[ 9.567596] psmouse serio1: elantech: Elan sample query result 03, 81, 86
[ 9.641891] input: ETPS/2 Elantech Touchpad as /devices/platform/i8042/serio1/input/input8

So, it doesn’t seem to like the power cord for some reason.
I looked at the article and those people were making kernel patches. Is this another kernel bug?

1 Like

The original log shows the device properly as Elantech touchpad when it was working.

Then it shows the psmouse when it’s not.

Try creating a file in:
/etc/modprobe.d/elan.conf containing only the line “options psmouse elantech_smbus=0”

Edit: You may have to create this file and add the line to it and save. If it doesn’t work you can remove it.

Try creating a file in:
/etc/modprobe.d/elan.conf containing only the line “options psmouse elantech_smbus=0”

I have created a file in /etc/modbrobe.d/elan.conf containing the line:
options psmouse elantech_smbus=0 without quotes. However, it did not fix the issue.

@Chronoshift
Well…it was a shot in the dark. You can just remove the file if it didn’t work. Did you look at your pacman log and see if you could see the updates around the time it quit working? Your pacman log is in /var/log/pacman.log

@Chronoshift
What does xinput list show?

Edit: You could try: “i8042.reset” as a kernel parameter in grub command line.