ETPS/2 Elentech Touchpad - Not Working after Endeavour OS fresh install and attempting to install package

I have been trying to get my ETPS/2 Elentech touchpad working on My Gigabyte P35 V5 Laptop with little success. I had just reinstalled the Offline Version yesterday and the touchpad wasn’t working. The next morning I woke up and booted my laptop and found that it was working mysteriously. I was afraid to update anything so I just attempted to install Timeshift for backups so that if something goes wrong I can revert to when it was working. However, in that moment my touchpad stopped working and timeshift didn’t install. Using a mouse via usb works, the touchpad doesn’t work with or without the mouse plugged in. I have placed Xorg.0.log and pacman.log in separate pastebins in the comments below:

The steps that I did immediately prior to my touchpad not working are as follows:

  1. sudo pacman -S git base-devel
  2. git clone
  3. cd timeshift/
  4. makepkg -sri

I was trying to follow the steps to install Timeshift found here:

(I skipped the “sudo pacman -Syu” becuase of reasons explained above which might have been dumb on my part, but I don’t know.)

I hope that I will be able to find a solution on here because I really wanted to use it. I there are any more commands or information needed please let me know and I’ll happily oblige.

I have reinstalled Endeavour OS. Installed Timeshift via yay timeshift. Then installed cronie for the crontab dependency and created a snapshot. The touchpad is still not working, but the usb mouse still works as it should. At least if it does start working I can make another snapshot to restore to that point if using timeshift can fix it. I would like to know what is causing this issue and the solution to fix it.

Here are some logs that are relevant to my ETPS/2 Elantech Touchpad issue: -Xorg.log -pacman.log

Why not just type yay timeshift in terminal?

$ yay timeshift
3 aur/autoupgrade 1.0.0-1 (+1 0.87) 
    Automatic snapshot and then upgrade the system. (When the system fails, run `sudo timeshift --restore` and remove this package until the problem is solved.)
2 aur/timeshift-autosnap 0.9-1 (+9 0.81) 
    Timeshift auto-snapshot script which runs before package upgrade using Pacman hook.
1 aur/timeshift 20.03-1 (+117 5.79) 
    A system restore utility for Linux
==> Paquetes a instalar (eg.: 1 2 3, 1-3 or ^4)

1 Like

I didn’t want to update anything by accident. Should I do that or will that not help me with my touchpad issue? I see that I could have done that and I can’t turn back time now. (Haha joke)

$ cat /sys/bus/i2c/devices/i2c-ELAN1205:00/*


For me this outputs:
cat: ‘/sys/bus/i2c/devices/i2c-ELAN1205:00/*’: No such file or directory

1 Like

sudo libinput-list-devices


Edit: typographic error → libinput list-devices
The middle script does not go, just a space, sorry.

Output: sudo: libinput-list-devices: command not found

Perhaps I should install libinput?

1 Like

It looks like libinput was already installed.

1 Like
$ sudo pacman -Ss xf86-input
[sudo] password for judd: 
extra/xf86-input-elographics 1.4.2-2 Elographics TouchScreen input driver
extra/xf86-input-evdev 2.10.6-2 (xorg-drivers) evdev input driver
extra/xf86-input-libinput 0.30.0-1 (xorg-drivers) [instalado]
    Generic input driver for the X.Org server based on libinput
extra/xf86-input-synaptics 1.9.1-2 (xorg-drivers)
    Synaptics driver for notebook touchpads
extra/xf86-input-vmmouse 13.1.0-5 (xorg-drivers) VMWare Mouse input driver
extra/xf86-input-void 1.4.1-5 (xorg-drivers) void input driver
extra/xf86-input-wacom 0.39.0-2
    X.Org Wacom tablet driver

Verify that it is the same as mine?

sudo pacman -S xf86-input-synaptics



It appears to be the same.

1 Like

to see if it loads the module:


I did the command:
sudo pacman -S xf86-input-synaptics

and rebooted

Nothing changed
Also, when I shutdown it says something like watchdog did not stop. I’ve always had that an I figured to mention it in case if it was important.

1 Like

Not a problem, but you can add to the kernel line nowatchdog

or you can open the /etc/default/grub file:


and after closing the file:

sudo grub-mkconfig -o /boot/grub/grub.cfg

Touchpad →

Delete xf86-input-synaptics, sorry :frowning:

1 Like

Hello @Chronoshift
See if it lists your device.

libinput list-devices

Also see what module is loading as @Resiliencia has asked.


Then check:

dmesg | grep -i elantech

This may help: