Laptop does not resume from hibernation

I’m having the exact issue this guy is having, but the instructions does not work for me.

inxi -F
  Host: VSENVY Kernel: 6.7.2-arch1-1 arch: x86_64 bits: 64 Desktop: KDE Plasma
    v: 5.27.10 Distro: EndeavourOS
  Type: Convertible System: HP product: HP ENVY x360 Convertible 13-bd0xxx
    v: Type1ProductConfigId serial: <superuser required>
  Mobo: HP model: 8824 v: 47.45 serial: <superuser required> UEFI: Insyde
    v: F.37 date: 03/22/2023
  ID-1: / size: 82.32 GiB used: 19.16 GiB (23.3%) fs: ext4 dev: /dev/nvme0n1p8
  ID-2: /boot/efi size: 256 MiB used: 81 MiB (31.6%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: partition size: 15.8 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p7
  Processes: 237 Uptime: 2h 25m Memory: total: 16 GiB available: 15.37 GiB
  used: 3.73 GiB (24.3%) Shell: Zsh inxi: 3.3.31

The swap partition is configured correctly

swapon --show
NAME           TYPE       SIZE USED PRIO
/dev/nvme0n1p7 partition 15.8G   0B   -2


lsblk -af
NAME        FSTYPE FSVER LABEL            UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
├─nvme0n1p1 vfat   FAT32 SYSTEM           ECF9-57B5                               175M    32% /boot/efi
├─nvme0n1p3 ntfs         Windows          5230AE6730AE51B1
├─nvme0n1p4 ntfs         Data             926C7F156C7EF2F9                      135.5G    32% /mnt/data
├─nvme0n1p5 ntfs                          01D8FA6F425266C0
├─nvme0n1p6 ntfs         Windows RE tools C65EF77A5EF7619B
├─nvme0n1p7 swap   1                      1e71a314-c78e-4d2d-b9aa-7aa648fb36d0                [SWAP]
└─nvme0n1p8 ext4   1.0                    bb997112-69f6-48a0-92d6-6052aac21f7c   58.9G    23% /

lsinitrd -m /boot/initramfs-linux.img
Image: /boot/initramfs-linux.img: 23M
Early CPIO image
drwxr-xr-x   3 root     root            0 Jan 30 15:27 .
-rw-r--r--   1 root     root            2 Jan 30 15:27 early_cpio
drwxr-xr-x   3 root     root            0 Jan 30 15:27 kernel
drwxr-xr-x   3 root     root            0 Jan 30 15:27 kernel/x86
drwxr-xr-x   2 root     root            0 Jan 30 15:27 kernel/x86/microcode
-rw-r--r--   1 root     root      7367680 Jan 30 15:27 kernel/x86/microcode/GenuineIntel.bin
Version: dracut-059

dracut modules:


cat /proc/cmdline
BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=bb997112-69f6-48a0-92d6-6052aac21f7c rw nowatchdog nvme_load=YES resume=UUID=1e71a314-c78e-4d2d-b9aa-7aa648fb36d0 loglevel=3

I tried everything I could but no success.

Please have a look at this post:

That was a quick reply, thank you.
But it still does not work, rebooted multiple times to see if it works.
My resume.conf looks like this now:

add_dracutmodules+=" resume "
install_items+=" /usr/lib/systemd/system/systemd-hibernate-resume.service "

Could there be any other place, where things could possibly go wrong?

After adding that line to your resume.conf, you would need to rebuild your initrds.

Regenerating the initrds

You can regenerate the initrds with the command sudo dracut-rebuild


What is the processor and graphics on this laptop?

here are some more specs.

  Info: quad core model: 11th Gen Intel Core i7-1165G7 bits: 64 type: MT MCP
    cache: L2: 5 MiB
  Speed (MHz): avg: 925 min/max: 400/4700 cores: 1: 400 2: 1219 3: 400
    4: 1353 5: 1718 6: 743 7: 400 8: 1171
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel
  Device-2: Chicony HP Wide Vision HD Camera driver: uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.11 driver: X: loaded: modesetting
    dri: iris gpu: i915 resolution: 1920x1080~60Hz
  API: EGL v: 1.5 drivers: iris,swrast platforms: x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.3.4-arch1.2
    renderer: Mesa Intel Xe Graphics (TGL GT2)
  API: Vulkan Message: No Vulkan data available.

I did, when I run

sudo dracut-rebuild
Failed to build initrds, use "sudo reinstall-kernels" instead

then, I sudo reinstall-kernels.
reboot, still not working :frowning:

I see you have Windows installed. Are you using hibernation on Windows also?

yes, I use hibernate on windows too.

Just to make sure we are on the same page: after reboot, did you put your system into hibernation and then tried to resume?

yes, multiple times I tried this:

  1. I rebuilt initrds
  2. rebooted system
  3. tried to hibernate
    it hibernates, but does not resume.
    edit: does not “resume”, I meant it does not powers back up from a saved state. Appologies for the confusion.

What exactly happens when you try to power the laptop back on from a hibernation state which has no power. Resume i tend to think of suspend to ram and then resume. Hibernation it has to power back up from it’s saved state.

See, when I try to hibernate, the screen first goes black, comes back, and then goes black.
Now the pc is in hibernate, the expected behaviour is to power back up from the saved state, but when I press the power button, grub menu appears, and the computer boots up normally, as if no hibernate was applied.
This does not happen when I put the pc into sleep. Suspend to ram works as expected.

Maybe this explanation helps @pebcak

Not sure. A bit confusing situation:

OP seems to be using a Grub and dracut install, so not sure why dracut-rebuild is not working.
reinstall-kernels is for systemd-boot and dracut install.


Thanks for all of your help, the system is now resuming from hibernate properly, I forgot I installed kernel-install-for-dracut, your reply helped me to remind what I did wrong.
Thank you for help again, it really helped me to resolve my issue :smile:.

Glad you got it resolved!
Also, welcome to EnOS’ community @vanshaj !
:enos: :handshake:t5:

1 Like

Thank you, I’m glad to be a part of it.

1 Like

I use grub and I’m not even sure how dracut fits in with it because i don’t usually have any issues. I don’t use hibernation either. I usually always install with btrs or ext4 and swap file.

Edit: I guess you’re right it should be sudo dracut-rebuild but I’ve never had to use it.

Seems to be? How did you know this?

Edit: Because of /boot/efi?