KDE Window Decoration Titlebar Buttons Issue

After upgrading…is anyone else having an issue with their Windows Decorations > Titlebar Buttons not showing…and (warning, if trying this) if you add one, it duplicates them but you can’t see the buttons to remove them?

:flushed: :scream:

Everything looks fine on my end. Here is my Dolphin, with window borders enabled:

2 Likes

:thinking: Have you tried adding a button to the title bar? I refreshed my image to circle the issues.

1 Like

Yes, I see what you’re talking about. There is a purely visual glitch with the System Settings. You can still add and remove buttons, you just don’t get visual feedback on what you’re doing.

Definitely a bug.

1 Like

Never do that! This will likely get you in a partial update situation.

You should never install packages between synchronising your local package database and upgrading. Install packages either after upgrading, or before sync, but never between, because you’re installing new packages on an outdated system. A partial update situation can have very unpleasant consequences, like an unbootable system.

1 Like

Similar things happened before, KDE is not most stable thing especially in Settings…Hopefully it will be fixed soon :slight_smile:

1 Like

:grinning: all right, the idea is just to upgrade whatever, to get those packages right

Ok, good. I am not going crazy, well, on this anyway. Unfortunately on mine, I can’t remove the buttons, nothing to click on even though I can’t see them. I will file a bug report. Thanks again. :+1:

1 Like

You can remove them, just try clicking and dragging on the mock up titlebar. On your screenshot, there is that big X button, try dragging that one away (you’ll likely remove something else).

1 Like

If you want to upgrade, the correct command is:

pacman -Syu

@Kresimir I know that : - )

I can click and move the big x button, but even it is messed up, the click only happens way above it, but for the invisible buttons there is nothing there. I have clicked all over that thing, LOL. It must also be a theming issue, but I have even tried changing themes, the same. strange.

I assumed you didn’t know that, because if you did, you probably wouldn’t be suggesting pacman -Sy <package_name>. This tells pacman to sync the local package database, not upgrade anything, and then install a package (according to the synced db) on an outdated system. This is how you create a partial update.

@Kresimir
that was a typo sorry, you are right :slight_smile:

@RodneyCK
maybe window decoration:
switch away from breeeze, or your actual decoration ?

EDIT: my KDE is OK updated all the way up ?
maybe you got qt5-base wrong ?

1 Like

Yeah, I tried all that, did a complete global theme switch to breeze, turned on and then off Kvantum, changed window decorations, icons, everything. I still can’t move anything on that bar but the big X button. thanks.

@RodneyCK
image

which version do you have ??

1 Like

Thanks. I had high hopes, saw it in my updates. I just did an update, rebooted and it is still the same. :exploding_head:

Same as you. The strange thing is, I have my main desktop pc on Garuda linux, totally different distro and theming, same issue as my laptop with EnOS.

Odd, I never received a breaking issue when upgrading today on either distro. I have libcap version 2.56-1 installed.