[KDE] Failed to start Load Kernel Modules

hey guys, so yesterday i went and updated all my packages and rebooted since i saw a linux kernel package of some kind, but after rebooting i get said error, the system continues to boot for a while, and then freezes (i cant even open a tty). im assuming this is likely a display manager issue or driver issue of some kind since i used to have this same issue on this same pc a while back while using manjaro, but i could at least tty when that happened. im not super sure what to do here and this install has been running for about two weeks so id prefer to not reinstall if possible, but i understand if i have to. all i really can give you right now is this screenshot, but if you can think of anything helpful please ask and ill do what i can! one more thing, this is a fairly recent laptop with an nvidia rtx gpu (its hard to find affordable laptops with amd here), so i wouldnt be surprised if its something to do with that

thank you!

On the grub boot menu, press e and edit the kernel boot line by adding 3 to the parameters.

This could get you to TTY. Login with your credential, and see if you can get some logs.

Make a note of the URLs and post them on the forum. Hopefully someone will be able to assist you.

Good luck!


If you are using the latest kernel with a recent intel cpu you may need to add ibt=off as kernel parameter in grub.

Either that or switch to the LTS kernel.

1 Like

Welcome to the forum @jalipeno :enos: :enos_flag: :partying_face:

hey, so adding this seems to have worked, im just confused as to how to make it permanent. thank you guys so much!

1 Like

If you are using grub you can add it to /etc/default/grub in the GRUB_CMDLINE_LINUX_DEFAULT line.

Then run sudo grub-mkconfig -o /boot/grub/grub.cfg

problem solved! you guys are great tysm!!


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.