System is not booting into DE

I’ve wanted to install EnOS with the Mate DE, installation works fine but when I want to boot into the system I guess it loads some services but then gets stuck and doesn’t load the Login panel.
I’ve installed the it with systemd boot.

inxi -Fxxz

  Kernel: 6.2.8-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 info: xfce4-panel wm: xfwm
    v: 4.18.0 vt: 1 dm: LightDM v: 1.32.0 Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop S5402ZA_K5402ZA
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: S5402ZA v: 1.0 serial: <superuser required>
    UEFI: American Megatrends LLC. v: S5402ZA.307 date: 09/08/2022
  ID-1: BAT0 charge: 65.4 Wh (100.0%) condition: 65.4/70.2 Wh (93.2%)
    volts: 13.1 min: 11.9 model: SMP K340258 type: Li-ion serial: N/A
    status: full
  Info: 14-core (6-mt/8-st) model: 12th Gen Intel Core i7-12700H bits: 64
    type: MST AMCP smt: enabled arch: Alder Lake rev: 3 cache: L1: 1.2 MiB
    L2: 11.5 MiB L3: 24 MiB
  Speed (MHz): avg: 2414 high: 2700 min/max: 400/4600:4700:3500 cores:
    1: 1017 2: 813 3: 2700 4: 2700 5: 2700 6: 2700 7: 2700 8: 2700 9: 2700
    10: 2700 11: 2700 12: 2700 13: 2700 14: 2700 15: 554 16: 2700 17: 2700
    18: 2700 19: 2700 20: 2700 bogomips: 107560
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: ASUSTeK
    driver: i915 v: kernel arch: Gen-12.2 ports: active: eDP-1 empty: DP-1,
    DP-2, DP-3, DP-4, HDMI-A-1 bus-ID: 0000:00:02.0 chip-ID: 8086:46a6
    class-ID: 0300
  Device-2: Quanta USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 2-2:2 chip-ID: 0408:30e0 class-ID: fe01 serial: <filter>
  Display: server: X.Org v: 21.1.7 compositor: xfwm v: 4.18.0 driver: X:
    loaded: modesetting alternate: fbdev,intel,vesa dri: iris gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 2880x1800 s-dpi: 96 s-size: 762x476mm (30.00x18.74")
    s-diag: 898mm (35.37")
  Monitor-1: eDP-1 model: Samsung 0x416d res: 2880x1800 hz: 120 dpi: 234
    size: 312x195mm (12.28x7.68") diag: 368mm (14.5") modes: 2880x1800
  API: OpenGL v: 4.6 Mesa 23.0.0 renderer: Mesa Intel Graphics (ADL GT2)
    direct-render: Yes
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: ASUSTeK
    driver: sof-audio-pci-intel-tgl bus-ID: 0000:00:1f.3 chip-ID: 8086:51c8
    class-ID: 0401
  Sound API: ALSA v: k6.2.8-arch1-1 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.67 running: yes
  Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi
    v: kernel bus-ID: 0000:80:00.0 chip-ID: 8086:24fb class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  Device-1: Intel Wireless-AC 3168 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 2-10:5 chip-ID: 8087:0aa7 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
    v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
  Local Storage: total: 968.32 GiB used: 6.62 GiB (0.7%)
  ID-1: /dev/nvme0n1 vendor: Micron model: 2450 MTFDKBA1T0TFK
    size: 953.87 GiB speed: 63.2 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: V5MA010 temp: 38.9 C scheme: GPT
  ID-2: /dev/sda type: USB vendor: Generic model: Flash Disk size: 14.45 GiB
    type: SSD serial: <filter> rev: 8.01 scheme: MBR
  ID-1: / size: 10 GiB used: 81.5 MiB (0.8%) fs: overlay source: ERR-102
  Alert: No swap data was found.
  System Temperatures: cpu: 39.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 351 Uptime: 21m wakeups: 31534 Memory: 15.25 GiB
  used: 2.75 GiB (18.0%) Init: systemd v: 253 default: multi-user Compilers:
  gcc: 12.2.1 Packages: pm: pacman pkgs: 900 Shell: Bash v: 5.1.16
  running-in: xfce4-terminal inxi: 3.3.25

It seems like ppl. have solved it by adding this in the grub cfg, how is this applicable to systemd?

Also what I’ve figured that when using the offline install everything seems to work.

You can add kernel options by appending them to /etc/kernel/cmdline and then run sudo reinstall-kernels

Thanks, did that. On the LTS Kernel(6.1.31) it won’t load the DE. On the 6.3.5 Kernel it does load but it takes ages and I also got a error message that something in /dev failed. How can I provide some system logs for further information?
edit: Is this a known issues? For some background. I was running the cinnamon DE for quite some time without issues and after a system update yesterday, things started happening. E.g. the system didn’t boot, when it booted some services did not load, sometimes it loaded the NetworkManager sometimes it don’t. In the systemctl --failed I had 7 failed ones, one was called realtime scheduler and two which had a user in it.

journalctl output of the last boot

Did a offline install and booting into the DE worked fine. Then proceeded to update the packages with sudo pacman -Syu and then rebooted. After rebooting I’m having the same issue as with the online install. Some package is causing this issue but i don’t know how to debug this.

do you use systemd-boot or grub, maybe you have a similar problem as here

We don’t ship that configuration by default. The only way to get the systemd-boot/mkinitcpio combo is to manually convert a pre-Cassini system to systemd-boot or to manually convert a Cassini system to mkinitcpio.

Unless the OP did one of those manually that issue shouldn’t impact them.

it’s either way. I ran cinnamon with grub and then I tried to run the system with systemd, but it didn’t help.

I think the only way is to install each package one by one and check what package is causing this issue?

Issues seems to be with the kernel 6.3.5 and seems to be an issue with this Laptop and the components. I can boot the system with kernel 6.3.4. Fixed it by mounting the drive and the efi drive and downgrading the kernel in the live USB environment.

For now you might consider installing the lts kernel and headers and using that if you have an issue with the latest kernel. I always keep the lts kernel installed just in case as it isn’t uncommon for issues with the latest kernel to popup.

strange thing is I couldn’t boot the system with the LTS kernel either.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.