Internet don't work

I’m not good in English
I’m using EndeavorOS Qtile version
I have connected to Windscribe VPN and watching video on YouTube. after a time VPN disconnected automatic, so I decided to close Windscribe and use another VPN but the app didn’t close.
I tried to kill it with terminal by bpytop. When I searched for the windscribe I found 4 processes: openvpn, WStunnel, helper and windscribe itself.
Two of them created by root user, so for killing them I opened bpytop with sudo.

Now internet don’t work with or without VPN and different connection. I tried to connect to my mobile internet with cable, but it doesn’t work.
I tried to restart system, when system shutting down, process with pid=1000 took 1.5 minutes to close!!

What network connection are you using? Were you able to connect to the internet after the system reboot?

Using mobile internet connection(hotspot and usb cable) and University wifi

No I can’t connect to internet after reboot.
I can only connect to my university local websites when connected to university wifi

Has the university used a proxy to block access to external websites? Do I understand correctly that you connect to the mobile internet with a USB cable?

No they don’t block external links.
Now I’m connected to my mobile hotspot.
Problem is only with my laptop, everyone can use internet with any connection except me with my laptop.
I can’t even connect or ping any website.

can you report

inxi -Fza
1 Like

output of inxi -Fza

You have more than one vpn. Did you try removing the vpn?

1 Like

cat /etc/resolv.conf

No I don’t remove VPNs.
Just windscribe installed. I downloaded other VPN from GitHub and run it from file manager.
This problem happened after I killed the windscribe

When I connected to university wifi:

When I connected to my mobile hotspot:

I found the process with pid=1000 which takes 1.5 minutes to kill is User Manager.
Sometimes it takes a while to kill, not everytime I shut down my laptop.

This is independent of the establishment of an Internet connection. What does it mean you can’t uninstall VPN? For what reason do you need it?

It’s so easy to uninstall the VPN and see what the problem is and go from there in my opinion.


Try without VPN. If everything works, then the problem is with VPN. You then have a clearer way to troubleshoot that.


That’s what i said too! Long ago! :wink:


You’re just too fast for me. You post faster than I can read.

Hey i have an idea here!


You should try without VPN and see if it’s the cause of problem!

1 Like

I got another idea. Try another vpn if that one doesn’t work. Remember a vpn doesn’t work if you have no internet. :stuck_out_tongue:

1 Like

I uninstalled Windscibe, reboot and now internet working.
but I checked running processes, only windscribe-helper run in the background :man_shrugging: