Internal drive issue

well, im not to sure how to describe this problem now where to put it.

The second internal drive always needs the admin password one the first mount, when i for example try to use wine with the c drive in said internal drive it doesnt seem to work.

my guess is i would have to remove this admin password prompt to programs dont need root access?
or is there some other way i can make the drive automount and without having interferences?

Edit: another example of this being is a game on this drive trying to install aditional files it doesnt see the drive and thus shows it as 0, which was the initial thing that made me think this might be some perm issue with the whole password prompt?

If you give it a mount point then the system will mount it automatically without prompting you for a password:

You can mount at boot or mount when accessed.


while i am aware of fstab this is far out of my expertise to use the arch wiki as it requires to much additional knowledge to even understand, knowledge i do not have

You are aware that you lack knowledge and that the Arch wiki has it.

Feel free to ask about something you don’t understand.

If you’d prefer it in a different language then here’s German and Magyar:

i dont think you understand what i meant, i dont understand what the arch wiki is trying to tell me, its to cryptic for me to comprehend what its trying to tell me.
the arch wiki (for me) as i said is written with the reader needing already extensive knowledge to use it properly.

In short, i just dont understand it, which is why im asking this friendly forum for the help i need.

I’m trying to help you. “I don’t know how to read” is not a valid excuse for not learning how to read.

You need to add an entry into your fstab for the other partition.

Which bit do you need help with beyond that?

Here’s pretty short and on point post, you may find more info in that topic

I assume you’re more of an audio / visual person, but couldn’t really find any youtube guide which is just that task of fstab mounting… :laughing:

1 Like

Had the same problem last week, and I’m new too…
don’t worry it’s less scary than it seems…

in my case, I added the following line to my /etc/fstab file:

UUID=795b410f-d53c-481f-b686-a4d927ad106f /run/media/mathias/Data ext4 defaults 0 0

UUID obviously has to be changed to the UUID of your partition,

second part is the location of the mount point… This is a folder that has to exist, if it doesn’t: make it.
Of course you can name it whatever you want

3rd part “ext4” is the filesystem the partition uses, so if it is anything else than ext4 change it there

4th part “defaults” are the mounting options… I chose just defaults, the wiki has info about others.

5 part “0” is dump, this is usually set to 0

6th part, the other “0” is <fsck> sets the order for filesystem checks at boot time; see fsck(8). For the root device it should be 1 . For other partitions it should be 2 , or 0 to disable checking.

edit: seeing previous post, seems like I might want to add noatime for improved performance

UUID=795b410f-d53c-481f-b686-a4d927ad106f /run/media/mathias/Data ext4 defaults,noatime 0 2

is probably better, isn’t it?


I’m sorry but i understand exactly what @AmandaONeill is saying. I too agree that for a lot of people reading the Arch wiki isn’t going to help them. It is written in a way that is so technical most people can’t understand it and it just leads you down a rabbit hole of frustration and disillusionment. I myself find it difficult and sometimes excruciatingly painful to just read through some stuff. So i understand exactly what is being said. I don’t believe in RTFM and you’ll be able to do it. I think there is a better way and that is explanation and showing and doing. Learning …baby steps! As they say! It’s obvious the user knows something and probably has learned it this way and not from reading the Arch wiki!
No offence…just my opinion. :slightly_smiling_face:


you dont have to be rude just because other people do not have the same understanding of a wiki as you, just because someone can read doesnt mean they can understand everything they are able to read.

while it is short and on point my technical knowledge is has the same problem as the wiki for me.
thank you for searching for a video but i have a dislike for video tutorials.

lastly for krimkerre, i tried to do exactly as you said adding the entry but as a result i wasnt able to boot

sorry to bother so many people with this and my limited knowledge

I agree, I usually have to combine the wiki with another source of information

most of what i learned is probably like most others selftaught through trial and error, tho even with that i barely scratched the surface level.

god damn, I’m sorry!
Did you manage to get into your system to fix it?

I’m not being rude - I’m trying to provide an analogy for avoiding learning something.

This is why you need to understand what you’re doing before doing copying and pasting something from a web page.

1 Like

It takes time and the thing is to not give up. Linux (Arch) is like a universe and once you reach one destination there are many more. There are a lot of people with way more experience than myself and a lot have a grasp of the Linux command line that i don’t so i get it. I just try to learn something new everyday and i do! Some days.

i always keep a liveusb ready so i was able to get in and delete the entry, was right back.

i probably just did something terribly wrong.

could it be that the drive having a space in its name it also causing an issue? i have noticed that when i tried to set some path in wine.

when it was to what i entered it was all step by step, the uuid, the path, the format, defaults but no atime noticed that to late

I have to ask: is there something wrong in my fstab entry, because it works just fine here,

the fact i am here should be proof enough i am willing to learn no?
otherwise i would just use any other distro that wont give me this problem

i dont just copy paste whatever i see, another assumption that has been made, i adjusted the suggestion to my needs is all

1 Like

that’s possibly the culprit :slight_smile:

So - what did you add to your /etc/fstab ?

On what did you base the included information?