Instant logout with i3wm

Hey there!
I’m a relativly new EOS (and a little less new linux) user and have been lurking this forums for quiet some time now.

First some background:
Before EOS I tryed different distros, like Ubuntu, Manjaro, etc. mainly with XFCE as my DE.
I like the idea of tiling WMs but I’m a little nervous about jumping the tiling WM-train completely. Because I’m familiar with XFCE, I installed EOS with XFCE and i3WM together, so I can switch to XFCE in case I run into some issues where I need a GUI.
So everything went fine and I used EOS with i3WM and a little trip to XFCE now and then for arround 4 months without any bigger problems.

Now my problem:
I use the login-screen that comes with XFCE (I guess?) for logging in and switching my “active” DE/WM.
Today I wanted to login to a i3WM-session and all it does is turning my screen black for half a secound and bringing me back to the login-screen. Logging into XFCE works without a problem though.

Duck-duck-going and even googling didn’t bring me any results, so I wanted to ask if maybe here someone is familiar with this issue and might provide / direct me to a solution.

Many thanks in advance!
I hope I chose the right category for my question :sweat_smile:

Did you check your logs for errors after your login failed?

journalctl -b -u lightdm
1 Like

if i understand login to DE is working and only i3 causing issue, so using debug session would be the thing to do:
Using i3 (with debug-log) as session to login
and produce a logfile like i3 docs say:

DISPLAY=:0 i3-dump-log | bzip2 -c | curl --data-binary @- https://logs.i3wm.org
2 Likes

Welcome Aboard!

Alternatively, now that you have gotten your feet wet so to speak and like the combination of i3WM and XFCE why not just use both at the same time?

Read here:

This way you keep all the XFCE goodies and use i3 as the window manager. I have a piggy back post to that one coming but it wont be until later tonight. Since you say logging into XFCE works correctly this should as well since you don’t actually change the session from XFCE to I3 when you log in.

2 Likes

Thanks for all your replies!
@vlkon:
Running journalctl -b -u lightdm gets me this log:

Mai 18 18:27:49 T420s lightdm[1461]: gkr-pam: stashed password to try later in open session
Mai 18 18:27:49 T420s lightdm[1461]: pam_systemd_home(lightdm:account): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.
Mai 18 18:27:49 T420s lightdm[1461]: pam_unix(lightdm:session): session opened for user wst(uid=1000) by (uid=0)
Mai 18 18:27:49 T420s lightdm[1461]: pam_env(lightdm:session): deprecated reading of user environment enabled
Mai 18 18:27:49 T420s lightdm[1461]: gkr-pam: gnome-keyring-daemon started properly and unlocked keyring
Mai 18 18:27:50 T420s lightdm[1461]: pam_unix(lightdm:session): session closed for user wst

I guess I’m to much of a noob to get, why the session for user wst was closed :thinking:

@joekamprad
How do I get into a i3 session? When I login, I’m immediately redirected to the login-screen. I’m not able to run any commands :confused:

@Elloquin
thanks for the suggestion, I’m definitely gonna check this out!

Edit1: Tryed xfce+i3 out and now I can’t even get into XFCE anymore. So the problem realy seems to be with i3 :thinking:

Edit2: reformatting

Welcome to Endeavour!

1 Like

welcome to forum

what kernel use ? I read people have problem on 5.12 but ok on lts .

1 Like

My kernel version is 5.12.4.

I also ran

journalctl -b -u lightdm

again in the tty and it returned the same log as I posted before, but I think I missed to copy the first line:

gkr-pam:  unable to locate daemon control file

might help … it interesting read

Issue with Window Managers persists (for me) with latest 5.12.4.
Both linux-lts and linux-hardened working fine.

I also on 5.12.4 but no problem like you + other people :disappointed:

2 Likes

Thanks, this sounds exactly like my issue. Guess I’ll have to switch to the lts-kernel then.

try lts , see if it help ! I sure fix will find soon then you switch back . Always good have 2 kernels . it rare both no work after updated.

1 Like

I’m at it, never installed and switched to a secound kernel, so I’ll have to do some googling, but I’ll report back with my results :slightly_smiling_face:

Wow that was hardly as complicated as I expected :sweat_smile:
Switched to the lts kernel now and I’m able to login again :partying_face:
Thank you all for your help!

Now I’ll continue to set @Elloquin 's suggested XFCE+i3 up.

1 Like

as lightdm try to start i3 what fails it would produce the logfile, you would have been able to produce the pastebin … /usr/bin/i3-dump-log is a command only no need to run i3 session to use it :wink:

2 Likes

There is no error or warning. My wild guess is that lightdm “worked as intended”.
I observed this sometimes when a new kernel did not like my nvidia drivers. Do you by any chance use proprietary nvidia drivers? Maybe if you investigate your X11 logs then you may see some error messages (last I remember those required some level of mysticism to understand them :grinning_face_with_smiling_eyes:).
That would not explain why XFCE worked without problem. If you want to dig deeper into this topic then @joekamprad’s advice with capturing i3wm debug logs is good place to start. :+1:

3 Likes

NVidia :wink:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.