Installing EndeavourOS with Plasma is Broken & Add the Nvidia Kernel Parameter by Default

Here’s the proof. Black screen is the kde polkit, and something I couldn’t show is that rightclicking makes the menu span the entire desktop with no text. I’ve been able to replicate this twice, once a few months ago, and today. I had another monitor connected during install and boot, and I’m on an optimus laptop. And the past times I’ve installed recently, the kernel parameter (nvidia drm modest) isn’t in the grub menu.
I have an install log, but I can’t upload it for some reason and pastebin says its too big (its like 50kb over the limit)

Nothing is broken. Works fine on my hardware! No Nvidia here…

1 Like

Use a different pastebin service.


Is this an Nvidia thing or Wayland? I have polkit and my Kde works perfectly. :wink:

At least some info about how you install like using the nvidia boot option or installing nvidia on your own manually ? also the screenshots showing that you may have deselected some packages manually on install process? as I do not see the EndeavourOS theme in settings shot…

The install log should not be that huge also usually is about 500kb and 450 lines.

You can use eos-sendlog to send the log to pastebin and get the URL like so:

sudo cat /var/log/endeavour-install.log | eos-sendlog

My install process was I chose the second boot option the one that says (latest nvidia cards), then I chose kde desktop as my DE and chose gnome-disk-utility under the gnome option. Installed normally from there. heres the log, I included quite a few things, hopefully one of them solves the problem

xf86-video-intel is installed what could be an issue…
and I see indeed nvidia DRM modesetting option is not set in grub.
we will check about these… while that you should try adding the option to grub and the intel driver package should not be needed for your system too.

@dalto @manuel :wink:
we need to check this. Could be something goes wrong with nvidia implementation.

1 Like

I can’t see any problems on my EOS systems w/ nvidia dkms but I have a similar issue with a Manjaro KDE system (intel GPU).
Maybe xf86-video-intel or some other gpu stuff have a conflict with following libraries:
glibc lib32-glibc

I have downgraded both glibc packages to v.2.36-7 and it works, maybe some library stuff are not updated yet or is broken.
@TheKarion maybe you could try w/ a downgrade of glibc & lib32-glibc afterwards put it on ignore list

some more details:

@cluster the solution proposed on the M - forum is overkill, with renaming the whole .config folder basically resetting everything …

1 Like

Could be that the kernel parameter ibt=off is needed?
Worth a try anyway.

1 Like

@TheKarion mentioned and we can see this in the logs too that he was using nvidia option on the installer to boot but he do not have the kernel parameter for nvidia modesetting DRM in grub.
Do we still have this or is there a change ?

1 Like

It should be in nvidia-inst at least.

1 Like

Yes KDE same issues after glibc has been updated, lost desktop settings and menu & other stuff are broken, only a glibc downgrade to .2.36-7 solved these issues …
I dont think it’s a compiler issue because the newer glibc package breaks the system again after a reboot.

have you already read this?

I have downgraded both glibc packages to v.2.36-7 and it works, maybe some library stuff are not updated yet or is broken.
@TheKarion maybe you could try w/ a downgrade of glibc & lib32-glibc afterwards put it on ignore list

about missing icons and stuff:

The issue seems to be within the file .config/plasma-org.kde.plasma.desktop-appletsrc, specifically within this section:


After deleting the section (best to use vim or something that works on ~20 MB file), and rebooting, everything is back to normal.

But we have two different issues to think of here … the icons issue and the issue with not complete setup of nvidia driver

1 Like

that is a sure way to get other issues (partial update, toolchain mismatch etc).
The solution i gave in the other thread here on Endeavour forum comes with a bit of work (configuring the Desktop itself again) but it is the safer way and does not reset every installed program - and it also does not reset every KDE setting.
I rebuild the plasma-workspace package that provides the plasmashell and it did not solve the issue, the Qt base package was updated shortly after the glibc dropped, so that is not the issue either. And not all installations are affected, my notebook for example did not have the issue, only my desktop although the relevant packages installed and config in KDE are the same on both machines.

1 Like

it’s not meant to be a permanent fix, i’ll use it as a temp. solution until the problems are fixed.

as the proper fix is resetting a part of your config and newly created users also don’t have the problem, and not even the majority of existing users have it, there probably won’t be a fix.

If you think that the issue is solved with rebuilds against the new glibc and the rebuild toolchains against glibc, switch to testing, it already contains the Plasma 5.27 packages which is a full rebuild of all KDE packages. If the issue persists, there most likely will never be a fix, or at least not soon.


Thank you guys!
so if it’s not caused by a conflict w/ latest glibc I’ll install the new glibc packages and reinstall the KDE stuff afterwards & do some changes in plasma-org.kde.plasma.desktop-appletsrc etc.