Installer unable to fetch packages, but firefox/ping works

I am having the same problem as this guy , but I dont have pihole or anything, just a regular system with a modem. This is my "lspci -k | grep -PiA4 " network controller: | ethernet controller: " output

03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 11)
	Subsystem: ASUSTeK Computer Inc. Device 859e
	Kernel driver in use: r8169
	Kernel modules: r8169, r8168

I have noticed that firefox takes some time to display any webpage. I have opened multiple tabs on firefox, and all of them keep me waiting before showing up simultaneously. Can someone help me? I have already formatted my partitions and am stuck here.

Edit : This is from the installation terminal after selecting the partitions and clicking next.

12:35:23 [6]:  ..  partition table 0x7f9bd8050520 type 4 
12:35:33 [6]: QString PartUtils::findFS(QString, FileSystem::Type*)
    Found filesystem "ext4" 
12:35:48 [6]: bool PartUtils::isEfiBootable(const Partition*)
    Check EFI bootable "/dev/sdb1" "/dev/sdb" 
12:35:48 [6]:  ..  flags QFlags(0x1) 
12:35:55 [8]: QML Component (default slideshow) Next slide
12:36:35 [8]: QML Component (default slideshow) Next slide
12:37:15 [8]: QML Component (default slideshow) Next slide

It is not checking any url.

Edit 2 : I just had a notification from eos-update-notifier saying “Internet connection is not available”

Maybe this will help; do the offline installation first, then if still no go on the network, follow these steps. R8168 is annoyingly inconsistent for me on my Asus Rog Strix laptop too.

Ok thanks.

Just wanted a clean kde installation, but looks like i have no choice. I will update the thread afterwards.

Installed os through the offline mode, manually installed the 8168 package from arch website (mirrors kept timing out), rebooted and the network has stopped working. There is no network connection

Is there anything else I can do?

Do the inverse remove the r8168 package and reboot and tell us if it works ?

The hardware problem comes from Realtek firmware. Some hardware takes only r8168 likes my old Linksys which is wrongly detected as r8169 by default but some others r8168 works with the r8169 driver…

In your case it seems to work with the r8169 here Solved -- Help with Realtek module r8169

check your services systemctl if it’s enable or not…

I have removed the 8168 package, rebooted and I am back to a laggy internet experience. Mirrors keep timing out and websites open after 2 min.

I am not sure how to check if its enabled via systemctl but googling gave me this command.

“sudo systemctl status systemd-networkd”

Here is the output. Hope that helps.

● systemd-networkd.service - Network Service
     Loaded: loaded (/usr/lib/systemd/system/systemd-networkd.service; enabled; vendor preset: enabled)
     Active: active (running) since Sun 2020-10-18 15:36:33 IST; 16min ago
TriggeredBy: ● systemd-networkd.socket
       Docs: man:systemd-networkd.service(8)
   Main PID: 279 (systemd-network)
     Status: "Processing requests..."
      Tasks: 1 (limit: 19122)
     Memory: 3.8M
     CGroup: /system.slice/systemd-networkd.service
             └─279 /usr/lib/systemd/systemd-networkd

Oct 18 15:36:33 Alluri systemd-networkd[279]: Configuration file /etc/systemd/network/20-ethernet.network is marked executable. Please remove executable permission bits. Proceeding anyway.
Oct 18 15:36:33 Alluri systemd-networkd[279]: Configuration file /etc/systemd/network/20-wireless.network is marked executable. Please remove executable permission bits. Proceeding anyway.
Oct 18 15:36:33 Alluri systemd-networkd[279]: Enumeration completed
Oct 18 15:36:33 Alluri systemd[1]: Started Network Service.
Oct 18 15:36:33 Alluri systemd-networkd[279]: eth0: Interface name change detected, eth0 has been renamed to enp3s0.
Oct 18 15:36:33 Alluri systemd-networkd[279]: enp3s0: IPv6 successfully enabled
Oct 18 15:36:33 Alluri systemd-networkd[279]: enp3s0: Link UP
Oct 18 15:36:36 Alluri systemd-networkd[279]: enp3s0: Gained carrier
Oct 18 15:36:36 Alluri systemd-networkd[279]: enp3s0: DHCPv4 address 192.168.0.103/24 via 192.168.0.1
Oct 18 15:36:37 Alluri systemd-networkd[279]: enp3s0: Gained IPv6LL
~
~
~
~
~
~
~
lines 1-22/22 (END)

if this was out of Installer Live Environment it looks like that you need to use the

r8168

module to me.
so change it on live ISO to this one:
sudo pacman -S r8168
sudo rmmod r8169
sudo modprobe r8168
sudo systemctl restart NetworkManager
then start installer

Is there any difference between installing it after an offline installation or via the live iso?

Coz I did install the r8168 package after an offline installation, only to see an empty network connection list. I had to remove it in order to get my network working.

I figured it out.

From arch wiki on ethernet

Another fault in the drivers for some revisions of this adapter is poor IPv6 support. IPv6#Disable functionality can be helpful if you encounter issues such as hanging webpages and slow speeds.

I gave “ipv6.disable=1” as a kernel parameter and the system works perfectly.

So, how do I do this in the live iso? Do the same when the boot menu comes up?

2 Likes

Instead of booting up, press e to edit the kernel command line and add ipv6.disable=1 to the boot parameters. Hope this helps.

1 Like

That worked. Thanks for everything guys.

4 Likes

so we got the wrong direction, because this modules are known for issues. On live ISO you can also disable ipv6 in network settings, then disable and enable network.

1 Like