Online Installer can't fetch packages but FireFox/ping works

As the Title says:

I downloaded the May 8th EOS build, put on a SD Card, and booted it up using the Nvidia Drivers option.

Specs:

  • Ryzen 7 2700
  • GTX-1080
  • 32GB DDR4 @ 3200MHz
  • MSI B450 Tomahawk Motherboard
  • 1440p @ 144Hz

Problem:

I opted for the Online installer for customization. After I fill out the first couple of pages, it gets to the “package selection” page, but it errors out saying it’s unable to fetch package lists & to check my network connection (screenshot attached).

Things that didn’t work:

  • updating the welcome installer (went from v2.6-1 to v2.7-1)
  • updating the mirrors
  • allowing HTTP mirrors
  • changed my network settings from DHCP to static (since I have it set to static anyway in my router)
  • disabling IPv6 since my router has IPv6 disabled as well.

I’m at a loss on what to do exactly. I’m even using FireFox on the LiveCD right now to type this, but yet it keeps saying there’s no network/can’t fetch package lists.

Other things:

  • The MD5SUM was verified before burning to SD card
  • GPT formatted SSD
  • Ping 8.8.8.8 works normally

Other things I noticed that are unrelated but felt I should bring them up:

(1) When you manual format there’s no option to “label” your partitions like gparted allows. Not important, but would be nice.

(2) When you manual format, it throws a very helpful popup error stating that you need to create a /boot/efi partition with an “esp” flag. Unfortunately, there’s no esp flag available, but there is a boot flag which I read on Google that that is the flag it’s talking about.

(3) The Offline installer did install (but couldn’t boot, that’s another issue). I created sda1 with a /boot/efi partition with FAT32 formatting and ~2GB of space, and enabled the boot flag. Not sure what went wrong on that, but it kept hanging with a blinking cursor (underscore).


All help appreciated, and thanks for making this distro!

  • Ben

Here’s a startup screenshot with the only actual error that shows up.

I’ll have to let the experts at you on this one - but from what I know it sounds like you may have run into an outage of the git-based repositories for Endeavour. I had that issue recently when adding the EndeavourOS repo to an Arch system I have, and I had to ‘sort’ the mirrorlist to Germany first to crawl through it… then sync it up and proceed. Might help with identification of the problem -as it appears that the install otherwise happened - ie: the Arch mirrors functioned OK.

2 Likes

Welcome aboard! :smile:

Can you show the output of command:

lspci -k | grep -PiA4 " network controller: | ethernet controller: "

it could be that, simple failed to connect to GitHub needed for installer… this would be solved simple on waiting and retry…

If it’s trying to get to GitHub, then that was probably the issue. I could not get to GitHub last night at all (several hours down) even though a GitHub-status said it was online. I even had to go to archive.org to download the MD5 checksum. I’ll check the output of that command in just a little while.

Here’s the output of that command:

[liveuser@eos-2020.05.08 ~]$ lspci -k | grep -PiA4 " network controller: | ethernet controller: "
22:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)
Subsystem: Micro-Star International Co., Ltd. [MSI] RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
Kernel driver in use: r8168
Kernel modules: r8169, r8168
26:00.0 VGA compatible controller: NVIDIA Corporation GP104 [GeForce GTX 1080] (rev a1)

Also, GitHub is still down for me. I’m in Georgia, USA. I even tried changing the mirrors to only Germany as FreeBird suggested, and that didn’t work either.

Have you tried blacklisting the r8169 module?

No, how do I do that?

I’ve checked the mirrors and they seem to be reachable (at least from here) and are perfectly in sync.

Yeah, all the sites reporting on github status say they are fine.

I can’t access github through my home network or through my cell phone’s network. Not sure what’s going on, but it appears to be this region I’m in.

I might try to install my VPN on the liveCD instance and go to another region.

1 Like

VPN in Florida worked. Installing now, I’ll update if it boots or not.

Won’t boot. Just a blinking cursor.

Did you select the Nvidia drivers when you did the online install?

Yes, I selected Nvidia drivers under package selection.

I’m dumb. I had the legacy boot HDD option set in BIOS. Switched it to UEFI HDD boot and that worked. Seems like everything is good-to-go now. Thanks for your all’s help!

1 Like

Hey, as noted in my second screenshot, I still get that “wget service failed” error. How do I fix that?

This is after installation right? Is wget installed? It should be i think.
Check:
pacman -Q wget

Yes, this is after installation. It outputs that wget is installed (v 1.20.3-3)

That wget error is caused by the github error when eos-update-notifier is trying to download a file from github. Fortunately it is not a “dangerous” issue, only this one program is affected.
But you can fix it quite easily as follows.

What it is trying to download are actually two files:

  $HOME/.config/systemd/user/eos-update-notifier.timer
  $HOME/.config/systemd/user/eos-update-notifier.service

Their contents are:

[Unit]
Description=Run EOS update notifier a few times a day

[Timer]
OnStartupSec=30sec
OnCalendar=0/1:25:00
 
[Install]
WantedBy=timers.target

and the second is:

[Unit]
Description=EOS update notifier service

[Service]
Type=oneshot
ExecStart=/usr/bin/eos-update-notifier -systemd

[Install]
WantedBy=eos-update-notifier.timer

respectively. You can copy the above contents to those two files, and then give a command

  eos-update-notifier -init

Then the eos-update-notifier command should be working as expected (i.e. helps you keep your system up to date) without giving that error message.

1 Like

There is some bug in the installer.
Before doing anything in it go to the terminal window behind and search for the info containing the link of the failed attempt to connect to the github server.
Right click on it to open the link in firefox.
If it opens close the installer window and restart the installer.
Now it should run ok.

1 Like