Solved -- Help with Realtek module r8169

using command “lspci -v”,

under Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit

ethernet Controller (rev 15)
Subsystem: ASUSTeK Computer Inc. Device 205f
Flags: bus master, fast devsel, latency 0, IRQ 24, IOMMU group 13
I/O ports at d000 [size=256]
Memory at fc804000 (64-bit, non-prefetchable) [size=4K]
Memory at fc800000 (64-bit, non-prefetchable) [size=16K]
Kernel driver in use: r8169
Kernel modules: r8169

So, wizards of Linux, where does this selection of r8169 happen?

…is " udev rules written by the administrator go in /etc/udev/rules.d/
a clue?

udev should detect your network interface controller (NIC) and automatically load the necessary kernel module at startup. Check the “Ethernet controller” entry (or similar) from the lspci -v output. It should tell you which kernel module contains the driver for your network device.

edit: removal of r8168 package solved my issue

1 Like

I have the same controller in my laptop and had the same issues. Removing everything Reltek worked for me… the r8168 specifically…

I wish you luck!

from experience, removing the r8168 driver package results in LOSS of ethernet network connection.

my guess is that the solution is somewhere in UDEV, not the removal of any package

1 Like

Yes of course it will but install the r8169 in its place maybe do that first

About r8169 it depends your hardware, on mine it’s a r8168 but detected as a r8169, so the install of r8168 made it work…

Try to see first what there is in your hardware !

May have stumbled onto cause of my issue.

removed r8168 package, REBOOTED, r8169 appears under “nmcli”

ethernet network connection working!

1 Like

I tried modules-load.d modprobe.d and default/grub but nothing. I had to manually modprobe r8169 every boot!

BUT Thanks to Mr G and his simple solution I have regular ethernet again!!

Thank you!!