Install KDE on XFCE?

Hi,
I’m an old fan and lover of KDE. I am just worried it won’t run OK on my machine as I had hard times with KDE (Manjaro), freezing, not responsive… etc… wasn’t the Linux I know of.

Finally I installed Endeavour (XFCE) 2 night ago, I couldn’t have option to chose as during installation I couldn’t though I tried lots of tricks to connect to my WI-fi.

Asking experienced users (especially after Kresimir said at I'm limotux, Just Saying Hi! Hope I'm Welcome! - #41 by limotux that currently KDE is lighter than XFCE)

So, I have a few questions:

  1. is KDE really lighter than XFCE recently? on Endeavour?
  2. as I couldn’t get Wi-fi during installation, can I install KDE rom pacman and reboot to KDE? no conflicts? anything to do a fresh KDE install with Wi-fi issue?

Here is my machine:

[limo@lenovo ~]$ inxi -F
System:
  Host: lenovo Kernel: 5.14.5-arch1-1 x86_64 bits: 64 Desktop: Xfce 4.16.0 
  Distro: EndeavourOS 
Machine:
  Type: Laptop System: LENOVO product: 20157 v: Lenovo G580 
  serial: <superuser required> 
  Mobo: LENOVO model: Emerald Lake 2 v: FAB1 serial: <superuser required> 
  UEFI: LENOVO v: 62CN34WW date: 04/26/2012 
Battery:
  ID-1: BAT0 charge: 27.4 Wh (97.5%) condition: 28.1/42.8 Wh (65.6%) 
CPU:
  Info: Dual Core model: Intel Core i5-3210M bits: 64 type: MT MCP cache: 
  L2: 3 MiB 
  Speed: 1199 MHz min/max: 1200/3100 MHz Core speeds (MHz): 1: 1199 2: 1197 
  3: 1197 4: 1253 
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel 
  Device-2: Acer Lenovo Integrated Webcam type: USB driver: uvcvideo 
  Display: x11 server: X.org 1.20.13 driver: loaded: intel 
  unloaded: fbdev,modesetting,vesa resolution: <missing: xdpyinfo> 
  Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  driver: snd_hda_intel 
  Sound Server-1: ALSA v: k5.14.5-arch1-1 running: yes 
  Sound Server-2: PulseAudio v: 15.0 running: yes 
Network:
  Device-1: Broadcom BCM4313 802.11bgn Wireless Network Adapter driver: wl 
  IF: wlan0 state: up mac: 08:ed:b9:97:27:0f 
  Device-2: Qualcomm Atheros AR8162 Fast Ethernet driver: alx 
  IF: enp3s0 state: down mac: f0:de:f1:fd:53:97 
Bluetooth:
  Device-1: Foxconn / Hon Hai Broadcom BCM20702 Bluetooth type: USB 
  driver: btusb 
  Report: rfkill ID: hci0 rfk-id: 3 state: down bt-service: disabled 
  rfk-block: hardware: no software: no address: see --recommends 
Drives:
  Local Storage: total: 465.76 GiB used: 58.21 GiB (12.5%) 
  ID-1: /dev/sda vendor: Seagate model: ST9500325AS size: 465.76 GiB 
Partition:
  ID-1: / size: 456.88 GiB used: 58.21 GiB (12.7%) fs: ext4 dev: /dev/sda2 
  ID-2: /boot/efi size: 511 MiB used: 296 KiB (0.1%) fs: vfat dev: /dev/sda1 
Swap:
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) file: /swapfile 
Sensors:
  System Temperatures: cpu: 54.0 C mobo: 49.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 178 Uptime: 22m Memory: 3.68 GiB used: 1.8 GiB (49.0%) 
  Shell: Bash inxi: 3.3.05 
[limo@lenovo ~]$ 

P.S. I had a few issues with file search and finally installed Dolphin which got Baloo with it (on XFCE) and everything is OK with file search. I love both.

Would my machine be OK with KDE?
Any advice highly appreciated.
Thank you.

Both XFCE and KDE recommend at least 2GB of memory and it looks like you have 4GB on your system if my eyes read that correctly, so theoretically you should be good to run either so long as you aren’t doing too many extensive tasks, i.e. having a bajillion Firefox tabs open.

There is a brief EndeavourOS wiki on installing another DE alongside your current DE since you had wifi issues with the online installation part. Check it out here:

For a slightly more in depth EndeavourOS wiki on removing XFCE (if you so choose, you don’t necessarily have to), here is a more in depth way to remove a DE here:

It’s quite hard to be truly objective which DE is lighter, KDE or XFCE, since it really just depends on your hardware and how you intend to use them. But if your looking for a bit of confidence or encouragement, personally I would opt for KDE of the two choices, since I like that it’s updated constantly. XFCE on the other hand takes their time to push out updates for their DE, so it’s something to consider. Day to day performance would probably hard to tell, they both use few system resources on boot and there are plenty of ways to customize and optimize either.

Truthfully, you can’t go wrong with either option. If you’re dead set on KDE, there’s no point in using XFCE then. But if there’s no rush, I’d say give XFCE a couple days, maybe a week or so and see how you like the feel of it and the performance and maybe then decide if you want to slip into the KDE side of things. Either option is great. Hope this helps a little bit!

2 Likes

From my personal experience both DEs are very comparable in terms of resources. I’m currently on Xfce but I’ve also used KDE on both Manjaro and EOS and I must say that KDE on EOS runs very smoothly. It was more problematic and laggy on Manjaro which I guess is more of a Distro issue.

1 Like

WOW! Thank you Scotty_Trees

Yes you are right I have 4GB RAM, and I don’t do extensive stuff.

I will see if I can get my XFCE desktop to its default look (Get Default View Back?). I know I am naughty and playing around a lot and messing things up!) But I’m addicted since I was a kid to be naughty, even now at this age!
FYI, the reason I was thinking of KDE is sorted out as I installed Dolphin which pulled Baloo with it and everything is fine with me now. (other than the look I messed as mentioned in the other thread).

If I got it sorted out I’m fine… (though I’m sure I’ll mess things up again :rofl:)
Thank you very much. I’ll go through the links you provided.

1 Like

That sounds great. So I may follow the links Scotty_Trees gave me.

Unfortunately it seems to be a distro issue as I tried LXQT and a day or two later it became a bit unresponsive as well.

1 Like

I did

sudo pacman -S plasma-desktop

but

limo@lenovo ~]$ sudo pacman -R qt5ct
error: target not found: qt5ct
[limo@lenovo ~]$ 

Is it OK to just work like this? should I proceed with other commands below?
Will try reboot KDE now :crossed_fingers:

It’s just saying it can’t remove it because it’s not installed on your system. That is okay. qt5ct isn’t needed on KDE anyways, it’s for other DE/WM’s to use for Qt integration, so basically you can safely ignore that message and proceed with testing out KDE.

Edit: Perhaps qt5ct was installed by default in previous versions of EndeavourOS, but maybe now it’s not installed by default so that could be why you saw that message. Perhaps the wiki may need to be edited/updated? @Bryanpwo @manuel ( sorry I forget who all are the old timer wiki maintainers :stuck_out_tongue: )

1 Like

Take it easy. It’s OK. It is not a big issue.
This distro is great, the community is great! Everything is beyond my expectations.

I booted and rebooted again! Wonderful! (though I felt it took a bit longer to boot, maybe because of 2 DE?).
I’ll proceed carefully with removing XFCE only, I don’t want to go allover again installing dropbox. It was a battle yesterday to get it installed. But I got wonderful support from my fellows.

UPDATE:
I just did from https://discovery.endeavouros.com/general-system-settings/removing-a-desktop-environment/2021/03/

`sudo pacman -Rs xfce4 mousepad orage parole ristretto 
thunar-archive-plugin thunar-media-tags-plugin xfce4-battery-plugin 
xfce4-datetime-plugin xfce4-mount-plugin xfce4-netload-plugin 
xfce4-notifyd xfce4-pulseaudio-plugin xfce4-screensaver 
xfce4-screenshooter xfce4-taskmanager xfce4-wavelan-plugin 
xfce4-weather-plugin xfce4-whiskermenu-plugin xfce4-xkb-plugin 
file-roller network-manager-applet leafpad epdfview galculator 
endeavouros-xfce4-terminal-colors xdg-user-dirs-gtk`

with just a few modification like removing leafpad…
Rebooted!
So far so good :crossed_fingers:

2 Likes
yay dropbox

?

KDE is slightly less resource than xfce which is lighter than gnome.

All are kind of irrelevant if you start using multiple tabs of a web browser.

It’s up to you too keep it light.

1 Like

I think everything will be fine.
To be honest, I have no idea at all how to use something other than KDE :blush: I tried various DE’s many times, but I always came back to KDE :slight_smile:
And since the days of Antergos, I have remained loyal to Plasma.
This is just my experience :innocent:

It was a battle, Dropbox Installation

There was a problem with trusting keys or something like that.
But the guys there gave me great support :+1: :+1: :+1:till it was installed.

1 Like

O see 60 posts!

Looks like the fix was just adding


wget https://linux.dropbox.com/fedora/rpm-public-key.asc

gpg --import rpm-public-key.asc

Just in case you consider a fresh install at some point…

1 Like

Well, to me this is a great surprise! If you see my first post you will know where I am coming from! Since 2000 I was on KDE, and it was known to be the heaviest desktop. But I saw many friends here mentioning it it is the same as XFCE if not better.

To me KDE is my Linux home.
So I feel I am home now after almost 8 years away.
Again, this distro and this community exceeded my expectations in everything.

I was told on previous distros I should never think of installing another DE (conflicts… etc. which didn’t sound OK with me), but here I simply just did it.

1 Like

You can, but things can also potentially conflict at some point. I ran for a while gnome and kde but at some point started acting oddly. As long as you know what you are doing, you are in control!

1 Like

I told you it was was a battle! It was very strange for me to find it so stubborn!
But it’s OK now, it is still installed and working fine :crossed_fingers:

I recall that problem last year, took some search to figure this one out but in the meantime Iswitched to nextcloud…

I think its just the signature required to download and build your package, you should be good now.

1 Like

I hope I do :rofl:

I just try to use my brains, consult with more experienced users!

I hope I won’t run through hassles again.

Though I hope developers attend to the issue of no WI-Fi during installation as I’ve seen many posts.

As far as I know, many many users use KDE, and if they find they cant’ install it they will turn away.

I am really eager to se Endeavour #1 on Distrowatch. So far it is the best distro and the best community.

1 Like

:joy: you will probably, but take it as a learning experience.

I learned much more using eos and arch plus forum than previously. For example the problem with gpg signatures and building a package via AUR may be described in the arch wiki. It could be an opportunity to learn how AUR package install works and potentially how to troubleshoot. I also need to spend more time on understanding things like that, as of now I just click yes and install…

1 Like

In a previous post I mentioned that I tend to be naughty even at my current age :rofl: So, I’ll definitely F* things up (Flip things up) as I always play around!

This is what I do most of the time :rofl: