How Can I Search for Files (by content/name/tags...)?

Hi guys,
Again, another question I couldn’t help myself with though I found this How to Add gnome-search-tool to XFCE4 Thunar

To brief you what I did till now (I hope I didn’t mess things up):
I installed catfish, launched it, left it opened, waited for some time. (when I search even file name, nothing indexed)
Then I tried “gnome-search-tool”, nothing
I did tracker:

[limo@lenovo ~]$ tracker status
Currently indexed: 0 files, 0 folders
Remaining space on database partition: 404.4 GB (82.44%)
All data miners are idle, indexing complete

I installed “dconf-editor”, modified some options (file extensions to index to include ‘,doc’, '.pdf’, ‘*.txt’… and waited … nothing.

Well, I’m mainly coming from KDE and was very satisfied with Dolphin + Baloo, where everything works out of the box.

I’m on XFCE now.

  • is it OK to uninstall the above software and install KDE? ( I had trouble with KDE Manjaro, was unresponsive)
  • would it be OK to just uninstall above and ONLY install Dolphin + Baloo under XFCE? (I tend to prefer this rather the full KDE. Will post a few details about my machine below)
  • any other solutions you suggest to have a proper desktop search (indexing content, tags… etc)
    here is my machine:
limo@lenovo ~]$ inxi
CPU: Dual Core Intel Core i5-3210M (-MT MCP-) speed/min/max: 2978/1200/3100 MHz 
Kernel: 5.14.5-arch1-1 x86_64 Up: 3h 58m Mem: 3043.3/3772.8 MiB (80.7%) 
Storage: 465.76 GiB (12.2% used) Procs: 190 Shell: Bash inxi: 3.3.05 
[limo@lenovo ~]$ 

Any help highly appreciated.
EDIT: with all due respect I tried LXQT on Manjaro, then it got a bit heavy and unresponsive! Maybe my machine didn’t like Manjaro. I don’t think it is that weak to handle KDE!

Hey limotux,

I use XFCE with Thunar and Catfish too.

Catfish uses the mlocator-db, wich can updated via Console (~/>sudo updatedb -v)) or via the Catfish-Menu (“Update Search Index” →

To use Catfish in Thunar, i created a new Action (Edit → $User Action (i have a german DE)):

Basic Register

  • Name & Description: feel free :slight_smile:
  • Command: /usr/bin/catfish --path=%F

App Conditions:

  • here i have all Options activated (Search in Directories, Media-Files, aso)

This works quite well for me.

I have it added to Thunar, but it seams it didn’t index the files

I will try

I remember I updated the search index through menu. But not finding anything almost.
Thank you. I’ll let you know how it is going.
UPDATE: There is only one text file xyz.txt that got content indexed. When I search for a word inside it it brings the file up but keeps searching for long. Which I believe means other files are not indexed.
UPDATE: in Custom Actions I have Command:catfish %f
in other tab “Appearance Condition” I checked all check boxes.

UPDATE: I noticed you had catfish %F but I had %f, so changed now to %F. Will update database and see. But what about other parameters at the bottom of the window? should it be %f %F %d %D %N… etc to search everything?
I wonder if that is OK.

%f, %d, %d, %… I think this only affects the selected files/directories. But with %F everything should work, even if no file/directory was selected.

Did you start updatedb with sudo?

1 Like

So it should work now. But not yet.
and yes I did “sudo updatedb -v”

EDIT: result of above command doesn’t include any .doc or .pdf … files. It have things like




Maybe I need to wait a few minutes?

No, if updatedb is done, then…its done. :slight_smile:

Have you activated in catfish “Search inside Files”? In german seems like this:

Yes, it is the third option in the main menu of catfish.

It is strange I get only the text file I put for testing in /home/limo/ , other files are in folders below.

puhhh… :slightly_smiling_face: :upside_down_face: :slightly_smiling_face:

perhaps it will help to reinstall the findutils (, where include updatedb - and recreate the /etc/updatedb.conf

I’m running out of ideas…

1 Like

Ok. I’ll try and see.
Sorry I bothered you.
If it didn’t work I’ll just go to bed in a while. Hopefully tomorrow will see.
Thank you very much and my apologies for bothering you.


limo@lenovo ~]$ yay findutils
3 aur/findutils-git 4.6.0.r235.gf2542a4f-1 (+1 0.00) 
    Basic directory searching utilities of the GNU operating system
2 aur/findutils-selinux 4.8.0-1 (+16 0.00) 
    GNU utilities to locate files with SELinux support
1 core/findutils 4.8.0-1 (487.1 KiB 1.6 MiB) [base-devel] (Installed)
    GNU utilities to locate files
==> Packages to install (eg: 1 2 3, 1-3 or ^4)
==> sudo yay findutils
 there is nothing to do
[limo@lenovo ~]$ 

Will update index again.

All is well!
I just wish I could help you better.

It’s OK. Don’t worry. You did your best. It’s me who sometimes be that unlucky.
I’ll keep trying.
I might even take the risk and install Dolphin and Baloo under XFCE.
But I’ll wait till tomorrow maybe some experienced guy tells me not to do it or to install full KDE.

Sometimes just waiting is a good option

1 Like

Sure. For me it’s about bed time. So I have to wait no matter what.
Have a good night.

Well, after leaving it overnight nothing worked so I just installed Dolphin, I noticed it installed Baloo with it. Indexed everything.
Working perfectly now through Dolphin.
For me this is the best of both worlds. XFCE so light and responsive, and Dolphin + Baloo searching my files. :smiley: :+1: :smiley: :+1:

Just to update you guys.
I ended up installing KDE as per my thread Install KDE on XFCE?

Thanks for all the support you give.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.