I have enough, I am going to switch

:laughing: of course I am not going to switch away from eos!

I switched to gnome 2-3 months ago (before used kde). Although it works great, I am not a huge fan of the workflow for long term use.

Therefore installed kde plasma on my Lenovo with hybrid Intel/Nvidia card last Sunday and used it at work every day. It’s Thursday and I do not have a good time with kde and this hardware (old post, http://ix.io/2HTM)

  1. scaling is going nuts especially with high dpi 4k laptop screen connected to lower resolution screen. I switched off Intel and only run Nvidia, speed is now ok but scaling awful.

  2. I tried to switch icons and global theme but they are not well integrated, for example when I choose a dark theme, text is almost unreadable on certain apps like thunderbird and libre office. Also the theming gui is buggy, sometimes it works sometime it doesn’t

  3. Firefox is acting strange! Often the window is half transparent and I have to resize full/floating to see contents. Gmail is disconnecting constantly, I have to close and reopen Firefox almost every 30 min. Am using now chromium! Never had that before.

There are a lot of little things but they just add up. The worst is the scaling. I want to use a qt based desktop, partly because we use qt framework for coding and it seems install of kde facilitates that out of the box.

so what are my choices at this point. Switch to another DE again, try to fix kde one by one, or just altogether use a WM and forget about kde and gnome? I want to settle and stop messing with my computer.

Am I doomed? Anyone else switching to another DE today?

Perhaps I should go back to i3wm or qtile. Too many choices!

2 Likes

Scaling multiple displays to different resolutions has never been something plasma is particularly good at but others have achieved it. I am not an expert on this though.

It sounds like your gtk and qt themes are mismatched. One of the things I have always liked about plasma is how easy it is to get all the themes matched. This should be an easy fix.

That is obviously not normal and not something most people are seeing. Whatever it is, I am sure it can be fixed.

1 Like

Would have to check, libre office is therefore gtk?

I never had that before but recently Firefox was updated, perhaps I can try to reinstall and reinstall it.

Funny you should ask, i literally just finished installing EOS Cinnamon love it. I used Gnome i think for 2 days, interestingly I do like it more then i thought i would. But what gets me about Gnome is I like Dash to Panel(Don’t like the fact it will break in a few months.) which should be an option in Gnome at install and Cinnamon gives me everything i like.

1 Like

This is the hardest bullet to bite for me.

To be honest, despite the community backlash, I really like gnome on my smaller 13-14 inch laptop, it works great, actually love it. However on a 15 inch gnome drives me nuts, somehow I feel I am wasting screen estate. Perhaps cinnamon might be my :pretzel: bun :rofl: but it is gtk based. Perhaps I am a gtk person after all.

1 Like

Try Cinnamon, it will only cost you some time. :+1:t3:

1 Like

Funny, I had the scaling issues on GNOME, not KDE. :sweat_smile:

Xorg or Wayland? For me fractional scaling on different monitors seemed to work on Wayland.

Under Help > About LibreOffice, the User Interface entry should tell you.

LibreOffice can use gtk or qt. (IIRC, it has its own toolkit but can “integrate” into qt or gtk environments nicely.) I’m not on my EOS machine right now and so can’t be more specific.

1 Like

I agree …try Cinnamon. :slightly_smiling_face:

2 Likes

Can’t say for sure, as I used both versions. I probably was xorg, cause it was needed for gaming.

It’s happening as we speak!

1 Like

Strangely the install with Nvidia ends up with installation failed, external command failed to finish. Command /use/bin/chrooted_cleaner_script.sh failed to finish in 300 s

Looking at the pacman log it tried to install Nvidia. Noticed that also with the kde install. Had to install with nouveau and then install Nvidia driver. Strange as I did not have that problem before.

1 Like

So you got Cinnamon all installed?

1 Like

yep :grin: writting on my cinnamon as we speak! but have to run to work…

1 Like

The only setting on Cinnamon is to turn off Window Effects in Effects.

1 Like

Nvidia fix described here…

1 Like

Mine is on, why turn it off?