I got a black screen when insatalling with Asus laptop

I have downloaded the latest IOS( endeavouros-2021.08.27-x86_64.iso) and burned the bootable usb through Echer, boot the installation by nvidia one.

then show the result like the pic below, and then i got a black screen!

A start job is running for monitoring of LVM2 mirrors snapshots etc…

My device info:

  • Asus fa506
  • ADM R7-4800H, NVIDIA RTX 2060
  • bois setting: secure boot disabled, fast boot disabled

Who can help me!?

Perhaps this thread can help you further:

But right now I can not even access to the live desktop~ :sleepy:

Read the thread carefully, then boot the Live ISO and chroot into your system to replicate the steps offered in the thread. To chroot, follow the steps in this article:

1 Like

Sorry, the problem what I’m facing is I can’t boot the install live ISO.
you mentioned using arch-chroot, that is to let me mout the install usb into other pc first and use chroot method to do somefihing with the install usb system?

You can try to boot with free drivers to continue in live iso, it should work

P.S. Welcome aboard! :rocket:

Sorry for the confusion. Have you tried the non nvidia option? That one should work, but a little advice in your particular case, wait for the next release that will be out on Friday.

i have tried it, but didn’t work as well~t

1 Like

Never mind. the free option gets almost the same result, alse get with the line

A start job is running for monitoring of LVM2 mirrors snapshots etc…
and then black screen.

Again, wait for the next release that is due this Friday. :wink: :gift:

2 Likes

What’s the error?

A start job is running for monitoring of LVM2 mirrors snapshots etc…

That’s not an error message; if the start job succeeds (like the others that say [OK]) it’s completely irrelevant.

Which is set as your primary GPU, and which is wired to output to the panel?

oh thanks for letting me know that.
my primary gpu is nvidia, what do mean wired to output??

Laptops have internal circuitry, and different models will connect either the iGPU or dGPU to the different outputs (e.g. on my new laptop, the iGPU is wired to the panel and dGPU to the HDMI port “for performance” :roll_eyes:).

This means if the “wrong” GPU is initialised then you end up with no output.

In this case, I can see references to setting the amdgpu backlight, which may mean the iGPU is being used for the internal panel.

Check in your BIOS to see if you can switch the laptop panel to the iGPU (might be called “switchable graphics”).

The BIOS in my laptop is not able to disable the GPU like this, maybe I have to give it up and use Ubantu instead. I just cant install both manjaro and EndeavourOS.

Are you able to boot on a another linux and provide the output of your hardware?

inxi -Faz --no-host
System:    Kernel: 5.11.0-40-generic x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.11.0-40-generic 
           root=UUID=9b1b4262-de39-4fc1-b182-5f97ccc4606f ro quiet splash 
           nvme_core.default_ps_max_latency_us=5500 amdgpu.exp_hw_support=1 acpi_osi=Linux 
           cpi_backlight=vendor vt.handoff=7 
           Desktop: Gnome 3.36.9 info: plank wm: gnome-shell dm: GDM3 3.36.3 
           Distro: Ubuntu 20.04.3 LTS (Focal Fossa) 
Machine:   Type: Laptop System: ASUSTeK product: ASUS TUF Gaming A15 FA506IV_FA506IV v: 1.0 
           serial: <filter> 
           Mobo: ASUSTeK model: FA506IV v: 1.0 serial: <filter> UEFI: American Megatrends v: FA506IV.316 
           date: 03/12/2021 
Battery:   ID-1: BAT1 charge: 32.0 Wh condition: 33.0/48.1 Wh (69%) volts: 12.5/11.7 model: ASUS A32-K55 
           type: Li-ion serial: <filter> status: Unknown 
           Device-1: hidpp_battery_0 model: Logitech Marathon Mouse/Performance Plus M705 serial: <filter> 
           charge: 55% (should be ignored) rechargeable: yes status: Discharging 
CPU:       Topology: 8-Core model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP arch: Zen 
           family: 17 (23) model-id: 60 (96) stepping: 1 microcode: 8600104 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 92629 
           Speed: 1391 MHz min/max: 1400/2900 MHz boost: enabled Core speeds (MHz): 1: 1390 2: 1334 
           3: 1397 4: 1397 5: 3352 6: 1889 7: 1697 8: 1258 9: 1378 10: 1363 11: 1396 12: 1439 13: 1218 
           14: 1856 15: 1397 16: 1397 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA TU106 [GeForce RTX 2060] vendor: ASUSTeK driver: nvidia v: 470.82.00 
           bus ID: 01:00.0 chip ID: 10de:1f15 
           Device-2: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel bus ID: 06:00.0 
           chip ID: 1002:1636 
           Display: x11 server: X.Org 1.20.11 driver: amdgpu,ati,nvidia 
           unloaded: fbdev,modesetting,nouveau,vesa compositor: gnome-shell 
           resolution: 1920x1080~144Hz, 1920x1080~60Hz 
           OpenGL: renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2 v: 4.6.0 NVIDIA 470.82.00 
           direct render: Yes 
Audio:     Device-1: NVIDIA TU106 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 chip ID: 10de:10f9 
           Device-2: AMD vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 06:00.1 
           chip ID: 1002:1637 
           Device-3: AMD Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A bus ID: 06:00.5 
           chip ID: 1022:15e2 
           Device-4: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 06:00.6 chip ID: 1022:15e3 
           Sound Server: ALSA v: k5.11.0-40-generic 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8169 
           v: kernel port: e000 bus ID: 02:00.0 chip ID: 10ec:8168 
           IF: enp2s0 state: down mac: <filter> 
           Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: AzureWave 
           driver: rtw_8822ce v: N/A port: d000 bus ID: 03:00.0 chip ID: 10ec:c822 
           IF: wlp3s0 state: up mac: <filter> 
           IF-ID-1: docker0 state: down mac: <filter> 
Drives:    Local Storage: total: 1.43 TiB used: 869.89 GiB (59.3%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS500G1B0C-00S6U0 size: 465.76 GiB 
           block size: physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 serial: <filter> 
           rev: 201000WD scheme: GPT 
           ID-2: /dev/nvme1n1 vendor: Kingston model: OM8PCP3512F-AB size: 476.94 GiB block size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: ECFK52.3 
           ID-3: /dev/sda vendor: Western Digital model: WDS100T2B0A-00SM50 size: 931.51 GiB block size: 
           physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 00WD scheme: GPT 
           ID-4: /dev/sdb type: USB model: aigo U330 size: 29.30 GiB block size: physical: 512 B 
           logical: 512 B serial: <filter> rev: 0000 scheme: MBR 
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
           ID-5: /dev/sdc type: USB vendor: SanDisk model: Ultra USB 3.0 size: 28.64 GiB block size: 
           physical: 512 B logical: 512 B serial: <filter> rev: 1.00 scheme: MBR 
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Partition: ID-1: / raw size: 93.13 GiB size: 91.17 GiB (97.89%) used: 43.22 GiB (47.4%) fs: ext4 
           dev: /dev/nvme0n1p1 
           ID-2: /home raw size: 338.94 GiB size: 332.62 GiB (98.14%) used: 287.82 GiB (86.5%) fs: ext4 
           dev: /dev/nvme0n1p9 
           ID-3: swap-1 size: 32.74 GiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) 
           cache pressure: 100 (default) dev: /dev/nvme0n1p6 
Sensors:   System Temperatures: cpu: 55.4 C mobo: N/A 
           Fan Speeds (RPM): cpu: 2500 
           GPU: device: nvidia screen: :1.0 temp: 48 C device: amdgpu temp: 49 C 
Info:      Processes: 511 Uptime: 20m Memory: 30.78 GiB used: 8.95 GiB (29.1%) Init: systemd v: 245 
           runlevel: 5 Compilers: gcc: 9.3.0 alt: 8/9 clang: 10.0.0-4ubuntu1 Shell: zsh v: 5.8 
           running in: gnome-terminal inxi: 3.0.38 

Are you able to try these kernel parameters on the EndeavourOS live ISO?

1 Like

Do you have a link to the forum thread where you asked for help? Perhaps there’s information there that would prevent duplication of effort.

Maybe. If something works then use it until the thing that doesn’t work works. That also means it doesn’t look like you’re trying to make people feel guilty that they can’t help you.

You might also want to look at the various log files that are available, for example /var/log/Xorg.0.log or when running startx in a terminal:

1 Like