How to add/set language in GNOME?

Installed GNOME DE. Liking it so far, except my language is set to finnish, which I hate. I like to use english as my system language. I tried switching through GNOME’s settings tabs, but there was only the option for finnish. I couldn’t add english.

How do I add other languages to choose from?

Welcome @His_Turdness,

to change it check https://wiki.archlinux.org/index.php/Locale

You need to modify the file /etc/locale.gen
Uncomment (erase) the # to the languages You want

then run as root

locale-gen    

restart x and now you can chose more languages in region and language in Gnome.

I tried setting locale once before and it fcked up my system. For example my plex server would no longer work. So I don’t really want to do that. Is there any other way to change the language only and not mess with locale?

check all this thread, You will know to use your languages with success :

Open “Settings” and go to the “Region and Language” tab

If this works for what you want to do, this is the easiest.

Pudge

First thing I tried. Doesn’t show any other languages.

Could give the result from ?

locale

and

localectl status

Edited language manually (not locale), crossed fingers and ran locale-gen as sudo. I was then enable to set my language as english! No issues with any services either, which is great. Could get used to gnome, though it’s a bit annoying that some basic functionality has to be enabled through extensions. But I’ll forgive it cause the DE looks so clean and works well.

Great you did it ! :rocket: