Install on Rpi 8GB

I think I have it now. If you don’t use post #11, the USB ports don’t work. If you do use post #11 then the screen goes blank after boot. When the boot text is there, then the screen goes blank indicates a video driver problem.

In post #24, I did a fresh install to test the procedure. I did have some video problems when I installed Budgie. The resolutions were acting strange, and a few other things. About a half an hour ago I updated that system. The updates included:
vulkan-headers (1:1.2.179-1 → 1:1.2.180-1)
raspberrypi-bootloader (20210608-1 → 20210615-1)
linux-raspberrypi4 (5.10.43-1 → 5.10.43-2)
vulkan-icd-loader (1.2.177-1 → 1.2.178-1)

After the update, all my video problems were gone. That’s four likely suspects.

Perhaps these updates will fix your problem also?

Pudge

No luck. Here is the sequence of the commands. Maybe you can spot the problem. Appreciate!

Boot from a stick

git clone https://github.com/endeavouros-arm/image-install.git
cd image-install
sudo ./install-image-V2.X.sh

Insert SD into RPi

sudo nmap -sn 192.168.0.0/24
ssh alarm@192.168.0.110 -p 22 #alarm
su #root
ping -c4 endeavouros.com
pacman-key --init
pacman-key --populate archlinuxarm
pacman -Syu git libnewt wget
pacman -R linux-aarch64 uboot-raspberrypi
pacman -S linux-raspberrypi4
sed -i ‘s/mmcblk1/mmcblk0/’ /etc/fstab
cat /etc/fstab
/dev/mmcblk0p1 /boot vfat defaults 0 0
systemctl reboot

After reboot, the RPi 4 should have the USB keyboard active
lower USB only? use Hub!

!!! no signal to monitor

Log into the RPi 4 as root

ping -c4 endeavouros.com #all of this again?
pacman-key --init
pacman-key --populate archlinuxarm
pacman -Syu git libnewt wget
systemctl reboot

git clone https://github.com/endeavouros-arm/install-script.git
cd install-script
./endeavour-ARM-install-V2.X.sh

Edited your last post below:

The second time of pacman-key --init and so forth is not necessary. The first time of initiating keys and updates while ssh into the RPi 4 is all that is necessary.

Optional edit mirrorlist instructions

Use vi or nano to edit /etc/pacman.d/mirrorlist.  Change this
## Geo-IP based mirror selection and load balancing
 Server = http://mirror.archlinuxarm.org/$arch/$repo

To this by adding a # in front of Server to comment out that line
## Geo-IP based mirror selection and load balancing
# Server = http://mirror.archlinuxarm.org/$arch/$repo

Then uncomment mirrors close to you by removing the # in front of desired mirror URLs

Optional enable pacman Parallel Downloads

If you wish to enable Parallel Downloads:
 vi /etc/pacman.conf     (remove the # to uncomment the following line)
 # ParallelDownloads = 5

Good Luck.

Pudge

EDIT:
If it still does not work, the only thing I can think of is RPi 4 doesn’t like your monitor. Try a different monitor or a HDMI TV. My RPi 4 is hooked up to a Samsung LED TV.

1 Like

Almost there:

A Desktop Operating System with your choice of DE will be installed

DE is not my choice just because I happen to be in Germany right now :slightly_smiling_face: Any ideas how to inform the script on the desired Locale? Thanks.

DE stands for Desktop Environment.

1 Like

Sorry, the DE I was referring to is “with your choice of Desktop Environment will be installed”.

I have not played around with informing the script of a different Locale. To change the Locale after everything is installed and up and running, follow the advice found here.
How to add / set language

Pudge

2 Likes

The install of the DE (Gnome) went well :slightly_smiling_face: RPi 4 presented itsself with the gdm login prompt on one monitor AOC 22P2DU.

However, I need to get it to work on monitor Asus VX24AH. Fedora and Ubuntu are not having any problems with this one. Here, it shows boot messages but when it gets to the gdm login screen, it receives no signal any more.

I have not been able to find an appropriate overlay setting in /boot/overlays/README. Any ideas?

Is that Fedora Arm and Ubuntu Arm? If it is Fedora and Ubuntu x86_64 then we are comparing Apples to Oranges.

Running a full blown OS with a Desktop Environment on Arm is still pretty much in the experimental stage. Part of the hazards of being a Pioneer. The biggest speed bump by far is video.

Here is the best info I have found on RPi 4b video settings
Be sure to scroll down to the “HDMI mode options” section. Unless the Asus VX24AH has Composite Video connectors. Composite Video MIGHT be an alternative?

I am guessing that the RPi does not recognize the EDID from the Asus VX24AH monitor. You might have to over ride the EDID and set it up manually in the
/boot/config.txt file. For one TV, I had to add:
hdmi_group=1 (for CEA , the standard typically used by TVs)
hdmi_mode=4 (for 720p 60 Hz)

Worked a treat.
My best advice, for what it is worth, would to be read the link above and start playing with options you think may work. Put on your pioneer hat and have fun! :cowboy_hat_face:

Pudge

1 Like

I meant to upload the install “script” that worked for me before I forget in case s.o. would like to have a go at it but just pictures are allowed?

The party is on when the monitor works. I will look into it later. :soon:

P.S. Apples w/ Apples

1 Like

The Asus VX24AH has a resolution of 2560x1440 (16:9) @ 60Hz which is not found in the official hdmi_mode list.

Hower, both Fedora 34 ARM, Ubuntu 21.04 ARM support it. They do not tell in /boot/config.txt which mode it is.

Any advice?

The only thing I can think of would be to try a lower resolution variant of 16:9 such as 1920x1080. It won’t be the native resolution, but it might be work and be acceptable.

Even if it does work but is not really acceptable, it would prove the resolution is the problem.

Pudge

I tried the lower resolution variant 2/82 and had no success. I also tried the official R-OS for both 32/64 bit which work flawless not having any specific hdmi specified similar to F34 and U2104 i.e. the reason must be in the EndeavourOS/Gnome. That said, it is surprising that all of the other OS support inofficial modes provided that list is up-to-date.

I noticed a hyphen instead of an underscore in config.txt (minor).

I give up :upside_down_face:

See attached the sequence of commands I used that may be helpful to others who do not happen to have a 2K monitor. However, the upload ist not working: you are not authorized… :wink:

EndeavourOS/Gnome support it on 32bit + 64bit :wink: i on 3440x1440 :innocent:

Finally bought a monitor that works, it is worth it: EndeavourOS/Gnome is as fast as my Laptop. I have never before experienced this. That said, Gnome sometimes freezes requiring a reboot. :cowboy_hat_face:

2 Likes

X should be ok . Wayland on p4 + pinebook pro have issue ( like you say ) pinebook pro on 5.13 and same issue

3 Likes

I am glad you have gotten things working. One cannot get a much more efficient computer as far as power. I pull 3 Watts at the 120 VAC outlet at idle and about 5 Watts at load. Measuring the power usage at the outlet includes any inefficiencies in the power supply. Most Ryzen devices waste more power than that just in power supply inefficencies.

My RPi 4b and my Odroid N2+ will handle 85 to 90 % of my daily usage. If I have something to do that is CPU or RAM intensive, I just fire up my Ryzen machine and git 'er done.

Pudge

3 Likes

@ng0177
How old was the monitor that did not work?
There have been numerous versions of HDMI the latest of which is Ver 2.1

I wonder if RPi 4b is version sensitive? It should be backwards compatible, but who knows?

I was also having this problem on my x86_64 device with Gnome 40 on Wayland. I solved it by removing the Firefox package, then installing FIrefox as a flatpak. Has helped greatly.

On my RPi 4b 8GB RAM, I removed the Firefox package but Firefox flatpak for aarch64 was not available. However, Librewolf flatpak for aarch64 was available. Seems to have helped.

If you decide to play around with this, before removing Firefox
Ctrl+Shift+o (the letter o)
Click on “Import and Backup”, then “Backup” and your bookmarks will be saved in a .JSON file. In Librewolf, do the same except click on “Restore”.

Pudge

yes firefox make problem for xwayland /wayland ATM on arm for me . zero problem on x86 yet!

EDit… new update may fix " xorg-xwayland-21.1.2-1 " who know :rofl: it all fun

Thank you. Here some belated answers and comments:

  1. HDMI 1.4 for both monitors

  2. Wayland turned out to be more stable than X11 for me

  3. That said, it is the Gnome Shell that crashes in particular when touching the Dock. I am watching it with journalctl -xe -f

  4. I am quite happy w/ Chromium. I did not found a relation to crashes

  5. It crashes still to often to work with it. I trust the frequent updates to fix it one day

My wishlist includes:

  • audio on the external 3,5 mm socket by pipewire

  • webgl to use Scratch

It is nice that this thread does not get automatically closed after a few days.

2 Likes

Thank you for the feedback. It, for the most part, mirrors my experience also.

Pudge