Hardware for running Linux

Hello fellow members, I want to open this topic to share some pieces of information about the hardware on what I run Linux, and everyone can share theirs and maybe some tips and tricks about what hardware parts work best in Linux.
The whole reason for this topic is that more than once I was asked what on what computer should one run Linux.

As this modern age, laptops are cheap, convenient and some are well-tuned for running Linux, some aren’t.
Will present my opinion on some brands, models. No that some brands, models are not supported.

For the best overall experience, I strongly recommend Lenovo Thinkpads, and not necessarily new ones.
Starting from early models, Thinkpads are very well supported and everything works. Cheap, sturdy, easily upgradable, there is something about those Thinkpads. The X, T, W models are the best.
Now, HP Probook and EliteBook are also very good, but some are a bit stubborn on booting them with default kernel parameters.
Toshiba Tecra good, nothing special.
Dell on all their models are pretty well Linux friendly, the XPS models are made for it.
Asus, Acer, and overall all other brands are ok, nothing to write home about.

On the desktop, very few things to say. Trying not to add too much bias here, AMD video cards are the way to go if you want a smooth experience in Linux, as in for gaming. Not that Nvidia are bad at it, just the drivers are somehow clunky.
Some prebuilt computers from HP are using some weird motherboards, stubborn to boot. If possible, buy parts and build your own.
If anyone wants to share some tips and tricks, you are more than welcome!
Cheers!

4 Likes

I got a Desktop PC with asus board. runs good on linux. minor is with xfwm4 you have to vblank off on kernel linux 5.2 further is runs nice !

System: Host: Konoha Kernel: 5.2.11-arch1-1-ARCH x86_64 bits: 64 Desktop: LXQt 0.14.1
Distro: Endeavouros
Machine: Type: Desktop Mobo: ASUSTeK model: PRIME A320M-K v: Rev X.0x serial:
UEFI: American Megatrends v: 5205 date: 08/01/2019
CPU: Topology: Quad Core model: AMD Ryzen 5 2400G with Radeon Vega Graphics bits: 64
type: MT MCP L2 cache: 2048 KiB
Speed: 1409 MHz min/max: 1600/3600 MHz Core speeds (MHz): 1: 1450 2: 1421
3: 1420 4: 1424 5: 1593 6: 1546 7: 1555 8: 1463
Graphics: Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series]
driver: amdgpu v: kernel
Display: x11 server: X.Org 1.20.5 driver: amdgpu resolution: 1920x1080~60Hz
OpenGL: renderer: AMD RAVEN (DRM 3.32.0 5.2.11-arch1-1-ARCH LLVM 8.0.1)
v: 4.5 Mesa 19.1.6
Audio: Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
Device-2: AMD Family 17h HD Audio driver: snd_hda_intel
Sound Server: ALSA v: k5.2.11-arch1-1-ARCH
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169

https://wiki.archlinux.org/index.php?search=Dell+XPS&title=Special%3ASearch&profile=default&fulltext=1
some of them need some tinkering to run nicely-

And welcome back digital live :wink:

My wife and I have four (4) computers, three of which are now running EndeavourOS (my own ‘main computer’ still runs Antergos; that will be changed in the near future); they are all ZaReason models - two UltraLap 6440 i5 (which we use when traveling and also for some other uses around the house) plus two Verix models which were custom-made by ZaReason for us and which are used by us most of the time (these four are our main computers).

They all originally had Antergos installed and, when we decided to switch, EndeavourOS installed easily and perfectly with absolutely no ‘glitches.’

I also have one other ZaReason computer: a Mediabox to which I was unable to install Antergos (thank you cnchi) but was able to get Manjaro to install. As this computer runs well for the purposes for which we use it, I am leaving it alone.

Now I also have two other computers: an Alienware AW17R3-7092SLV and an Asus ROG Strix GL553VE-DS74. These are both gaming computers which came with Windows 10 installed.

I have ‘wiped’ Windows off of them and originally had Antergos installed (having previously tried several other distros, most notably MX Linux) and now have EndeavourOS installed on both - but the installation was tricky and required several tries.

For whatever reason, I could not install EndeavourOS onto that Alienware with UEFI enabled and Secure Boot disabled. I had to change the entire BIOS to Legacy Mode in order to get EndeavourOS to install.

The Asus was somewhat easier. EOS did install with UEFI enabled and Secure Boot disabled - a good thing as I can find no way to disable UEFI and enter a Legacy Mode which does not appear to be an option on this computer. I did have to edit the installer with modprobe.blacklist=nouveau but, once you know that, installation is easy. (But I evidently do not have the Nvidia graphics card functioning on this computer - nor is it functional on the Alienware. That’s okay - I am not a ‘gamer.’)

I do recommend that, if you plan to buy a new computer, give some extra consideration to the brands (ZaReason, System76, Star Labs, Emperor, etc.). I believe that you will find installing EOS (or any other GNU/Linux distro) to be much easier and much more straightforward.

After all, who needs or wants to ‘fight’ with a computer just to get an operating system installed? I believe that most people just want to use their computers for specific tasks at hand. At least that’s what I want in a computer.

I was formerly somewhat of a ‘distro-hopper’ but no more. I find EndeavourOS to be the most perfect operating system I have ever used. I hope that it stays that way!

Thanks for reading this.

Lawrence

@Anticupidon From my experiences I can’t agree with you, you’ve mentioned most minor laptop producers and made them look like ‘just everything works out of the box’.

I had lenovo w520 which was a nice machine, but it wasn’t that good for linux, I had plenty of issues with bumblebee, nvidia quadro grafics also didn’t worked as expected out of the box. I also had many problems with uefi booting, mostly I had to run linux on legacy bios, and worked best with inegrated graphics off. Tried plenty of distros on that one, from fedora to debian, kali etc etc.

Now I own Acer laptop and this one also isn’t smooth- you need to tweak your sound setting to make it play on all 3 speakers, if you don’t- you can listen everything through subwoofer :wink: And from other forums and bit deeper diggin I noticed that this issue is related to bunch of Acers’ laptops.

Dell xps 13 works really nice with linux, no issues after a year, but on this one I have vanilla arch since very beginning, and no experiments since then.

Plenty of ppl complain on wifi or bleutooth chip issues with different vendors.
Of course hardware is way more compatible these days, but it’s not that painless experience, and anyone moving to linux have to acknowledge that there is some learning curve and troubleshooting involved. Always.

1 Like

@patryk, the elephant in the room is the Nvidia’s Bumblebee switchable graphics.
Linus Torvalds was right, Nvidia is known for giving headaches when it comes to their Linux drivers.
And every brand, model with Bumblebee struggled with Linux, at the cost of people thinking bad about that specific brand/model.
A simple search will give you a hell of a read about that touchy subject.
Alas, each own is entitled to an opinion and from everyone we could learn something.
I say that everybody could and should share configurations and which works best and those who don’t.

Lenovo Thinkpads FTW

X240 - x250 - t440p -w541 and a friend is borrowing a t440s :wink:

1 Like

Amen brother!

1 Like

It’s pretty incredible how popular something like the x200 -x220 still is. Up until the x230 they still had the old kb’s and those machines still keep purring like kittens. They were built to last a life time and it was easy acess to fix anything that broke. Just incredible to see users still asking to buy these ones. They are like 10 ++ years old now

1 Like

I do have a Thinkpad T60 upgraded to a 64bit CPU more RAM + SSD is working like a baby with EOS (i3)

2 Likes

As many forum members watch this thread and ask themselves:
Why in heavens some random guys are so die hard fans of some brand or models?
Well, years ago I was in their place, asking myself why a guy which I know was soo ecstatic about ThinkPads, felt like some other brand cult.
Thing is I work as a computer technician and I fix laptops for a living. Over the years, I became so fond of the simple and outstanding features of engineering built in those machines, and the fact the the manufacturer gave you a list with the spare parts and other parts from another model compatible with yours, was the cherry on the cake.
Bought my first ThinkPad in 2009 was a X200s, which to this day runs perfectly sold it to my mechanic.
Nowadays I own an X220, X230 and a heavy Frannkenpaded T440p.
Since 2009 I distro-hopped continuously, so I’ve tested Linux on those machine heavily.
Not a single issues with ThinkPads, not one. Maybe I’m extremely lucky, but having a simple laptop and install Linux on it just works.
As Tom from Lawrence Systems said : ThinkPads and Linux is a match made in Heaven.
Sorry for the worship, let myself carried away

3 Likes

For me is a part, a Golden Fist Rule. Not too new. had always old pc’s. Maybe here and there some glitch. personal not so fond of Laptops thats subjective. Now a days linux runs on most machines , i think atleast. And sure there are brands thats quicker to share there hardware info.

This desktop i bought this year but hardware wise is not so new, just wat i need. And this time also focussed on Amd before i was using intel/nvidia combo. Experiences can be subjective too dont know why but between same models of systems you can have variety different issues :slight_smile:

1 Like

I run linux on:

Dell PowerEdge T30:

Everything works great!

Lenovo ThinkCentre M710q:

Everything works! One running Windows. Sorry! :wink:

Some HPE servers:

OpenMediaVault on them for backups.

3 Likes

I am on my second Acer laptop on linux and it works flawlessly, love my laptop. Lots to write home about actually.

Edit to add: I am not sure why people buy hybrid laptops, unless you are a true gamer with little space, but I bet that percentage is small. I always build my desktop PC for gaming, and always buy an intel cpu/gpu laptop, and that has no driver issues on linux.

1 Like

If i bought a new laptop right now it would be Ryzen 7 4700U HP

1 Like

I was wondering at this point if you know laptops that you can’t run Linux on. Linux drivers for laptops are pretty good these days.
I had good experiences with:

  • a 2008 Sony Vaio (Core2Duo P8400/Radeon HD3600) - Only tested Ubuntu and Mint, about 6 years ago on it.
  • a 2012 Samsung NP900X4D ( i5-3317U) - Ran Antergos and EndeavourOS perfectly
  • a 2019 MSI Prestige 15 (i7-10710U/GTX1650) - Runs Manjaro and EndeavourOS perfectly except fingerprint sensor (which I don’t use so I didn’t even research to see if it could be made to work)

That’s already Sony, Samsung and MSI.
Add Lenovo, Dell, Acer, Asus and HP already mentioned in this very thread and you already have most major brands.

Maybe we are past the times when installing Linux on a laptop was a hit or miss and having a bad experience is rather an exception?

Ok there is still a struggle to install Nvidia (although there’s a lot of guides out there for enabling hybrid graphics, and there’s also video drivers installers like EndeavourOS and also Manjaro has), and some quirks to get past some BIOS “optimizations”, but once that bridge is crossed it’s smooth sailing.

I’ve got every piece of hardware that I’ve thrown at my Linux OSes recognized (except that sensor I was talking about), wacom tablets, phones, usb-c docks, wireless mice and keyboards, printers, you name it.

Has anyone configured their fingerprint readers, and if so, how well does it work?

I have one, but have never taken the time to see if it works/supported/find out how to install, etc. Not a big priority or necessity really for me, just curious. I know Ubuntu in their latest release has done more with it, supported more devices, etc., one of their selling-points.

This HP has on one it also and i was wondering too how well it works. What does yours show for the device?

lsusb

Edit: I was looking at the setup here. Maybe you can try it out.

It seems mine is supported now. That was not the case in the past.

04f3:0c03 ElanTech Fingerprint Sensor

I do use SDDM as my login manager, which requires extra warnings and finagling. I will have to properly back it up before attempting.

I was looking at the wiki. I don’t know anyone who has mentioned a fingerprint reader here.