GRUB only displaying uefi settings and they only display a black screen

Hello, recently I updated my system again after a while (1-2 weeks) and I noticed that there was a grub discussion going on again with some issues. I updated my system like always and followed the two steps which were shown to me on the terminal which recommended running both grub installation and generation of configuration, so I did. I did not immediately reboot after this and went on my way for a few days again and choose to do another update, this time I rebooted into the following screen.

I tried opening the UEFI firmware settings but end up on a black screen which won’t load anything. I tried booting from my USB into endeavour os, so I could try out the same procedure with the problem grub had in August/September, but I can’t even do that it seem because I always end up with a black screen or on the screenshot I sent.

I would greatly appreciate any help or ideas on how to solve this issue, thank you very much.

Maybe try renaming the /boot/grub/grub.cfg file to .old and then reinstall grub and update grub with the proper command. See if that works to correct the grub configuration file.

Edit: Is this a dual boot set up with Windows?

Thanks for the reply.

My laptop is a single boot device, I only have endeavour os installed on it.

I am sorry to ask, but I don’t know how to rename the cfg file to .old inside the grub command line.

I cannot seem to boot into a live usb to try to chroot or use the terminal like I am used to.

You don’t rename the file there anyway. Are you able to boot on a live ISO? If so can you post this

lsblk -fm

Edit: What are you doing booting on the ISO because it requires arch-chroot. You have to mount the / partition and then mount the /efi partition and the arch-chroot to /mnt using the proper device names of course.

If you arch-chroot from the live ISO you could do grub-install and then run
sudo grub-mkconfig -o /boot/grub/grub.cfg

Edit2: I can walk you through the arch-chroot if you post the output for lsblk -fm

I’ve installed the endeavour os onto an USB per the instructions with Rufus to try to boot into the live usb environment. But it just doesn’t seem to want to boot into it. I am either left on a blank black screen or the screenshot I sent earlier.

I wouldn’t use rufus half the time it doesn’t work. Are you creating it from a Windows computer?

Yes, I have a separate Windows device I use.

I would use etcher to create the live usb first on Windows.

I will try out etcher and see if it works with it.

The outcome is still the same. It just ends up with a blank, black screen. I’m going to try to leave it for a while and see if it is just taking a ridiculous amount of time to boot into something.

If you get the live usb to boot and you are connected to the internet then post your hardware. For this you just post the url.

inxi -Faz | eos-sendlog

also post the output for

lsblk -fm

How did you install it in the first place then?

Edit: Are you using the latest ISO?

Here’s a question? Can you boot it up and switch to a TTY and then see if you can run an update?

sudo pacman -Syu

I installed EOS back in July last year. Everything worked flawlessly back then, the laptop had a windows install prior.

The only thing I can boot into is the grub command line and editing the boot commands. The boot command that is available is:

setparams ‘UEFI Firmware Settings’

If you let it boot to the black screen and switch to a tty with alt f2

Edit: If it will get you to a tty you could try running the update and see what it shows.

Ah, a fellow :clown_face: i see!


This clown is very sad right now, thanks for the welcome regardless!

1 Like

Stop clowning around. We can’t even boot up. :rofl:

Edit: Needs help here… :pray:

1 Like

I tried this now, and sadly it didn’t work either, it just seems to be completely unresponsive once it tries to boot into the UEFI Firmware settings. That’s where the blank screen occurs. I can record a video of my steps if that would help solve this, but so far it’s always been:

  1. Boot up laptop.
  2. Grub boot selection screen → There is only one entry (uefi firmware settings)
  3. Select it and boot into it
  4. Blank screen. (unresponsive)

I want to add that before this issue, endeavour os was an entry in the grub selection, but after I updated and rebooted they were simply gone.

Yeah…I don’t know…
Perhaps it need some live usb + TTY treatment

@joekamprad @dalto ? :upside_down_face: