Gnome online accounts don't work on cinnamon

First of all: already tried solution from this topic, and it didn’t help.
But problem is simple: I try to connect my google account, it allows me to type email, but freezes on password.
Cinnamon version 5.8.4.
Kernel 6.4.4-arch1-1.
Launch from terminal give me this:

[sectos@sectos-tobefilledbyoem ~]$ cinnamon-settings online-accounts
Unknown module online-accounts

( Gtk-WARNING **: 16:13:45.502: Theme parsing error: gtk.css:4700:28: The style property GtkRange:slider-width is deprecated and shouldn’t be used anymore. It will be removed in a future version

( Gtk-WARNING **: 16:13:45.502: Theme parsing error: gtk.css:4702:29: The style property GtkRange:trough-border is deprecated and shouldn’t be used anymore. It will be removed in a future version

( Gtk-WARNING **: 16:13:45.504: Theme parsing error: gtk.css:6742:27: The style property GtkPaned:handle-size is deprecated and shouldn’t be used anymore. It will be removed in a future version

( Gtk-WARNING **: 16:13:45.505: Theme parsing error: gtk.css:7996:1: ‘/*’ in comment block
/usr/share/cinnamon/cinnamon-settings/ DeprecationWarning: Gtk.Window.set_wmclass is deprecated
self.window.set_wmclass(wm_class, wm_class)
Loading Online Account module

let me chack this for you…

sudo pacman -S gnome-online-accounts gvfs-goa
and after relogin or reboot it should appear in general settings gui under Online Accounts:

I can confirm this works as i just installed it on my Cinnamon desktop.

1 Like

Doesn’t help =/
Tried deleting gnome-online-accounts and gvfs-goa, cleaning dependencies, rebooting, installing with the terminal command, rebooting again. But when I try to connect Google account, the application still dying.
Is there any other way to connect an account?

Yes if i click on google it opens a box to allow me to log into google. Not sure why your is showing blanked out?

The first window (for entering a name) appears without problems, but everything freezes on the window for entering a password.

Do you have the setting set in effects to turn off Desktop and Window effects or maybe just Window effects. You could try that and see if it makes any difference?

Turned off effects, but it didn’t help.
I tried this on a virtual machine, and everything works normally (tried on cinnamon and budgie). Could some software be the reason?
Installed apps: vlc, audacious, gimp, kolourpaint, steam, dropbox, google chrome, telegram, thunderbird, tor, transmission, libreoffice, foliate, gnome boxes, double commander, endeavour, psensor.
Deleted evolution, but evolution-data-server refuses to be deleted.
Installed themes: adwaita-1.0, cinnamon-rhino, faience, graphite-one, graphite-zero, jade-1-blue, marwaita-master, Mint-xl_cheese-Aqua.

same blanked login for other online accounts?
could be theming but apps should not cause interference…
you can try set theme to arc or adwaita?
(adwaita would need to install gnome-themes-extra)

And try to login to google into browser does work? it could be a connection issue or related to your security settings on google.

Yes, I tried another Google account, but the same problem occurred.
Clicking on the “Microsoft” variant gives an error: “Error resolving “”: Temporary failure in name resolution”.
Setting apps theme and the desktop theme to Arc didn’t help. Same after deleting all custom themes and relogin.
Google Chrome is my default browser, and it connects to all google services normally.
I also installed KOrganizer today, and it also connects to the account without problems.

firewalld should also not be in the way… but you could try disable iut temprary…sudo systemctl stop firewalld and try again…

I’m not sure. It could be one of the packages you installed. I couldn’t even guess? Or it could be something else such as adwaita?

I just add my own little findings as I encountered a similar problem some time ago, without being able to solve it…
In my case I was under X11, and If I recall correctly, it was linked to a problem with WebKitGTK compositing, used by GOA for the popup dialog.


How did you fix it?

sorry If I wasn’t clear, I could not fix it :rofl:
I just gave up having a google account registered in Gnome.
I am on mobile now, but I’ll try to find the exact thread in WebKit where they were debating the issue.
In the meantime, if that’s the issue, it’d be useful to know if @Sectos05 has a Wayland or X11 session and what graphic card has

update: I was not able to trace back the exact topic in webkit discussion board, but it appears a recurring problem in 2022 as well, affecting ubuntu users as well - bear in mind, should be Wayland in this case.
I can direct you to GOA breaks on 42 in Reddit and Popup Window goes blank when adding Google account in AskUbuntu.
In particular, the compositing issue seems to be solveable WEBKIT_DISABLE_COMPOSITING_MODE=1 gnome-control-center (change with Cinnamon-specific, in your case).
If the issue is the one related with Mesa and Intel GPUs, as in Ubuntu, you might try the solution proposed there, ie. MESA_LOADER_DRIVER_OVERRIDE=x gnome-control-center where x is one of the three alternative drivers - iris/zink/i965.
In my case, I remember I was in X11 with an old Nvidia card and 390xx driver series; I definitely remember it was an issue with that specific combination of X-Server+Nvidia that created issues with WebKit compositing/shading, and preventing me to see the pop-up password box.
I hope to have contributed a bitt and not created even more chaos :sweat_smile:

1 Like


→ This worked for me!!! THANKS!

1 Like

WEBKIT_DISABLE_COMPOSITING_MODE=1 cinnamon-settings online-accounts
Works for me.
But now it forces me to re-login via this terminal command after every reboot.
And the Endeavour app doesn’t sees my Google account for some reason.
Снимок экрана от 2023-07-23 18-32-11

update: What I think about it is that, because I only need an online account to access Google Tasks from my PC, it would be easier for me to install the Thunderbird extension for this purpose.

I’ve never tried Endeavour myself, but I’ve found a similar issue reported in Endeavour gitlab repo (endeavour the application, not OS, to be clear)…
I remember Thunderbird worked with Google Tasks and Calendar via either a plugin or a kind of native tweaking…

update: How to add Google calendar without add-on here they refer to GCalendar, but considering GTasks is a subset of it, tasks might have a CalDav URL as well (honestly never tried that, just the Calendars)

glad it worked, although only temporarily; I think it might depend partly on google side as well, probably, for some reason (unknown to me), either GOA doesn’t manage to process locally the account, or you should grant again Gnome Accounts access as a trusted app in your google account…that’s the only things coming to mind right now