Online Accounts Empty - No Options

My Gnome online accounts is blank with no options at all to add accounts.

Online Accounts is available in System Settings:

Clicking it brings up Online Accounts with only one option, “Information about…”

Clicking that gives me this…

I did find THIS in a year old thread and followed it. No luck.


Do you have kaccounts-providers installed?

I’m on Cinnamon. Do I really need KDE’s kaccounts-providers?

1 Like

Haha…no :slight_smile:

I read the post too quickly while doing something else.

1 Like

are you using autologin?
and is it experiental wayland session or X11?

No autologin, I use X11 because experimental Wayland session sometimes glitches on me. But I tried in both experimental Wayland and X11. Same result. And I verified that gnome-online-accounts is installed.

EDIT: I also disabled Desktop and Window Effects. Not sure if that would have affected anything or not.

From what I remember on helping in this regard is that the issue is mainly about the verification process.

I can check in a VM real quick long time i tried that on Cinnamon… and on Gnome it is currently working as far as i remember…

1 Like

While searching the web for possible solutions, I see that for some, webkit2gtk was an issue. After running pacman -Q to see what is installed on my system, I have 2 versions installed: webkit2gtk-4.1 2.44.1-1 and webkit2gtk 2.44.1-1 .

Not sure if that info helps or not.

[joe@joe-virtualbox ~]$ cinnamon-settings online-accounts
Unknown module online-accounts cannot open shared object file: No such file or directory
Failed to load module: /usr/lib/cinnamon-control-center-1/panels/
/usr/share/cinnamon/cinnamon-settings/ DeprecationWarning: Gtk.Window.set_wmclass is deprecated
  self.window.set_wmclass(wm_class, wm_class)
Loading Online Account module
Could not load online-accounts module; is the cinnamon-control-center package installed?
'NoneType' object has no attribute 'set_no_show_all'

[joe@joe-virtualbox ~]$ locate
[joe@joe-virtualbox ~]$ locate libgoa-backend-

there is a version mismatch… cannot open shared object file: No such file or directory

Downgrading both gnome-online-accounts and libgoa to 3.48.1-1
and the lib version matches again…
a symlink works too i bet

1 Like

Running cinnamon-settings online-accounts I get exactly as you did.

From you next post, I get nothing…

[wombat@endeavour ~]$ locate
[wombat@endeavour ~]$ locate libgoa-backend-
[wombat@endeavour ~]$

what you have installed?
yay -Qs goa

Issue is a that cinnamon-settings needs to get rebuilt against new goalibs

[wombat@endeavour ~]$  yay -Qs goa
local/gnome-online-accounts 3.50.1-1
    Single sign-on framework for GNOME
local/gvfs-goa 1.54.0-2 (gnome)
    Virtual filesystem implementation for GIO (Gnome Online Accounts backend; cloud storage)
local/libgoa 3.50.1-1
    Single sign-on framework for GNOME - client library
local/pinta 2.1.2-2
    Drawing/editing program modeled after Paint.NET. It's goal is to provide a simplified alternative to GIMP for casual
[wombat@endeavour ~]$

So this is an issue Cinnamon needs to address? If so, perhaps I should file a bug? Or at least see if such a bug exists?

yea just checked and even a simple rebuild of cinnamon-settings is not working must be in the releasecode

1 Like
[joe@joe-virtualbox ~]$ LANG=C yay -Qo /usr/bin/cinnamon-settings
/usr/bin/cinnamon-settings is owned by cinnamon 6.0.4-2

oh its not in the cinnamon-settings-daemon it in cinnamon package…

1 Like

i will try rebuilding cinnamon package…

1 Like

uff… its removed: