Gnome 43 Bugs

Greetings lovely community,

Gnome 43 has just landed in the stable Arch repos today (https://archlinux.org/groups/x86_64/gnome/), so I figured I’d update and see how things work. For context, I had a very painless and seamless transition from Gnome 42 to 43, however with all the changes in 43, I expect there to be some issues that will need to be ironed out. It is my intention that we can use this discussion to catalog any bugs/issues/regressions the community comes across and if necessary file the appropriate bug reports upstream. This is similar to my previous thread for the Gnome 42 Bugs.

It’s a good practice before a major Gnome upgrade to disable all your extensions beforehand, in case they interfere with anything. Using the Extensions app or Extensions Manager app has a one click toggle for ON/OFF all extensions. Also, if you’ve upgraded to the latest Gnome and can’t get some extensions to work, you may need to enable legacy extension support if you haven’t already. For that, just open a terminal and enter the following:

gsettings set org.gnome.shell disable-extension-version-validation "true"

If you’re looking for the “new” replacement apps Gnome’s talked about for Gedit and Terminal, they were moved from the AUR to the official Arch repos for this release, those packages being gnome-text-editor and gnome-console respectively. If you don’t already have them installed, feel free to test them out if you’re curious. You can now use pacman (or yay if you prefer) to install them directly from the Arch repos:

sudo pacman -S gnome-text-editor
sudo pacman -S gnome-console

Please feel free to share any bugs you may come across so the community can help report and squash them to make Gnome better, thank you.

For the full official Gnome 43.1 release changelog see this link:
https://ftp-chi.osuosl.org/pub/gnome/core/43/43.1/NEWS

Being a Gnome point release, the bugs and issues should be at a minimal, but as with any major update, please do remember to save and backup your data before updating and rebooting.

One thing I’d like to mention as well, the new top bar Quick Settings got a big UI overhaul, luckily extensions like Quick Bluetooth Connect, Just Perfection, and GSConnect already support this new aspect of Gnome 43. Two brand new extensions worth a quick mention to help customize this new UI aspect are Quick Settings Button Remover and Quick Settings Tweaker.

Here’s a current list of Gnome packages being updated for reference:

:: 74 Packages to upgrade.
74  core/readline                    8.2.0-1                  -> 8.2.001-1
73  extra/adwaita-icon-theme         42.0+r1+gc144c3d75-1     -> 43-1
72  extra/cheese                     41.1-2                   -> 43alpha+r8+g1de47dbc-1
71  extra/eog                        42.3-1                   -> 43.1-1
70  extra/epiphany                   42.4-1                   -> 43.0-1
69  extra/evince                     42.3-2                   -> 43.1-1
68  extra/evolution                  3.44.4-2                 -> 3.46.1-1
67  extra/evolution-data-server      3.44.4-2                 -> 3.46.1-2
66  extra/file-roller                3.42.0-1                 -> 43.0-1
65  extra/firefox                    106.0.2-1                -> 106.0.3-1
64  extra/flatpak                    1:1.14.0-1               -> 1:1.14.0-3
63  extra/folks                      0.15.5-1                 -> 0.15.5-2
62  extra/gcr                        3.41.1-2                 -> 3.41.1-3
61  extra/gedit                      42.2-1                   -> 42.2-2
60  extra/geocode-glib               3.26.4-1                 -> 3.26.4-2
59  extra/gjs                        2:1.72.2-1               -> 2:1.74.1-1
58  extra/gnome-backgrounds          42.0-1                   -> 43-1
57  extra/gnome-calculator           42.2-1                   -> 43.0.1-1
56  extra/gnome-characters           42.0-1                   -> 43.0-1
55  extra/gnome-chess                42.1-1                   -> 43.0-1
54  extra/gnome-clocks               42.0-1                   -> 43.0-1
53  extra/gnome-contacts             42.0-1                   -> 43.0-1
52  extra/gnome-control-center       42.3-2                   -> 43.1-2
51  extra/gnome-desktop              1:42.4-1                 -> 1:43-1
50  extra/gnome-desktop-4            1:42.4-1                 -> 1:43-1
49  extra/gnome-desktop-common       1:42.4-1                 -> 1:43-1
48  extra/gnome-disk-utility         42.0-1                   -> 43.0-1
47  extra/gnome-font-viewer          42.0-1                   -> 43.0-1
46  extra/gnome-logs                 42.0-1                   -> 43.0-1
45  extra/gnome-maps                 42.3-1                   -> 43.1-1
44  extra/gnome-online-accounts      3.44.0-1                 -> 3.46.0-1
43  extra/gnome-photos               1:42.0-1                 -> 1:43.0-2
42  extra/gnome-power-manager        3.32.0-2                 -> 43.0-1
41  extra/gnome-session              42.0-1                   -> 43.0-1
40  extra/gnome-settings-daemon      42.2-1                   -> 43.0-2
39  extra/gnome-shell                1:42.5-1                 -> 1:43.0-2
38  extra/gnome-sudoku               42.0-1                   -> 43.0-1
37  extra/gnome-terminal             3.44.1-1                 -> 3.46.3-2
36  extra/gnome-user-docs            42.0-1                   -> 43.0-1
35  extra/gnome-weather              42.0-1                   -> 43.0-1
34  extra/grilo                      0.3.15-1                 -> 0.3.15-2
33  extra/grilo-plugins              1:0.3.15-1               -> 1:0.3.15-2
32  extra/gsettings-desktop-schemas  42.0-1                   -> 43.0-1
31  extra/gssdp                      1.4.0.1-1                -> 1.6.0-1
30  extra/gupnp                      1:1.4.3-1                -> 1:1.6.0-1
29  extra/gupnp-av                   0.14.1-1                 -> 0.14.1-2
28  extra/gupnp-dlna                 0.12.0-1                 -> 0.12.0-2
27  extra/gupnp-igd                  1.2.0-2                  -> 1.2.0-3
26  extra/libcheese                  41.1-2                   -> 43alpha+r8+g1de47dbc-1
25  extra/libcloudproviders          0.3.1-2                  -> 0.3.1+r8+g3a229ee-1
24  extra/libcryptui                 1:3.12.2+r69+g9c70a43b-1 -> 1:3.12.2+r71+ged4f890e-1
23  extra/libgweather-4              4.0.0-1                  -> 4.2.0-1
22  extra/libmalcontent              0.10.5-1                 -> 0.11.0-1
21  extra/libnautilus-extension      42.2-1                   -> 43.0-1
20  extra/libnma                     1.10.2-1                 -> 1.10.2-2
19  extra/libnma-common              1.10.2-1                 -> 1.10.2-2
18  extra/libnma-gtk4                1.10.2-1                 -> 1.10.2-2
17  extra/liboauth                   1:1.0.3+r15+gac4cf3a-1   -> 1:1.0.3+r16+gc26f038-1
16  extra/libsysprof-capture         3.44.0-2                 -> 3.46.0-1
15  extra/malcontent                 0.10.5-1                 -> 0.11.0-1
14  extra/mutter                     42.5-1                   -> 43.0-1
13  extra/nautilus                   42.2-1                   -> 43.0-1
12  extra/ostree                     2022.6-1                 -> 2022.6-3
11  extra/polari                     42.1-1                   -> 43.0-1
10  extra/polkit                     121-1                    -> 122-1
 9  extra/seahorse                   1:42.0-1                 -> 1:43.0-1
 8  extra/sushi                      42.0-1                   -> 43.0-1
 7  extra/totem                      42.0-1                   -> 43.0-2
 6  extra/totem-pl-parser            3.26.6-1                 -> 3.26.6-2
 5  extra/xdg-desktop-portal-gnome   42.3-1                   -> 43.1-1
 4  community/gnome-connections      42.1.2-1                 -> 43.0-1
 3  community/gnome-tour             42.0-1                   -> 43.0-1
 2  community/libosinfo              1.10.0-1                 -> 1.10.0-2
 1  multilib/lib32-libxau            1.0.9-2                  -> 1.0.10-1
18 Likes

Maybe I’m missing something @Scotty_Trees but I just run my normal updates in Welcome and I see 42.4 is my current Gnome. Since I back up every day and do snapshots, I just let the updates take care of everything.
SO why am I still on 42.4?

You might want to use reflector-simple to update your mirrors. Always after updating your mirrorlist, refresh the entire system with:

yay -Syyu

Once you do that, you should see the new Gnome 43 updates, it’s most likely that you’re mirrors haven’t synced up just yet since it was just released.

1 Like

After I did this, I got pop-tiling back, the only thing I’m missing is my “ideapad mode” options which are Lenovo Legion specific. And I can realistically do all of it with tlp-ui, it was just convenient.

And the sound switcher extension I was using to toggle between my computer / bluetooth speaker doesn’t work. I thought it was somehow included in GNOME 43.

Otherwise, a fairly benign update on my end. Everything seems to be working still.

Edit: I just didn’t know how to do it yet. Looks to be working just fine. So, only one VERY specific extension broke on me.

Screenshot from 2022-10-31 17-14-20

1 Like

You’re syncing to a mirror that hasn’t updated yet, that’s all.

1 Like

Mostly working, but more extension breakage than i’m used to!

Internet Radio

manual fix on github page

Shutdown Timer by Deminder
Not working

system-monitor by Cerin
Not working, nor is system-monitor-next

You can now also enable legacy extension support from a simple toggle on the shell extensions web page

I’m too tired to investigate further :slight_smile:

1 Like

I have both the Extension and Extensions Manager app installed, but the first once will always notify me of any extension updates. Upon a reboot just now after Gnome 43 update, the Extensions app notified me to logout so it could update the Bluetooth Quick Connection. Perhaps you just need to update it because it works for me in Gnome 43.

Screenshot from 2022-10-31 20-26-13

Outr Internet has been up and down for the past 2 weeks, so that would account for the mirrors being out of sync.
I see gnome updates in the list.
Thanks for being ever so alert to the Gnome 43 update.

2 Likes

Everything working here :+1:t3:

3 Likes

Just noticed an issue, but I’m not sure what could be the most likely culprit. Essentially on Gnome 42, my laptop displayed colors perfectly fine. However on Gnome 43, all my colors appear slightly dull and faded. Best way I can describe it is it looks like I have Night Light enabled even though it is off. Reds look like oranges, bright greens are now a dull green like dying grass, and yellows look like dark mustard instead of bright yellow like big bird. Sigh…I had this exact same issue show up on Fedora 37 Beta and Ubuntu 22.10, during my testing which both use Gnome 43 as well.

I suspected previously it might’ve been a Nvidia issue or possibly an Xorg/Wayland issue, but since I’ve been on Xorg this whole time for Gnome 42 and Gnome 43 I think it might more than likely be related to something with Gnome more specifically, perhaps mutter or some other specific color management package. I doubt this is a widespread issue, but if others can’t verify this issue as well, it may be quite difficult to pin point where to troubleshot to let upstream know. Honestly this color issue is a bit of a deal breaker for me, but at this time the only distro that doesn’t have this issue is Ubuntu 22.04 and I’d rather not have to go back there if I can help it, but staring at awful colors all day long is a big issue.

I’m not in the US but we are geographically closer to the US, so I use them.
I would have thought they were updated by now.

everything working here too.
installed gnome-console and gnome-text-editor… nice :ok_hand:

What about GNOME/Web ?
Anyone tried it?

1 Like

There’s like 100 mirrors in the USA, it would depend which one you’re trying to sync with. Just because it’s here in the states doesn’t mean it up to date yet.

Got it. It only gave me 43.0, but I am ok with waiting for it to propagate into the point release on whatever server it is using. I just choose US and give it a long download timeout to account for our dead slow Internet.
image

Ive been running G43 since it hit testing, no issues to report so far

extensions all good, etc.

1 Like

Did you check if a color profile was enabled under color settings?

assuming it might work for G43 you can enable the application for it by editing the

/home/echoa/.local/share/gnome-shell/extensions/extensionfolder/metadata.json

I.E

"_generated": "Generated by SweetTooth, do not edit",
  "description": "Disable the screensaver and auto suspend",
  "gettext-domain": "gnome-shell-extension-caffeine",
  "name": "Caffeine",
  "settings-schema": "org.gnome.shell.extensions.caffeine",
  "shell-version": [
    "40",
    "41",
    "42"
  ],
  "url": "https://github.com/eonpatapon/gnome-shell-extension-caffeine",
  "uuid": "caffeine@patapon.info",
  "version": 42
}

to

"_generated": "Generated by SweetTooth, do not edit",
  "description": "Disable the screensaver and auto suspend",
  "gettext-domain": "gnome-shell-extension-caffeine",
  "name": "Caffeine",
  "settings-schema": "org.gnome.shell.extensions.caffeine",
  "shell-version": [
    "40",
    "41",
    "42",
    "43"
  ],
  "url": "https://github.com/eonpatapon/gnome-shell-extension-caffeine",
  "uuid": "caffeine@patapon.info",
  "version": 42
}

an extension i added recently is older and thats how i get it working

I had a default or standard icc profile on Gnome 42. That same exact file is unchanged in Gnome 43, and I only have one icc profile currently in /home/scott/.local/share/icc

I tried deleting that icc profile and rebooting to see if that corrects any color issue, but was unsuccessful. Looking over some mutter and gnome-shell bug issues, I found this one still open that seems somewhat like my current issue: https://gitlab.gnome.org/GNOME/mutter/-/issues/2217

It says Wayland in the title, but in the comments they mention Xorg is affected as well.

Hmmm…strange

I havent had any problems with my ICC profiles, the only other thing i could think is somehow a different color mode is being used. This can more likely happen when using HDMI and it switches to a non RGB color mode (my monitor does this). I use Display Port though so it defaults to RGB

I’m just using a laptop, no extra displays or monitors, so my configuration is nothing out of the ordinary. I’m just bummed it’s happening because like I said it’s a deal breaker for me.