Gnome 42 Bugs

Greetings lovely community,

Gnome 42 has just landed in the stable Arch repos today (https://archlinux.org/groups/x86_64/gnome/), so I figured I’d update and see how things work. For context, I had a very painless and seamless transition from Gnome 40 to 41, however with all the changes in 42, I expect there to be some issues that will need to be ironed out. It is my intention that we can use this discussion to catalog any bugs/issues/regressions the community comes across and if necessary file the appropriate bug reports upstream.

Right off a fresh reboot, there do appear to be quite a few glaring bugs that I’ve noticed so far.

  1. Logging in, Bluetooth is always set to default OFF, even if it was ON previously.
    Solution: https://wiki.archlinux.org/title/Bluetooth#Auto_power-on_after_boot/resume
    Note: This may or may not be an ideal workaround for some users hesitant with bluetooth security issues, but for my own experience this fix works. Not sure if this is a bug of Gnome 42, bluez, or pulseaudio bug, but this workaround at least allows bluetooth to be ON at startup again.

  2. The GNOME Settings window keeps increasing in size each time it’s reopened. This happens with some (not all) other libadwaita/GTK4 apps as well like Fragments, GDM Login Manager, Gnome Clocks, and various Open Dialog boxes as well open at full screen. I have since confirmed it only happens on Xorg. This issues does not happen on Wayland. Solution: Unknown, but Gnome is aware of the issue. Temporary Solution until Gnome fixes this issue I just found, use the Smart Auto Move extension, it remembers window size and location: https://extensions.gnome.org/extension/4736/smart-auto-move/

  3. Upon a few reboots, my App Draw in overview is normally 4 pages, but for whatever reason it was only displaying 2 pages worth of apps, with a bunch missing. A reboot or two later and it appears back to normal, perhaps the apps list just needed to be repopulated I’m not sure, but it was an odd thing to notice as it makes you think all your apps are gone. Solution: After a few reboots, it repopulated on my end, perhaps some cache issue, not sure. But if you don’t want to wait, you may force the apps to show again by resetting them:
    gsettings reset org.gnome.shell app-picker-layout

  4. If you use the Adwaita/Adwaita-dark theme, the default becomes Adwaita upon upgrade and reboot. But if you prefer a dark style like myself, you’ll have to re-enable it after the update. Gnome Settings > Appearance and select Dark Style. Note this only gets applied to GTK4/libadwaita apps. So in addition, you may need to open Gnome Tweaks tool, under Appearance, change Legacy Applications to your preferred theme. Solution: Found.

  5. In the Overview App Draw, if you had dragged some applications together into a folder, some of those icons may become small/wrong size. To fix this, simply drag them all out and create another app folder with them and the icons should display the correct size. Solution: Found.

  6. Not a bug I noticed, but another user pointed out: “FYI: it looks like it will default you to login with Wayland, even if you have Nvidia, even if you previously had GDM set to Gnome on Xorg.” If you want to check if you’re using Wayland or Xorg, open Gnome Settings, select About and under Windowing System, it’ll say X11 (aka Xorg) or Wayland.

It’s a good practice before a Gnome upgrade to disable all your extensions beforehand, in case they interfere with anything. Using the Extensions app or Extensions Manager app has a one click toggle for ON/OFF all extensions. Also, if you’ve upgraded to the latest Gnome and can’t get some extensions to work, you may need to enable legacy extension support if you haven’t already. For that, just open a terminal and enter the following:

gsettings set org.gnome.shell disable-extension-version-validation "true"

Please feel free to share any bugs you may come across so the community can help report and squash them to make Gnome better, thank you.

Edit: There’s also a discussion on r/archlinux: https://www.reddit.com/r/archlinux/comments/txx3d0/gnome_42_is_here_check_out_extra_repo/

Edit2: If you’re looking for the “new” replacement apps Gnome’s talked about for Gedit and Terminal, they are not yet in the Arch repos, but they are in the AUR if you are curious to test them, FYI. You can find them in AUR as : aur/gnome-text-editor (or -git) & aur/gnome-console (or -git also).

10 Likes

Thanks for sharing your observations. Probably by the end of April we will know if a point release is coming sooner or later.

On a side note, I’m not sure why Gnome doesn’t remember a users preferences for things like bluetooth. I used to have TLP shut it off for me because of the default on setting. And now that TLP is off my system I shut off the bluetooth service. So maybe not a bug in my eyes as I prefer not to use bluetooth because of the potential security risks and annoyances like it auto connecting to my devices that were paired.

1 Like

Great write-up mate.

Follow this https://wiki.archlinux.org/title/Bluetooth#Auto_power-on_after_boot/resume
This should solve issue no 1.

5 Likes

I just updated and am not having this issue on wayland,

to my knowledge this is not a bug but due to a change in how dark styles are handled with libadwaita

I havent encountered this, very weird :thinking:

Nvidia is actually in pretty great shape on Wayland with Gnome if using the latest drivers. Performance is good and since they want Wayland to be the main focus this makes sense.

This is very annoying as it COMPLETELY disables my bluetooth and i have to pop open terminal to get it working again.

I haven’t had any of these thus far… I’ll keep an eye out though

If I go into settings - online accounts and click on one of my configured Google accounts nothing happens

This normally takes you into the settings for that particular account

To those who are using the arc-gtk-theme-eos: this package was updated about an hour ago into our repo.

They said it includes GNOME 42 fixes and more.
See https://github.com/jnsh/arc-theme/releases/tag/20220405.

3 Likes

See also this: [Warning] Pamac update indicator is not compatible for now with Gnome 42

1 Like

Thanks to a patch provided by Barnabás Pőcze on the bug I reported - https://gitlab.manjaro.org/applications/pamac/-/issues/1252 - and a little patch I made, you can use pamac with Gnome 42 until there is a proper fix.

See attached screenshot.

Enjoy!

2 Likes

since the update to gnome42 i have the calendar items listed twice in the menu bar

Make sure that they are not actually recreated at your Calendar provider (Gcalendar?)

After a reboot and a double login to Gnome 42, more and more things are auto-improved :smile:
Some extensions were updated to a compatible state, after re-login.

On my first login, control center had crashes in the logs, without being started from GUI.
After starting GUI, it crashed on the Color section/tab. Then the GUI would not start anymore. After re-login, it started and had focused to my last used section (Color).

Setting User Locale has inconsistencies. On first enter, it was reporting en-US instead of the Greek locale, though Gnome environment was on Greek. Maybe because I use local reset in .{,x}profile for bspwm.
On modification, it seems visually denying the change, but on Section change (and back to Locale), it shows as modification was accepted. :man_shrugging:

Generally it runs fine, but is not stable, of course. (as expected :laughing: )

I do not quite understand this
when I open the calendar app all entries are only available once.

Then you are safe :smile: .
Maybe it’s a cache related thing.
You can report upstream, if it isn’t already reported.

can i “delete” this manually?

Thankyou for being the guinea pig, so we don’t have to :grimacing:
I am on 41 with Wayland using mesa integrated video. I figure next month I will switch.
Does it sound like a plan?
Great work!

1 Like

I have no idea.
I use Bspwm. I was just curious and gave it a sync (=guinea pig) :grin:

1 Like

Took a leap of faith and installed Gnome 42. So far so good.
My needs are pretty simple, so I don’t expect too much drama. It’s happily using Wayland on Gnome.
Then again, I have Dalto’s Btrfs Assistant, so to restore a snaphot is only a few mouse clicks :smiley: :camera_flash:

3 Likes

I’m seeing an issue where in the “Appearance” settings, I see the light vs dark mode selection, but I’m missing almost all of the other options underneath it, including accent colors. I’m using Wayland and I saw this post where someone else had a similar issue and fixed it by installing the gnome-control-center. I tried that and rebooted, but no luck. Anyone else seeing this or have any ideas?

1 Like


This is how mine looks currently.

Gnome 42 only displays Light/Dark style selector, and a collection of Gnome Wallpapers and/or wallpapers that you have added and that’s it for Gnome 42 currently. Now you might have seen news from Ubuntu 22.04 that has their own “accent color” feature they’ve included only for their distro though, it’s not a feature that’s been implemented upstream yet, but Gnome devs are going to implement an accent color (maybe) and recoloring API in Gnome 43, so if you’re desperate for accent colors you’ll want Ubuntu’s latest release.

If you want any of the included Gnome backgrounds, you’ll need the gnome-backgrounds package:

sudo pacman -S gnome-backgrounds

And it’ll look something like this:

3 Likes