Games with DXVK are not launched

Compared to Manjaro, some games that work with DXVK on EndeavourOS are not launched and I have to use the appropriate command on Steam (PROTON_USE_WINED3D = 1). Why didn’t this happen on Manjaro? What is Endeavor missing? I forgot, not all games that use DXVK don’t work, because Snake Pass launches perfectly.

Which games don’t launch? Which games DO launch? Can you send your inxi -Faz?

Not Launched: Duke Nukem 3D, Lego The Hobbit and Alien Swarm Reactive Drop. While, the only DXVK game that works is Snake Pass (among the ones I’ve tried).

Kernel: 5.17.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-linux-zen
root=UUID=8da467b3-f4f7-434c-bd58-7ccb8d021ee1 rw loglevel=3 nowatchdog
nvme_load=YES nvidia-drm.modeset=1
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 wm: kwin_x11 vt: 1
dm: SDDM Distro: EndeavourOS base: Arch Linux
Type: Desktop Mobo: ASUSTeK model: PRIME B450-PLUS v: Rev X.0x
serial: UEFI: American Megatrends v: 0604
date: 12/08/2018
Info: model: AMD Ryzen 5 2600 bits: 64 type: MT MCP arch: Zen+
family: 0x17 (23) model-id: 8 stepping: 2 microcode: 0x800820D
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 576 KiB desc: d-6x32 KiB; i-6x64 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 2x8 MiB
Speed (MHz): avg: 1810 high: 3712 min/max: 1550/3400 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2387 2: 3019
3: 1351 4: 1300 5: 1725 6: 3712 7: 1373 8: 1366 9: 1375 10: 1372 11: 1373
12: 1374 bogomips: 81436
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Retpolines, IBPB: conditional, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Device-1: NVIDIA TU106 [GeForce RTX 2060 Rev. A] vendor: ASUSTeK
driver: nvidia v: 515.43.04 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-05) arch: Turing pcie: gen: 1 speed: 2.5 GT/s
lanes: 16 link-max: gen: 3 speed: 8 GT/s ports: active: none
off: HDMI-A-1 empty: DP-1, DP-2, DVI-D-1, HDMI-A-2 bus-ID: 09:00.0
chip-ID: 10de:1f08 class-ID: 0300
Device-2: Microdia USB 2.0 Camera type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 5-2:2 chip-ID: 0c45:636d
class-ID: 0102 serial:
Display: x11 server: X.Org v: 21.1.3 compositor: kwin_x11 driver: X:
loaded: nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
gpu: nvidia,nvidia-nvswitch display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 108 s-size: 602x342mm (23.70x13.46")
s-diag: 692mm (27.26")
Monitor-1: HDMI-A-1 mapped: HDMI-0 note: disabled model: BenQ LCD
serial: built: 2019 res: 2560x1440 hz: 60 dpi: 109 gamma: 1.2
size: 597x336mm (23.5x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 2560x1440 min: 640x480
OpenGL: renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2
v: 4.6.0 NVIDIA 515.43.04 direct render: Yes
Device-1: NVIDIA TU106 High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 09:00.1 chip-ID: 10de:10f9 class-ID: 0403
Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0b:00.3
chip-ID: 1022:1457 class-ID: 0403
Device-3: Microdia USB 2.0 Camera type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 5-2:2 chip-ID: 0c45:636d
class-ID: 0102 serial:
Sound Server-1: ALSA v: k5.17.9-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.51 running: yes
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 04:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac:
IF-ID-1: anbox0 state: down mac:
Local Storage: total: 1.58 TiB used: 61.89 GiB (3.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Kingston model: SA1000M8240G
size: 223.57 GiB block-size: physical: 512 B logical: 512 B
speed: 15.8 Gb/s lanes: 2 type: SSD serial: rev: E8FK11.R
temp: 38.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD5000AAKS-22V1A0 size: 465.76 GiB block-size: physical: 512 B
logical: 512 B speed: 3.0 Gb/s type: N/A serial: rev: 1D05
scheme: GPT
ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD10EZEX-21WN4A0 size: 931.51 GiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial:
rev: 1A01 scheme: GPT
ID-1: / raw-size: 465.46 GiB size: 457.09 GiB (98.20%)
used: 61.89 GiB (13.5%) fs: ext4 dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 296 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
Alert: No swap data was found.
Message: No sensor data found. Is lm-sensors configured?
Processes: 268 Uptime: 2h 35m wakeups: 0 Memory: 15.62 GiB
used: 4.13 GiB (26.4%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 12.1.0 Packages: pacman: 1044 lib: 301 Shell: Bash v: 5.1.16
running-in: konsole inxi: 3.3.16

You might be missing dependencies

Try following this

And make sure drivers are all good

1 Like

I should have everything installed, just yesterday I installed a 32bit library for nvidia, I also followed the guide that is in the forum and consequently I should be okay. But my problem is certainly because I miss an addiction that was in Manjaro, but which one? And why even in its absence can I start Snake Pass which uses DXVK?

Still should double checked, I’ve missed dependencies and had a similar issue previously. Those 2 guides should cover it all

I did a little test and as I thought I have everything I need, but anyway I have to use WineD3D for some games, through the command PROTON_USE_WINED3D = 1

Did you get a proton log? Enable logging for proton so it’ll tell you what’s missing

Make sure you have all requirements

how do i get it?

I managed to create the log but not so read it, I do not understand anything

Its failing to create vulkan instance

This means there is something strange with your driver setup. AMD vulkan bits didn’t get installed by mistake maybe?

Have you tried different proton versions? Can’t be sure exactly what’s causing it but its driver/vulkan related

Check for lib32-amdvlk

But I have an Nvidia card

All needed Vulkan packages are listed here, see if you have all of them installed please.

steam might have accidentally installed it as a dependency, check if you have any AMD bits

It is unable to create the 32bit vulkan surface and this is a common issue when AMD bits get accidentally installed on nvidia systems

1 Like

I already have everything I need, in theory

How do I check this thing?

There should be no theories, prove it! :laughing:

pacman -Qsq | grep -iE "vulkan|nvidia"
1 Like

im not 100% on this but this might work, I havent been using Arch lately (Fedora is calling me) so i cant test it atm

pacman -Qs | grep -iE "amd"

edit: or what @keybreak posted above me with “amd” instead should work

You were right, I have this 32-bit library for amd, but I don’t have an AMD video card and I don’t know it serves my CPU which is Ryzen, so what do I do? Do I do scorched earth? Do I delete that thing?

local/amd-ucode 20220509.b19cbdc-1
Microcode update image for AMD CPUs
local/lib32-amdvlk 2022.Q2.2-1
AMD’s standalone Vulkan driver