Fresh install 6/10/21 - pacman.conf - no #paralelldownloads

I did a EOS plasma install last night and just wanted to note in the pacman.conf file

#ParallelDownloads = 5

wasn’t there. I know in Arch it is commented out, but it’s there. I don’t know if that’s an oversight or if correct and left out purposely - but I just thought to note for someone to check on the pulled pacman.conf file.

Otherwise another smooth install. Thanks everyone!

You might have to merge pacman.conf.pacnew with pacman.conf.

Add whatever entries you want from /etc/pacman.conf.pacnew into the file /etc/pacman.conf (especially the one for parallel downloads). Then you can remove # from before ParallelDownloads. You will need superuser privilege to edit the file (for example, using sudo).

Oh. And don’t make duplicate entries :relaxed:

Run eos-pacdiff

It was a fresh install last night. so this isn’t the pacnew file merge issue from last week. Thank you for your help though!

@manuel - nothing to do (same outcome with eos-pacdiff in terminal)


What’s you pacman version?

Have you updated the fresh install yet? :thinking:

Thank you. My regular computer is great, and I had no issue adding the line.

I’m merely troubleshooting for other fresh EOS install people. I don’t need “help” - I’m trying to help.


derek@f**kubuntu ~> inxi -Fxxxza --no-host
System:    Kernel: 5.12.9-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-linux-zen 
           root=UUID=251f26d6-bf40-4668-917a-c62af5b237bf rw quiet loglevel=3 nowatchdog 
           resume=/dev/disk/by-uuid/251f26d6-bf40-4668-917a-c62af5b237bf resume_offset=563200 
           Desktop: KDE Plasma 5.22.0 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: EndeavourOS 
           base: Arch Linux 
Machine:   Type: Portable System: Dell product: Inspiron 7548 v: A05 serial: <filter> Chassis: 
           type: 8 serial: <filter> 
           Mobo: Dell model: 0AM6N0 v: A00 serial: <filter> UEFI: Dell v: A05 date: 07/20/2015 
Battery:   ID-1: BAT0 charge: 11.7 Wh (38.1%) condition: 30.7/43.3 Wh (70.9%) volts: 11.2 min: 11.1 
           model: SDI Dell type: Li-ion serial: <filter> status: Discharging 
CPU:       Info: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP arch: Broadwell 
           family: 6 model-id: 3D (61) stepping: 4 microcode: 2F cache: L2: 3 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 17560 
           Speed: 2195 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 2195 2: 2195 3: 2195 4: 2195 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass 
           mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: 
           conditional, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel HD Graphics 5500 vendor: Dell driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:1616 class-ID: 0300 
           Device-2: Sunplus Innovation Integrated_Webcam_HD type: USB driver: uvcvideo 
           bus-ID: 2-5:2 chip-ID: 1bcf:2b8a class-ID: 0e02 
           Display: x11 server: 1.20.11 compositor: kwin_x11 driver: loaded: intel 
           unloaded: fbdev,modesetting,vesa resolution: <missing: xdpyinfo> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel Broadwell-U Audio vendor: Dell driver: snd_hda_intel v: kernel 
           bus-ID: 00:03.0 chip-ID: 8086:160c class-ID: 0403 
           Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Dell driver: snd_hda_intel 
           v: kernel bus-ID: 00:1b.0 chip-ID: 8086:9ca0 class-ID: 0403 
           Sound Server-1: ALSA v: k5.12.9-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.30 running: no 
Network:   Device-1: Intel Wireless 3160 driver: iwlwifi v: kernel port: f040 bus-ID: 07:00.0 
           chip-ID: 8086:08b3 class-ID: 0280 
           IF: wlan0 state: up mac: <filter> 
Bluetooth: Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8 bus-ID: 2-7:4 
           chip-ID: 8087:07dc class-ID: e001 
           Report: This feature requires one of these tools: hciconfig/bt-adapter 
Drives:    Local Storage: total: 223.57 GiB used: 28.3 GiB (12.7%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37240G size: 223.57 GiB 
           block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> 
           rev: 0103 scheme: GPT 
Partition: ID-1: / raw-size: 223.07 GiB size: 218.51 GiB (97.96%) used: 28.3 GiB (13.0%) fs: ext4 
           dev: /dev/sda2 maj-min: 8:2 
           ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 280 KiB (0.1%) fs: vfat 
           dev: /dev/sda1 maj-min: 8:1 
Swap:      Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
           ID-1: swap-1 type: file size: 16 GiB used: 0 KiB (0.0%) priority: -2 file: /swapfile 
Sensors:   System Temperatures: cpu: 51.0 C mobo: 42.0 C 
           Fan Speeds (RPM): cpu: 0 
Info:      Processes: 186 Uptime: 41m wakeups: 1 Memory: 15.54 GiB used: 2.46 GiB (15.8%) 
           Init: systemd v: 248 tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1049 
           lib: 232 Shell: fish v: 3.2.2 running-in: konsole inxi: 3.3.03 
derek@f**kubuntu ~> 


derek@f**kubuntu ~> pacman -Q | grep pacman
pacman 6.0.0-3
pacman-contrib 1.4.0-3
pacman-mirrorlist 20210509-1
derek@f**kubuntu ~> 

derek@f**kubuntu ~> stat / | grep Birth
 Birth: 2021-06-10 18:15:57.000000000 -0700
derek@f**kubuntu ~> 

And in my config file - this section ended with #VerbosePkgLists, I added ParallelDownloads = 10

# Misc options
# We cannot check disk space from within a chroot environment
ParallelDownloads = 10

There was some other line under #ILoveCandy I took out - I think it was TotalDownload or something. But I thought it was odd that the MiscOptions ended at the #VerbosePkgLists and not with #ParallellDownloads = 5 as I was expecting it to.

I gotta get going to work @manuel

Maybe someone out there can spin a VM just to verify the fresh EOS pacman.conf file is correct for new users. Otherwise I’ll give it another go when I get home tonight.

AND the flip side, if that is correctly how EOS wants to ship it out, you can disregard this.

think you mean


eDit … that replace old " TotalDownload "

1 Like

Maybe that’s it. I installed last night and at the time I didn’t think much of it, but this morning I realized - I know to add in the line - others may not.

1 Like



I edited it for this thread actually, I usually put something abrasive in my installs.

My neofetch is way better than that.

Anyway, no shenanigans, not here at least - this thread is serious.

I moved it to the bug report category :wink:

I just did a fresh Gnome VM install and I can confirm @fbodymechanic issue as well.


I just installed EndeavourOS into a VM.
And /etc/pacman.conf.pacnew is not there.

What you could do is

cd /tmp
yay -G pacman
sudo meld pacman/pacman.conf /etc/pacman.conf

and get the changed stuff from the new pacman.conf info your existing /etc/pacman.conf.

But of course, don’t just copy the file. By simply copying you’ll lose all EndeavourOS repos…

@manuel It should be there on a fresh install, this needs further investigation. (and anyone who wants to help us in solving this mystery is more than welcome to join us :wink:)


I’d guess it is an issue with the new pacman.
But I don’t remember ever having this kind of situation with pacman.conf before.

It’s probably just that the line is missing when I pulled the config during install. So whatever you all do when you add the endeavour mirrors into the config file upon installation must be missing that line, that’s all.

I say that with zero idea how it’s actually done. I let you all do the magic. Haha.

1 Like

I am guessing that the problem might be that pacman.conf is copied using Calamares here

The copied file does not have ParallelDownloads.

The offending file (that does not currently have ParallelDownloads) might be either this one or this one.

1 Like

yes exactly… we copy the pacman.conf from ISO to installed system, because we need to add eos repository to it… and the pacman.conf on ISO is pre pacman-6.
We should change to use sed to merge eos repo into pacman.conf so we will not have this in the future.
I mean when was the last time pacman.conf changed ?


Last week hahaha. Before that though, no idea.

1 Like