Fastfetch?

Has anyone tried fastfetch?

I would never add screenfetch/neofetch to my shell startup because of the time delay but if I cared about such things I wouldn’t hesitate with fastfetch, it really is quite fast.

:racing_car:

10 Likes

Like Neofetch, but much faster because written in C

honka_memes-128px-39

Thx for sharing, it’s quite nice!

1 Like

It also comes with another command, flashfetch which is even faster because it is completely precompiled. That being said, I can’t tell the difference in a VM or on bare metal.

i find neofetch really fast if you drop packages

also thx for sharing, never heard of it bevor.
it looks nice and have a little bit more information as neofetch.

1 Like

Wow! That is faster… neofetch took 854 miliseconds and fastfetch took 328.

Not comparatively.

$ time neofetch
real    0m0.566s
user    0m0.278s
sys     0m0.187s

$ time neofetch --disable packages
real    0m0.403s
user    0m0.214s
sys     0m0.167s

$ time fastfetch
real    0m0.019s
user    0m0.001s
sys     0m0.007s
5 Likes

Not even close, compared to that one!

P.S. It need to hit arch repos - deserving! :upside_down_face:

I’ve tried fastfetch. It is much faster than neofetch. Only thing is that it is in the AUR and arch is x86_64. I don’t remember if it works on ARM.
I’ve kept fastfetch in the zshrc of my laptop before.

Edit:
It works on ARM.

@dalto have you tried Macchina. You can customize your fetch.

macchina  0.01s user 0.01s system 67% cpu 0.026 total
4 Likes

Also can be customized btw

3 Likes

I’ve seen the configs is in C and pretty simple. I don’t think there are graphical configurations.
If you see my screenshot of macchina, I’ve customized the rounded corners, text color, delimiter, the dots at the bottom etc.

flashfetch uses the C config which is simple. fastfetch uses the config in ~/.config/fastfetch/config.conf

[scott@EndeavourOS ~]$ yay -S fastfetch
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 endeavouros is up to date
:: Searching databases for updates...
:: Searching AUR for updates...
:: Checking development packages...
:: Starting full system upgrade...
 there is nothing to do
error: Unknown option -S

Hmm, have I somehow messed up my privileges? I haven’t done anything, I’m the only user, but somehow I must’ve broken yay even though I haven’t done anything and I’m fully up to date. Any thoughts?

Do you have an alias or a function for yay that is broken?

What does which yay return?

2 Likes

Nail on the head!

alias yay='yay && flatpak update'

I guess I should probably change that to something else eh?

2 Likes

Yep. At the very least, put yay at the end.

Yes, something that is not yay :rofl:

It is trying to flatpak update -S

Anyway to find out more? I just wanted yay to update pacman/AUR/and flatpaks with yay. Looks like I’ll have to use a new word. I wouldn’t know what else to report other than the “unknown option -S” error :sweat_smile:

Edit: in the meantime I’m just going to change it to this:

alias yup='yay && flatpak update'
``

Have you tried:

alias yay='flatpak update && yay'

Better yet, flatpak updates should be safe so just put them in a systemd timer. That is what I do.

1 Like