External monitor slight flicker then 'sizing' change

Hi everyone!
A question on what I should be looking at…

I have a framework laptop running EOS (been running EOS for about 3 months-ish).
This morning, I started up the laptop. It’s HDMI plugged into an external 24" 1920x1080 Dell monitor.
It worked normally. the next step is where I fudged up
I ran an update, not paying attention to what was being updated because there was a lot (the laptop had been shut down for about 4 days and not been updated for several days before that).
I rebooted.

the external monitor started flickering (not on/off, more of a “trying to find the right resolution” type of flickering) but it was still at the correct 1920x1080 resolution.
I rebooted. (there were several reboots, monitor swaps, and cables swaps in this step because the flickering was giving me a headache)
After 10 or so reboots, the flickering stopped but the resolution change (less desktop space, bigger everything else)
The resolution changed to something smaller but the system still lists it as 1920x1080.
The current problem is the resolution is not displaying what is listed by the system.

I ran inxi and this is what pops up.

$ inxi -Ga
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300
  Device-2: Realtek Laptop Camera type: USB driver: uvcvideo bus-ID: 3-7:4
  chip-ID: 0bda:5634 class-ID: 0e02 serial: 200901010001
  Display: x11 server: X.Org compositor: kwin_x11 driver:
  loaded: intel unloaded: fbdev,modesetting,vesa display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 202 s-size: 242x136mm (9.5x5.4")
  s-diag: 278mm (10.9")
  Monitor-1: DP1 res: 1920x1080 dpi: 92 size: 530x300mm (20.9x11.8")
  diag: 609mm (24")
  Message: Unable to show advanced data. Required tool glxinfo missing.

I ran xrandr and this is what shows up:

$ xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 32767 x 32767
eDP1 connected (normal left inverted right x axis y axis)
   2256x1504     60.00 +  48.00  
DP1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 530mm x 300mm
   1920x1080     60.00 +  50.00*   59.94  
   1920x1080i    60.00    50.00    59.94  
   1600x900      60.00  
   1280x1024     75.02    60.02  
   1152x864      75.00  
   1280x720      60.00    50.00    59.94  
   1024x768      75.03    60.00  
   800x600       75.00    60.32  
   720x576       50.00  
   720x480       60.00    59.94  
   640x480       75.00    60.00    59.94  
   720x400       70.08  
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)
DP4 disconnected (normal left inverted right x axis y axis)
VIRTUAL1 disconnected (normal left inverted right x axis y axis)

What am I missing? The configuration looks correct for my untrained eyes but the screen resolution is REALLY not correct.
I looked at the kernel thinking maybe there was a kernel update that fubar’d the resolution but it is the same version that was running last week with no issues. Currently running 5.14.16-arch1-1
Anyone have a sweet nugget of “you’re an idiot, try this” commands?

Just updating with what I’ve found for posterity…
So after some more digging, it seems it is not related to the DE. I can change the DE and the issue still exists. I use sddm but bounced to lxdm and gdm with no change.
I found a couple references to a similar issue, if not one of the same issue. Apparently, this is know as display x/y chattering. One of the references had the issue for a week or so and it was eventually fixed by an update (because that’s how it is usually fixed).

For reference, if someone else runs into a similar issue, this might work for you (it did not for me): https://www.linuxliteos.com/forums/video-cards/wrong-screen-resolution-lost-use-of-monitor-even-on-rebooting/

And a pseudo fix is in place!

  1. Set the System Settings → Appearance → Global Theme → Fonts → Force Font DPI value to my monitor’s real dpi.
  2. Create a .Xresources file in the home directory that sets Xft.dpi: to my monitor’s dpi value.

Reboot and the correct resolution loads up…mostly. I still have to disconnect my external monitor while the laptop is booting up lest I want to look at display x/y chattering. Once it is booted up, then I can plug in the hdmi cable to output to the external monitor.

Welcome! :enos:

Surely this is connected to X11 update Huge text and icons in KDE Plasma after xorg update
Just very unfortunate timing it will be fixed soon i’m sure :upside_down_face:

1 Like

After my first 2 posts, I looked around the plasma forum and it seems that is my issue (or at least most of my issue). I considered deleting my post but it says that I can not so I leave it here for posterity.

1 Like

It’s fine, someone might find it with search by same symptoms, so it’s good to leave. :wink: