Huge text and icons in KDE Plasma after xorg update

The latest xorg (X11) update has an “interesting” side effect on KDE Plasma. There’s a thread on Reddit about it (with solutions) here -

The solution I have applied is also in this tweet - edit /etc/sddm.conf and add:
ServerArguments=-nolisten tcp -dpi 96

I went with this as it works, and is easy to undo once xorg is fixed.


This option works for me

If you’re not using SDDM as your login manager another thing that worked was forcing the font DPI to be 96 on the systemsettings font configuration module


I deliberately held off system updating because of this xorg jump.

1.21 is the first xorg update for over 3 years and there were bound to be regressions slip through, like this one.

Better IMHO to wait a while, if you can, until at least the next patch release for a fix rather than changing configs temporarily only to have to change them back later.

1 Like

Thanks its work fine for me :+1: :ok_hand:

1 Like

How is that supposed to work if you can’t update partially? Is it possible to exclude from the update? How?

Edit: Has been settled, I had already installed the current versions, without any problems.

This worked for me, thanks!

1 Like

Don’t upgrade til next xorg patch hits, which I think will be very soon, then nothing is done partially.

Next update will be larger than usual, but not too big.

I often delay updates when big updates to key system packages hit stable. There is no rush, waiting a couple of days doesn’t hurt.

Run checkupdates, find the xorg packages in the update …

xf86-input-libinput 1.2.0-1 -> 1.2.0-2
xf86-video-amdgpu 21.0.0-1 -> 21.0.0-2
xf86-video-ati 1:19.1.0-2 -> 1:19.1.0.r9.g5eba006e-1
xf86-video-fbdev 0.5.0-2 -> 0.5.0-3
xf86-video-vesa 2.5.0-1 -> 2.5.0-2
xorg-server 1.20.13-3 -> 21.1.1-2
xorg-server-common 1.20.13-3 -> 21.1.1-2
xorg-xwayland -> 21.1.3-1

Add them to IgnorePkg in /etc/pacman.cong. Update.

This will lead to a partially updated system, which is not supported, but in the short term it should be fine.

When xorg patch hits, remove from /etc/pacman.conf, update as usual.

That said, I am not doing this. Waiting a couple of days is just easier. I like easy.

xorg-server 1.20.13-3 -> 21.1.1-2

Yeah, when I saw this, I said to myself: “I’ll wait a day or two or until someone posts something on the forum…” :grin:

The last time something like this happened, I was still using 'buntu…


Strange as i didn’t have this on my KDE. :thinking:


[ricklinux@eos-kde ~]$ pacman -Qi xorg-server
Name            : xorg-server
Version         : 21.1.1-2
Description     : Xorg X server
Architecture    : x86_64
URL             :
Licenses        : custom
Groups          : xorg
Depends On      : libepoxy  libxfont2  pixman  xorg-server-common  libunwind  dbus  libgl  xf86-input-libinput  nettle  libpciaccess  libdrm  libxshmfence  libxcvt
Optional Deps   : None
Required By     : sddm
Optional For    : None
Conflicts With  : nvidia-utils<=331.20  glamor-egl  xf86-video-modesetting
Replaces        : glamor-egl  xf86-video-modesetting
Installed Size  : 3.64 MiB
Packager        : Andreas Radke <>
Build Date      : Sun 07 Nov 2021 04:04:57 AM
Install Date    : Tue 09 Nov 2021 05:59:19 PM
Install Reason  : Explicitly installed
Install Script  : Yes
Validated By    : Signature

[ricklinux@eos-kde ~]$ 

It was installed yesterday and no issue.

Edit3: On my Arch install i do have this issue. But not on my Eos install on this machine anyway.

Can confirm. It works!
Just gonna remove these when upstream fix will hit the repos.

1 Like

Thank you, it´s working.

On Lenovo Intel Laptop running Artix the error occured.
On Ryzen Desktop PC running Endeavour nothing off it :slightly_smiling_face:

1 Like

From everything I’ve read, this isn’t a bug, but a fix. X11 forced 96 DPI, this update stopped doing that.


I see this too. This probably fixes a lot of issues people have with scaling?

1 Like

It fixed something for my hybrid card and external screen…

FWIW, I tried adding the directives to /etc/sddm

$ cat /etc/sddm.conf
ServerArguments=-nolisten tcp -dpi 96

But things didn’t get fixed until I updated my nvidia drivers which are now at

aur/nvidia-390xx-utils 390.144-3 (+33 1.99) (Installed)
aur/nvidia-390xx-dkms 390.144-3 (+33 1.99) (Installed)
aur/nvidia-390xx 390.144-1 (+53 0.10) 

I am using a rather ancient graphics card

$ inxi -G
Graphics:  Device-1: NVIDIA GF108 [GeForce GT 630] driver: nvidia v: 390.144
           Display: x11 server: X.Org driver: loaded: nvidia unloaded: fbdev,modesetting,vesa resolution:
           1: 1920x1080~60Hz 2: 2048x1080~60Hz
           Message: Unable to show advanced data. Required tool glxinfo missing.
1 Like

Yes, it looks like it’s a “feature” not a bug :thinking:

It prompted me to try out the promised Wayland improvements in Plasma 5.23 - which are significant and it’s now useable for me :+1: Although I still need to edit /etc/sddm.conf as above, or SDDM goes huge :crazy_face:

Looking at the number of the threads that now link to this one, it’s good to see how many people search first for a solution, instead of starting a new thread :wink:

1 Like

I was considering giving wayland a try out on plasma as well. Anything not working for you?

  • Firefox opens as a tiny rectangular window, but that’s easily fixed with a window rule

  • Cantata sometimes gets stuck in the non-expanded interface

  • The :enos: Welcome app does not produce a popup window when I click on “Don’t show me anymore” and then freezes when I try to close the main window (will be reporting this as a bug soon).

  • The Qt V4L2 apps don’t show any video from my webcam (the light comes on but there’s no image). VLC can access it OK though.

That’s it so far. Right click in the system tray works for all my apps. Sticking with it now.


What is strange is i do not have this issue on my Eos KDE but do on my Arch KDE.

Edit: On my EOS KDE and Arch i am running the 5.14.6 kernel (Same)

1 Like

Just got the updated xorg server files and now my Arch KDE is normal again. I removed file contents that were added and is all good. :grinning_face_with_smiling_eyes:


[2021-11-11T15:30:02-0500] [ALPM] upgraded xorg-server-common (21.1.1-2 -> 21.1.1-3)
[2021-11-11T15:30:02-0500] [ALPM] upgraded xorg-server (21.1.1-2 -> 21.1.1-3)