Endevouros boot stuck at "Reached target Graphical Interface"

So the system is EndevourOS, Xfce environment. I can boot to terminal through SHIFT+F2. My videocard is Nvidia GT 640.
Yesterday it worked flawlessly, even worked after updating system.

Look at this thread:

I have 1.8-1 libx11 version, it doesnt help to solve the problem.

Can you post boot logs and hardware logs as per

Welcome to :enos: forums!!

Did that update process include a reboot?

See also:

Here
https://clbin.com/EngWz
https://clbin.com/ajDpB

Yes, included

OK, so what else changed between the update and reboot and you trying the machine today?

Installing Telegram Desktop, Chromium, Steam, nothing special.

Please be specific. Troubleshooting is impossible with generic information.

I thought you said you updated?

1 Like

Sorry for misunderstanding. I didnt update my system.

Yes, installed these programs, nothing more.

Update your system.

It’s pointless being on a rolling-release distro if you don’t update for months at a time.

2 Likes

How to do that out of terminal? I installed the latest iso of endevouros yesterday

yay

or

UpdateInTerminal

You also really need to be aware of the available documentation: https://discovery.endeavouros.com/

@Akse
I assume you used the offline install and did not update the whole system after rebooting?

Yes, ive used offline one. And seems like i didnt update my system after booting.

After offline install (and reboot) the first thing to do is update the installed system.
In terminal you can use e.g. the commands I wrote above.

I guess its updating?

I think there is a lock on the pacman database file. Use the following command to remove it:

sudo rm /var/lib/pacman/db.lck

This happens whenever there is another instance of pacman (package manager) running and/or interrupted.

2 Likes

Updated with yay, problem didnt solve. Linux 5.18.2-arch1-1 now