EndeavourOS & Arch Live USBs fail to boot

Okay, so I’ve been using EndeavourOS on my laptop for over a year now, but when I tried to install it on my brand new desktop with a Ryzen 9 7950X & Nvidia RTX 4090, I get this when choosing the default boot option:
20221112_140321

It hangs until I press the reset button on my computer.

Then when I try to install using the newer Nvidia cards option, I get, well, the exact same thing. But when I choose nomodeset, I get a bit further but then this happens (a link to a video I made showing the issue):

Only Arch & EndeavourOS have these issues; Ubuntu & Fedora appear to be fine, but I want to use EndeavourOS. Does anybody know a way to install it?

Oh, and eos-sendlog hangs when using it.

Edit: Now ZorinOS works, it seems to be something with the Linux-Arch kernel and Nvidia drivers.

I am not sure the current ISO has new enough packages and firmware to boot that hardware.

You may need a newer ISO.

Is there are a newer ISO from either Arch (which I tried the 2022.11.01 release with kernel 6.0.6) or EndeavourOS currently available?

If i would run that system where I live I wouldn’t ne able to pay my energy bill. Nice rig though.

Heh, thanks. :wink: I just am currently running it on Eco Mode with Windows 11 until the kernel version and Nvidia drivers align so I can install EndeavourOS!

And I was replacing a 9900K machine that went through several different GPUs, though the CPU was starting to become a bottleneck.

My laptop is all AMD (AMD CPU & GPU) and that had zero issues with EndeavourOS minus the stock MediaTek RZ616 card, which should have been a budget card, not used in a premium laptop, but it was only $20 - $30 to replace with an Intel AX210, which did work well in EndeavourOS, through the GRUB issue and beyond! :wink:

And here I am running mitigations=off as a kernel parameter to eek out that little bit of extra performance :laughing:

:joy: Though I do force Microshaft Winblows 11 to disable Core Isolation because it feels invasive; the same reason why my main OS is Linux; I don’t like companies telling me what I can and cannot do with my hardware I paid good money for. Not Microshaft, crApple, or Screwgoogle.

1 Like

@cameron
Does the grub command line on boot have this kernel parameter?

nvidia-drm.modeset=1

Yes; should i change it to 0?

Edit: Still froze with the change.

I’m not sure exactly what the issue is but i think it’s not recognizing the hardware in some way. Maybe you can spend some time going through this.

https://download.nvidia.com/XFree86/Linux-x86_64/396.51/README/index.html

I’m a bit concerned that Debian, Ubuntu, & Fedora seem to be just fine with nomodeset, but EndeavourOS is flipping out.

20221112_183137

It’s not showing a driver loaded and it’s also not using open source nouveau. The 7950X has amd graphics doesn’t it? Are you able to hook the monitor to the onboard Hdmi or display port and use the amd graphics to boot on and install. Then you could install the Nvidia graphics shutdown swap the montor to the Nvidia card and try booting on it. :thinking:

Edit: I’m just thinking out loud! Or are you already booting that way?

Edit2: Not likely since i don’t see any amdgpu?

I just tried that and it still either hangs or X crashes…

Did you try it with setting only onboard graphics in Bios and hooked directly to the motherboard HDMI or Display port?

Well that’s odd; while I try your suggestion, this happened with the Arch boot:
16682972126983041274859197476049

Another individual had a similar problem to yours and was able to solve it by building a new ISO.

I tried building a new ISO from the Github files but joe said it doesn’'t work with Calamares currently?

Edit: I don’t know enough to fix it.

You just need to rebuild the calamares_current package.

How?

Would this setting be it?
1668297359527722826199184847990