Endeavour OS ISO download?

A week or so ago, I installed Endeavour OS on my system with the default XFCE “OFFLINE” version. It worked perfectly, and it was the reason that I switched to it.

Now when I go to the website there seems to be only one download.

I was going to install it on a few more PC’s, mainly my parents, but apparently with the only version I can find per .ISO’s it doesn’t seem to play well with NVIDIA cards, or that is IT WORKED BEFORE BUT NOT NOW. It’s simply not a good build Imo. I even did a practice run on my PC and it did not go well at all, and yes I know how to install NVIDIA on LINUX, I’ve done it like 1 thousand times before and by that I mean real world hardware, not virtual machines.

Anyway, I’m not complaining or nothing like that. I’m just wondering where can I get the previous builds where you had a choice as to how you wanted your system installed rather than this “ONE SIZE FITS ALL BUILD” that appears to be the only version available because it obviously does not work at least for me?

1 Like

There is only one ISO.

You choose offline or online when you install.

3 Likes

This is the latest release endeavouros-2021.04.17-x86_64.iso Is that the ISO you downloaded. It should have the offline and online installs on it. That is the only ISO that has been there? :thinking:

Edit:There are different locations to download the ISO but it’s the only one available.

2 Likes

There were other links, or that is the webpage has changed. You could get a ISO with either NO OS, or one with Some stuff installed, or ETC… Where has that gone?

You are thinking of a different distro. There has always only been one ISO as long as I have been here.

You can grab old ones from a mirror but there has never been those types options. The offline installer installs xfce and the online installer lets you choose what to install.

Here is a link to the older ISOs but I think you will find they are all the same, just a single ISO.

1 Like

images

OH NO! I’m so sorry. I just realized, I am thinking of ARCOLINUX, I have tried so many out lately I got confused. Thank you dalto and ricklinux for the extremely fast reply. Faster than any other forums I have been on honestly.

I have vision issues, but that’s no exuse I should have took more time before posting anything. Sorry about that.

I have a backup of my Endeavour setup just to be safe on an external drive or an “Image backup” using foxclone, it works perfect for me. I restore from that.

I have one issue though, when I select “Restart” and restart my PC the mouse cursor ends up in the middle of the screen frozen so I have to press and hold the button to shut everything down and then on a clean start the issue is gone. Is there anything I can do about that? Does it have to do with temp files and memory or is there some command that I can add at startup to refresh that mouse USB port?

Anyway, thank you both, I’m sorry, I just got confused witch the download stuff. Arcolinux has the -S -D- Everything else and it was the one I had tried a few days ago before settling in on Endeavour which I believe is the better OS.

Thanks again!

2 Likes

Is this issue on the install of EndeavourOS that you did the other day or something to do with what you have been trying right now?

1 Like

I am using a Dell XPS 8700 i7 4790, with the Dell keyboard and mouse that came with it.

This is the version that I originally installed using Endeavour. It’s really not that big a deal, but for some reason when I select “restart” the system ends up having the mouse locked up in the middle of the screen. So I have to power off holding the power button and then turn it back on. I also have a MSI GTX 1050TI 4G graphics card, so maybe it is a power issue with this PC. Although everything works okay except for that one thing with the mouse.

It could be an issue with my patience because I haven’t let it just set there longer than a minute though, I normally just press the button the turn off the PC and then re power on and it works from there.

I’m guessing and that all it is because I am no expert at all. I did however setup a Tascam US122L audio device with my system so that is running off of a USB port, so that might be the issue. I posted a message about it on here somewhere.

Thing I can’t figure out though, I mean why would it work on a start from ZERO power and not from restart/reboot that is on command/selection. That’s why I was wondering if there was a refresh command I might could try to refresh the devices or that one port on startup, or maybe a clear memory and refresh. I dunno, I’m guessing and reaching and speculating on things I know nothing about.
I should mention also since I have a SSD I turned off swap, so that might be part of the problem also. I know I"m reaching with my theories here. I don’t think that it’s an Endeavour issue at all, I think that I just have a device with my Tascam US122L and all of that which could be causing that issue to happen.

Anyway, I hope I explained that right, thanks for asking. Maybe I need to put a delay on the startup session where Jack is starting up my Tascam US122L? I might try that.

Anyway thanks again.

1 Like

Talk less read more.

2 Likes

Do not shut down your computer by cutting power to it. That can cause filesystem corruption.

It’s about as graceful as banging your head against the wall when you can’t get to sleep, instead of taking a sleeping pill. It may work a few times, but eventually, it will cause damage.

Instead, when you computer is frozen, you can restart it using the Magic SysRq key:

3 Likes

I have to admit I’m guilty of this sometimes. :grimacing:

Thank you. I’ve realized what the real issue actually is, and it means something is not setup right, and I should say that would go for any operating system being it Linux or Windows or Mac or whatever it may be.
Today I reinstalled my Endevour LInux from an “IMAGE BACKUP” I made using Foxclone and done a little bit more research and realized that at least in my case the issue was permissions and me not being added to certain things concerning my USB Audio device. I got that resolved by fixing the premissions issues and such things and adding myself to groups and adding a few other things, and now everything seems fine.

So now I need to have no issues with my PC freezing when restarting my PC upon making that selection to restart.

One thing about it though, I have swap set to Zero, I have 16GB’s of ram, and a SSD drive, so I figure swap would do more harm than good.

Everything is working great for now honestly. I keep i mage backups just incase. I reinstalled WIn 10 with all my old stuff and went back to my Endeavour setup and done that a couple times.
I realized I like Endeavour the best after a while.

It’s not a HATRED for WINDOWS 10 or WINDOWS for that matter thing, it’s just, I like my Compiz settings and I like the speed that Endevour works at using XFCE4 and the customization. Windows wont let you do nothing, they want to treat you like you are a fish and just swim with the fold and follow thier rules.

Either way, thanks again.

1 Like

I have vision issues, and I try to read so please bear with me when I talk about my reading and reasearch.

1 Like

Having a little bit of swap never harmed anyone. I have 32 GB of RAM and I made a small (6 GB) swap file. I have vm.swappiness lowered to 10. That’s just what works for me.

People are divided on this, some say it’s important to have swap even if you have plenty of RAM and make good arguments, like this:

But there are others who use no swap and have no issues, which by itself, is also a good argument :slight_smile:

In any case, having some swap won’t negatively affect your performance. What can impact performance, though, is having vm.swappiness set too high, when you have plenty of RAM. The default value is 60, and it’s a good idea to lower it a bit (again, for me, 10 seems to be great, you can go as low as 1).

3 Likes

I am using a SSD Solid State Drive though, Swap has always been mentioned as something to not use for those from what I have read anyway. But I don’t know everything so that’s what I have heard.

Although I can say this, the way I have it set now my system is WAY faster than it has ever been using any other operating system be it Linux or Windows 10. I’m actually shocked at how fast it is.
I have tried a lot of OS’s, but Endeavour with arch using XFCE just flat out runs faster than anything I have ever used. I’m guessing that it might have to do that it doesn’t have the SPY crap in it that Windows has in it. Manjaro with Arch starts out fast but progressively gets slower and slower as though it’s phoning home even with me using a SSD drive running it.

I do have another internal Hard Drive but it’s not SSD which I could add a swap file to, but I don’t see the need considering this is working beyond my expectations. Although I realize some programs might ask for swap. I’ll think about it, but for now everything working great.

Thanks

I would argue you should only use swap with an SSD. Putting swap on a HDD is too slow. You might as well let the applications fail instead.

2 Likes

Having a swap file on an SSD is really not a problem. If you have plenty of RAM, it will be used very, very rarely. There are processes on your system that write much more to the SSD than swap.

2 Likes

Oh yeah?!
Try to use Deepin sometimes… :rofl:

Memory leaks are still thing :upside_down_face:

2 Likes

I have mine set to 10 and very occasionally it does kick in. It is obviously system specific though.

1 Like