Dual gpu nvidia/intel

Hello everyone i have a big problem my notebook have a dual gpu nvidia and intel, anyway if i use ubuntu iso all work great but if i use arch (even with bumblebee) still using nouveau and not nvidia-settings … i hope that can i use Endeavuor with this pc because i really appreciate arch and if anyone can help me i like it (sorry for my poor english) in ubuntu i read that i use primus but i make a try with manjaro and i can use optirun and primusrun … i really go crazy about that

1 Like

Hello!

If I understand you correctly you have an nvidia card and an an Intel one.

EndeavourOS has an install script for just that situation:

Install "nvidia-installer ", then run it with the -b option:

“sudo nvidia-installer -b” and it should set it all up correctly for you.

2 Likes

really ? just only this two command ? i’m not dream right ? :grinning:

2 Likes

It worked for me :slight_smile:

sudo pacman -S nvidia-installer
sudo nvidia-installer -b

the “b” option is for installing bumblebee, otherwise it installs it as if you don’t have an intel card, only the nvidia card.

3 Likes

Solve

Whelp, it’s settled. EOS won me over, when can I move in? :rofl:

Seriously, have been going at it for some time. Spared me an aneurysm.

2 Likes

it’s cause me a blank screen always i tried … i can’t use arch :frowning:

I had the exact same problem at the start. Check out my own thread regarding this issue:

ok i’ll try i hope to do it cause i’m tired about make format e reinstall system

1 Like

sudo nvidia-installer -n
will bring back nouveau drivers…

1 Like

HI!

I had exactly the same problem. I installed Endevour OS to an old laptop which originally used Optimus drivers to switch automatically.
I tried the NVIDIA installer with bumblebee, but it did not worked very well. I solved the problem by installing optimus-manager. it is at the end link

This allows you to choose which card to use, and by default uses the Intel so you to avoid the black screen. Although, I wanted to use the NVIDIA drivers, but there seems to be a conflict between the nouveau and NVIDIA drivers, so I blacklisted the nouveau creating a file

/etc/modprobe.d/blacklist.conf

with

blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off
alias lbm-nouveau off

I was able switch between NVIDIA and Intel cards. I also regenerate the initramfs, but
I don’t know if this step was necessary. I hope this helps.