Does KDE use wayland by default?

Does KDE Plasma on EndeavourOS by default use wayland or X11? If it is using Wayland by default does chromium-based browsers use XWayland?

If all of the above is true then how do I get KDE to use X11 instead of XWaylaand?

1 Like

Wayland support on plasma isn’t really ideal yet. They are constantly improving it but there is still a ways to go before everything is solid.

This page lists some of the major issue but there are also lots of minor problems as well.

Why do you ask, are you having an issue?

1 Like

Does it use XWayland for chromium-based browsers (sorry for my lack of knowledge) or x11?

So I made a post How do I fix Chromium-based browser lags and so I still haven’t been able to solve high CPU use for chromium-based browsers. I have been reading on Arch Wiki and there is this post https://bbs.archlinux.org/viewtopic.php?id=237383 and this person claims that using xorg over XWayland solved their lag issue

Nice, so it seems @schmidtbag that you managed to confirm the same conditions that I described in my posts.
I tried running Atom, is also does not work as smooth as it should, although it is not as bad as Chromium. Let me quote one of the comments.

To revise, what we know so far:

  • Running Chromium on Wayland (Gnome, KDE) runs it through XWayland.
  • Running Chromium through XWayland makes it perform poorly.
  • Chroimum works fine on Xorg.
  • If we downgrade xorg-server from 1.20 to 1.19, Chromium works fine on XWayland. But we don’t have to downgrade xorg-server-wayland.

I wonder what is the problem, and can we achieve smt without downgrading? Also, we should report this error/bug somewhere so they fix it. I am not sure where to report it in this case?
@Alynx Zhou have you reported the problem anywhere?

It is using x11 You can check.

echo $XDG_SESSION_TYPE

Edit: https://community.kde.org/KWin/Wayland

xwayland is needed to run wayland

Oh ok thanks, so that means that every application would go through x11 and not XWayLand by default?

Yes.

1 Like