Deepin 20 Arrived

Just got a big upgrade so I guess it’s come out of testing

1 Like

Is it me or does it seem like it needs some additional testing… :innocent:

seems ok to me so far… in fact fixed an issue where I couldn’t access my NAS from File Explorer

I didn’t test that heavily I was just playing around and noticed a few things not working. I just installed into an existing non-deepin installation so maybe it is just me.

I don’t remember everything I noticed but I remember I was unable to set the dark theme in personalization.

Okay. I just tried to set dark theme (and then auto) and it worked for me. Only thing not working is the startup/shutdown/logout sounds; but they never worked in the previous version after a certain update

Anyone know howto re-size the dock in the new deepin version ? also i have a gap between the bottom of the dock and the bottom of the screen … is anyone else seeing this ?
Thanks.

ok, i found how to re-size the dock … just re-size it with the mouse!
I still have the little gap underneath it though :frowning:

I think that gap is supposed to be there. If you would prefer it to be more like a panel at the edge of the screen why not shift it into efficient mode?

Let me know if you mates have problems mounting seperate NTFS data partitions from mechanical spinning disks.
This is what I get:

Exactly the same thing happens on 2 different computers - Must be Deepin-UOS bug

IT certainly wouldn’t surprise me. The first try for Deepin, I couldn’t even log in. It wasn’t the normal lightdm, but something else more styled - and it refused to accept the password. The second time, I got in fine (on lightdm this time), but when I let it go to the screenblanker, on return I got the different login window again, and it wouldn’t accept the password again. Something is odd, there…

I just tried it also today and found it giving me issues with the password also. Lot of times it won’t work.

Just updated to the 2020 version, and noticed a glaring bug, at least for me;
Right click the desktop, go to change the background or sreensaver, and all window chrome disappears; the panel and anything else running. By using the Ctrl Esc I can bring up the menu, but still nothing shows, so I reboot.
Anyone else getting this?

Yes, I’ve got this bug as well. I saw there’s some updates to deepin today but haven’t yet installed and checked it again

This new version was installed too early. Will use another desktop for now.

1 Like

Yes - I installed a 2nd desktop environment (Cinnamon) just in case this Deepin-UOS fails me.

In my opinion it’s best to have a backup desktop environment.
I still consider Deepin-UOS a beta!

1 Like

I’m hitting the background/screensaver bug as well, can someone point me at instructions for installing multiple desktop environments and switching between them after the install (i know the installer has options for this but i have my environment all set so don’t want to do a total re-install).
Thanks.

This was discussed earlier today:

Each desktop will install a session which you should be able to select from your display manager once the new DE is installed.

I am playing with it now. I don’t have any log in issues with authentication. There are some differences as to actions requiring root authentication however. If you want to launch applications like gparted, change clock settings, mount disks etc you need to log out of the current user and log back in as root. I don’t know if this is annoying or a welcome security feature aimed at average users. Back to playing…

1 Like

Thanks.

I am glad to see I am not the only one with troubles.

Megasync gives a segfault on deepin, any other program is giving this?