Dde-dock high cpu usage

Hi!

Being my first post I want to start by expressing my appreciation for the effort of creating and maintaining this awesome distro!

Now, the issue :slightly_smiling_face:

This is an issue I face since 1-2 months ago, and after the latest EndeavourOS realease I’ve reinstalled the distro but the issue is still there.

Long story short, dde-dock process eats a whole thread of my cpu and my laptop gets laggy and hot. I can only restart the dde-dock process and things go normal for 10-15-20 minutes, but after that it begins to eat my cpu again. I usually end up by killing the process permanently and work on my laptop without the taskbar, I prefer it as it helps me be more productive.

My laptop is an ACER Swift 5 SF514-54T.

Please let me know if I can provide more useful info. Thanks!

# hwdetect --show-modules

AGP      : agpgart intel-gtt 
ACPI     : ac battery 
BLOCK    : uvcvideo xhci-hcd xhci-pci typec typec_ucsi ucsi_acpi 
BLUETOOTH: btbcm btintel btrtl btusb bluetooth 
CPUFREQ  : acpi-cpufreq pcc-cpufreq 
CRYPTO   : aesni-intel crc32c-intel crc32-pclmul crct10dif-pclmul ghash-clmulni-intel glue_helper cryptd crypto_simd ecc ecdh_generic 
DRM      : drm_kms_helper drm i915 
HWMON    : coretemp 
I2C      : i2c-algo-bit i2c-i801 
INPUT    : evdev input-leds joydev atkbd mousedev i8042 libps2 serio serio_raw sparse-keymap hid-generic hid hid-multitouch i2c-hid usbhid 
KVM      : kvm-intel kvm 
MEDIA    : videobuf2-common videobuf2-memops videobuf2-v4l2 videobuf2-vmalloc mc uvcvideo videodev 
NET      : fjes iwlwifi bluetooth rfkill cfg80211 
SOUND    : pcspkr ac97_bus snd-compress snd-hwdep snd snd-pcm-dmaengine snd-pcm snd-timer snd-hda-ext-core snd-hda-core snd-intel-nhlt snd-hda-codec-hdmi snd-hda-codec snd-hda-intel snd-soc-hdac-hda snd-soc-acpi-intel-match snd-soc-acpi snd-soc-core snd-sof-intel-byt snd-sof-intel-hda-common snd-sof-intel-hda snd-sof-intel-ipc snd-sof snd-sof-pci snd-sof-xtensa-dsp soundcore 
TPM      : tpm_crb tpm tpm_tis_core tpm_tis 
WATCHDOG : iTCO_vendor_support iTCO_wdt 
OTHER    : intel-cstate intel-uncore rapl rng-core idma64 mac_hid intel-lpss intel-lpss-pci mei_hdcp mei mtd intel-spi intel-spi-pci spi-nor acer-wireless acer-wmi intel-hid intel-wmi-thunderbolt wmi-bmof wmi intel_rapl_common intel_rapl_msr spi-pxa2xx-platform acpi_thermal_rel int3400_thermal int3403_thermal int340x_thermal_zone processor_thermal_device intel_powerclamp intel_soc_dts_iosf x86_pkg_temp_thermal thunderbolt 8250_dw fb_sys_fops syscopyarea sysfillrect sysimgblt crc16 irqbypass 
1 Like
  1. Welcome! :partying_face:

  2. When you use Deepin - prepare to suffer endlessly :rofl:
    :bug: :bug::bug:

  3. To fix bugs like that (hopefully in a quick manner) try to report it upstream

    • Make sure bug report doesn’t already exist
    • Make sure you name your issue like: [Arch Linux] Issue name
    • Check journalctl -p3 -xb if there are errors / segfault of anything related to dde-dock or dde-daemon if so - also share that with devs, it may help.
    • Also add your inxi -Fxxxz, so that they’ll know what configuration you have

My sincere advice - don’t waste your time, as Deepin DE / distro is not a community project and all your efforts and time likely will be lost in a ocean of corporate demands and bugs later anyway :wink:

2 Likes

Thanks for the quick reply.
This is my first arch-based distro and I chose Deepin because it looks very good. Not the best criterion, I know, but I expected to get along well with it as long as it’s the same distro after all.

You raised a good point here and I think I will switch the DE (even I’m a bit sad about that). In this case, how do you recommend to do it? Reinstall EndeavourOS from scratch with another DE? What DE do you recommend? I also want to keep the /home partition as is. I guess this won’t be a significant problem.

1 Like

Don’t get me wrong though - i absolutely love Deepin for looks / UX as well, especially prior to v20 - they get everything right.

It’s cool to experiment with it, see new ideas, test…But for a daily driver just not good solution :woozy_face:


Personally i usually do it from scratch for my workflow, that’s just easier for me :slight_smile:
But if you choose DE and ask here, i’m sure a lot of people could help you switch without reinstall!
And yeah, keeping /home partition should be as easy as just literally keeping it :slight_smile:

That’s a very good question actually…Especially if you liked Deepin because there’s nothing like it :frowning_face:

  1. Usually KDE is a goto solution, i still use it too.

    It is very lightweight and full-featured at the same time.

    You can make it look and behave very good, but it will not be out of the box, defaults there may be wacky for your taste (at least for me it was), but it is extremely customizable and mature DE.

    Search this https://www.reddit.com/r/unixporn/ for KDE examples, you’d be surprised of what you can get from it :slight_smile:

  2. If you aim for something Windows-ish, stable and consistent - try Cinnamon

  3. If you have a lot of time on your hands investigate stuff like that:
    https://www.reddit.com/r/unixporn/comments/de0m3v/awesome_floppy/
    https://www.reddit.com/r/unixporn/comments/fhd70d/awesomewm_floppier/

    But that won’t be easy!

1 Like

No, you don’t have to reinstall, just install the other DE and, if you like, remove it afterwards.
If you’re used to Deepin, then I recommend Gnome, install Dash-to-dock and gnome tweaks afterwards, stretch the dock (in gnome tweaks) and you have the same feel as Deepin.

You could leave deepin next to Gnome because the new Deepin version didn’t reach the Arch repo, I think. This way you can test it and if the issue is solved you can switch back again.

How to add a DE and remove it, you can find on our wiki

3 Likes

there is now also a tutorial to remove a DE:

removing a DE have no foolproof way but we can guide you on your set-up if you want

1 Like

I tried all DEs and I think I will stick to Gnome for the moment. However, one thing I noticed at each DE is that they don’t scale windows and fonts very well. In Gnome I enabled the fractional scaling experimental feature (for Wayland) to scale X1.25 and the non-system apps were blurred/foggy. I think I will keep it disabled unless I find a good way to scale all apps with no blur.

Another issue, but it’s old and I observed it since I first installed Deepin is that sometimes when I start the system my RAM is not detected ok. I have 16GB but in htop it’s displayed 10x less: 1.59GB or something like that. While I was trying all these DEs I had to restart the system more than 10 times, and I think half of them I had only 1.59GB RAM. I guess it’s a driver issue. I did not find a solution because it happened on Deepin OS (not Endeavour OS with Deepin) as well on EndeavourOS (with all DE’s).

And the last issue is that with the default kernel (5.8.X) the sound does not work. I found a half-solution some time ago (in a Manjaro forum I think) in which I can have exclusively Mic or Speaker, bot not both. So I stick with linux-lts (5.4.X) which seems to work well. However, even I’m not sure, I think the RAM issue is only on 5.4.X.

Maybe my hardware is too new and not fully supported by drivers?

On all DEs it’s best to avoid fractional scaling, on both X and Wayland for some reason there are problems with that…

So it’s best to stick to non-fractional values in case on high-dpi for now.

For RAM and Exclusive sound issues, maybe it’s best to create separate threads for each one and post your inxi -Fxxxz, surely we’ll figure something out :wink:

Also when you’ll do, please mention if your BIOS detects the RAM correctly

1 Like

Also when you’ll do, please mention if your BIOS detects the RAM correctly

Now that you mentioned, since last time when I (re)installed EndeavourOS I can’t access BIOS :laughing:. It just hangs in the logo screen. And now I’m starting to make some links in my head: when the RAM thing happens, I can’t access BIOS. I going to open another thread for this one. Thanks!

hello,you are in uefi mode on your bios

Welcome to the community :beers:

hello,you are in uefi mode on your bios

I’ve just fixed that. I removed some boot entries with efibootmgr and got into BIOS.

When I will face the RAM issue again I will get some logs and post them on another thread. Thanks for support guys!

I think @JR29 was asking have you installed in UEFI mode or Bios?

1 Like

it’s installed in UEFI mode.

Myself I don’t find Deepen ready for Arch. There are still too many issues for me. I stick with Xfce, Cinnamon, Plasma, Gnome, or Mate.

1 Like

If you try their distro for long time use, you’ll know that it’s not ready for anything. Arch is just little faster, but it’s same all over :laughing:

1 Like

I’ve also got high usage on dde-dock, so running xfce although I might find a better desktop for HiDPI

I haven’t found one better for hi-dpi as yet than XFCE - but it does take some setting up :grin: Hopefully I’ll have a wiki entry for you on getting it all set, perhaps by the end of the weekend. If not - I’ll post a pointer to a post about it…

What problem is it giving you at the moment?

I’ve got a couple of apps (ktorrent is one) that are not scaling properly. I guess I can replace them with something else

Try Qbittorrent maybe?

1 Like