Dbus-broker is going to be the default D-Bus daemon

Arch announced that they are going to use dbus-broker by default as the D-Bus daemon, to read more go to the official announcement.


edit by @joekamprad adding info image

16 Likes

That was it! I had a problem last night, tried to downgrade dbus and systemd and broke my system quite badly! Didn’t know about the change so I just made it worse :rofl:

I wonder what happened, because updating the system should suggest to replace the old dbus package with the new package. And they are “theoretically” fully compatible and no breakage should happen.

I also recommend to subscribe to Archlinux News with a RSS reader in example: https://archlinux.org/news/

1 Like

eos-update-notifier should also announce the existence of Arch News - maybe check the config

1 Like

I read a bit about this yesterday, and decided to wait to update until my next day off since it looked like there needed to be some manual follow up to enable the new services.

nope, simply choose between broker (recommended) and daemon while updating and that’s it.

The stuff in the RFC on Gitlab is just internal stuff that is done in the background, no user interaction required.

On my system kde crashes during start when dbus-broker-units is used. If I use dbus-daemon-units everything is working as before. There is nothing in the logs that points me to the cause of the issue. So I hope dbus-daemon-units is not removed in the future…

you should add that you are using KDE-Unstable repo’s so your issue is not relevant to normal users who don’t:
https://bbs.archlinux.org/viewtopic.php?id=289413&p=6

and yet there you even post a log message and even have a reply with a possible solution:
https://bbs.archlinux.org/viewtopic.php?pid=2141865#p2141865

Dbus-broker is enabled and running. No mixing of daemon and broker. the first log was not the correct one - I saw this later (of course there is no …daemon… in the logs). My question about locale has no echo… What solution do you mean?

thanks for the update but…

…in a yay update yesterday, yay made me make a choice: update dbus by picking #1 dbus-broker or #2 dbus-whatever-i-cant-remember

in the opposite of a sherlock holmes moment I deduced Arch’s labeling of #1 with the parenthetical subtitle of (default) meant to pick it…

…so I gambled…
…rebooted=success so I have to assume I picked the right dbus. I did not consult internet or forum, I just kind of gambled, or ‘gripped it and ripped it’ as John Daly used to say…

sincerely, ellipsis-obsessed drunk

1 Like

Well:

https://wiki.archlinux.org/title/D-Bus#dbus-broker

The systemd system and user services are triggered by dbus.socket at systemd system and user levels. The sockets trigger the relevant dbus.service , the service file for which is a symlink to dbus-broker.service . The dbus-broker.service thus should not be expressly enabled.

sorry @Bryanpwo forget to post this before i was only adding it as a message on telegram and forget about it after this :roll_eyes:

3 Likes

Why apologize? You’re not the only one responsible for the news feed for this project. I received the announcement and and shared it over here, that’s all. :wink:

3 Likes

indeed :wink:

Don’t worry, i can spread it further by making some HONK!!!

honka_animated-128px-4honka_animated-128px-9honka_animated-128px-15

Gut gut :+1: :smiley:

Shit. I selected D-Bus daemon because I always knew it as what Arch used. RIP :rofl:

Edit: Am I going to have any issues if I don’t switch?

So that’s why my additional drives hang on mounting now perhaps…?

arch said it will be supported for some time:

For the foreseeable future we will still support the use of dbus-daemon, the previous implementation.

i bet there will be an announcement when support is fully stopping… but i would change now so you are safe…

1 Like