Change lock and login screen

I’ve tried changing lock and login screen but I can’t. I’ve tried changing sddm settings but nothing works. When launching sddm from terminal it works, but nothing changes when I try to make any changes. The only change that did something was changing the background picture, and it didn’t worked well and just removed the bg pictures (see attached image, sorry for the poor quality, had no way to screenshot it X3)

Thank you for further help and have a great day

What does the contents of /etc/lightdm/slick-greeter.conf look like?

If that file doesn’t exist, create it and add the following entries:


Note: It is recommended to place your wallpapers inside directories that the lightdm user can access; for example, /usr/share/pixmaps

Other configuration options are available as well. Here is a list of all configurable options for slick greeter:

# LightDM GTK+ Configuration
# Available configuration options listed below.
# activate-numlock=Whether to activate numlock. This features requires the installation of numlockx. (true or false)
# background=Background file to use, either an image path or a color (e.g. #772953)
# background-color=Background color (e.g. #772953), set before wallpaper is seen
# draw-user-backgrounds=Whether to draw user backgrounds (true or false)
# draw-grid=Whether to draw an overlay grid (true or false)
# show-hostname=Whether to show the hostname in the menubar (true or false)
# show-power=Whether to show the power indicator in the menubar (true or false)
# show-a11y=Whether to show the accessibility options in the menubar (true or false)
# show-keyboard=Whether to show the keyboard indicator in the menubar (true or false)
# show-clock=Whether to show the clock in the menubar (true or false)
# show-quit=Whether to show the quit menu in the menubar (true or false)
# logo=Logo file to use
# other-monitors-logo=Logo file to use for other monitors
# theme-name=GTK+ theme to use
# icon-theme-name=Icon theme to use
# font-name=Font to use
# xft-antialias=Whether to antialias Xft fonts (true or false)
# xft-dpi=Resolution for Xft in dots per inch
# xft-hintstyle=What degree of hinting to use (hintnone/hintslight/hintmedium/hintfull)
# xft-rgba=Type of subpixel antialiasing (none/rgb/bgr/vrgb/vbgr)
# onscreen-keyboard=Whether to enable the onscreen keyboard (true or false)
# high-contrast=Whether to use a high contrast theme (true or false)
# screen-reader=Whether to enable the screen reader (true or false)
# play-ready-sound=A sound file to play when the greeter is ready
# hidden-users=List of usernames (separated by semicolons) that are hidden until Ctr+Alt+Shift is pressed
# group-filter=List of groups that users must be part of to be shown (empty list shows all users)
# enable-hidpi=Whether to enable HiDPI support (on/off/auto)
# only-on-monitor=Sets the monitor on which to show the login window, -1 means "follow the mouse"
# stretch-background-across-monitors=Whether to stretch the background across multiple monitors (false by default)
# clock-format=What clock format to use (e.g., %H:%M or %l:%M %p)

Where is your wallpaper file located?

Do you mean you’re trying to change a greeter or are you just trying to change the background? EndeavourOS uses slick greeter and lightdm by default.

@MoreOwO says sddm is being used, but I agree with @anthony93, the image looks like lightdm.

So I guess we need to establish which Desktop Manager is in use. Please show the results of the two commands

pacman -Q sddm
pacman -Q lightdm


1 Like

Indeed. And if memory serves, EOS uses lightdm by default.

I hate to get nit picky, but the Desktop Manager installed by default depends on which Desktop or Window manager is installed. However, most of them do use lightdm & lightdm-slick-greeter.


The screen shot looks like the password entry box has the LXQT logo?


There is also this GUI tool for editing Lightdm:

1 Like

I’m using KDE as default windows manager. I don’t know if i’m using lightdm or sddm, i just know both were installed.

$~ yay -Q sddm
sddm 0.20.0-1
$~ yay -Q lightdm
lightdm 1:1.32.0-4

Content of slick-greeter, which is not really accurate with what i can notice on my logging screen.


SDDM seems to be way more stylable so if I can switch to it (if I’m not using it), it would be pretty nice (ofc, correct me if i’m wrong)
Please forward me to docs I could use to do that.

I don’t know if it’s related, but when running sudo sddm from terminal, it shows sddm right, but when I try to login, it just go black and does nothing.


please show the output of the following. This will tell whether Lightdm or sddm is enabled.

systemctl status sddm

systemctl status lightdm


This sounds like lightdm is enabled and sddm is not.

the picture looks like lightdm :thinking:

looks like mine(lightdm)

You can get the answer with only one command:

systemctl status display-manager

The above name is an Alias/link which is used by all DMs whenever they are enabled/started. :wink:

1 Like

LightDM is in use

$~ systemctl status display-manager
● lightdm.service - Light Display Manager
     Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; preset: disabled)
    Drop-In: /etc/systemd/system/display-manager.service.d
     Active: active (running) since Fri 2023-08-11 10:09:45 CEST; 18s ago
       Docs: man:lightdm(1)
    Process: 949 ExecStartPre=/usr/bin/plymouth deactivate (code=exited, status=0/SUCCESS)
    Process: 1048 ExecStartPost=/usr/bin/sleep 30 (code=exited, status=0/SUCCESS)
    Process: 3090 ExecStartPost=/usr/bin/plymouth quit --retain-splash (code=exited, status=1/FAILURE)
   Main PID: 989 (lightdm)
      Tasks: 13 (limit: 18328)
     Memory: 142.3M
        CPU: 3.811s
     CGroup: /system.slice/lightdm.service
             ├─ 989 /usr/bin/lightdm
             └─1029 /usr/lib/Xorg :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch

Aug 11 10:09:15 HP-Pavillon-de-Chloe systemd[1]: Starting Light Display Manager...
Aug 11 10:09:16 HP-Pavillon-de-Chloe lightdm[1151]: pam_unix(lightdm-greeter:session): session opened for user lightdm(uid=969) by (uid=0)
Aug 11 10:09:20 HP-Pavillon-de-Chloe lightdm[1236]: gkr-pam: unable to locate daemon control file
Aug 11 10:09:20 HP-Pavillon-de-Chloe lightdm[1236]: gkr-pam: stashed password to try later in open session
Aug 11 10:09:20 HP-Pavillon-de-Chloe lightdm[1236]: pam_unix(lightdm:session): session opened for user moreowo(uid=1000) by moreowo(uid=0)
Aug 11 10:09:20 HP-Pavillon-de-Chloe lightdm[1236]: gkr-pam: unlocked login keyring
Aug 11 10:09:45 HP-Pavillon-de-Chloe systemd[1]: Started Light Display Manager.

If you prefer sddm, you need to disable lightdm and enable sddm

sudo systemctl disable lightdm
sudo systemctl enable sddm

then reboot.

If you want to configure lightdm-slick-greeter, then you need to look at the first post of this Topic


1 Like

I’ve tried doing that, but then nothing would show up and i would need to hold Ctrl+Alt+F2 while bootup in order to have sddm. otherwise, i was stuck and i had to force reboot my computer (you can’t turn it off by clicking on the power button, idk why it’s dumb)

It sounds like sddm is launched on tty2 instead of tty1. Can you post the contents of sddm’s config file (/etc/sddm.conf)?

Pay attention to the MinimumVT= option under X11 section. Is it set to 2?


I had to create it by hand as it wasn’t created. Should i add this ?


I just went through the Arch Wiki. That setting is no longer available.

The fact that you have to switch to tty2 to see sddm means that something else is running in tty1 - most probably lightdm (since you have it installed).

If you don’t plan on using lightdm, just uninstall it. And then make sure that sddm is enabled. According to Arch Wiki, sddm should work out of the box.

I’ve uninstalled lightdm and enabled sddm and now, i can’t loggin in any tty. It’s even harder for testing as the window to change tty is like, 10s (during cleaning of passed forced shutdown). I’ve tried 1 2 & 3 and neither of them are working.

If you’ve enabled the service, it should launch at boot. If it doesn’t, it might have something to do with the graphics drivers. Are you using nvidia? If the nvidia drivers are loaded after your display manager, you will end up with a black screen and nothing else. To prevent this, you need early KMS, which ensures that the nvidia kernel module is loaded at the earliest possible occasion.

No, my laptop is under AMD. I have the plymouth animation and then, it ends and it just shows me what was previously on my screen before the animation.

The HP logo?

Are you able to access your system at all? If you can, find out what systemctl get-default returns.